Bug 98606 - aumix-X11-2.8-1 coredumps
aumix-X11-2.8-1 coredumps
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: aumix (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
: 98605 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-04 15:16 EDT by Jonathan Kamens
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version: 2.8-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-15 00:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-07-04 15:16:33 EDT
If I run aumix-X11 with aumix-X11-2.8-1 installed, it prints the following
errors and then crashes with a segmentation fault.  Note that I also have
aumix-2.8-4 installed; the mismatch may have something to do with the problem,
but there isn't a newer aumix-X11 in Rawhide.


(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 725
(gtk_signal_connect): assertion `GTK_IS_OBJECT (object)' failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtkaccelgroup.c: line 187
(gtk_accel_group_attach): assertion `GTK_IS_OBJECT (object)' failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 725
(gtk_signal_connect): assertion `GTK_IS_OBJECT (object)' failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 725
(gtk_signal_connect): assertion `GTK_IS_OBJECT (object)' failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 725
(gtk_signal_connect): assertion `GTK_IS_OBJECT (object)' failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 725
(gtk_signal_connect): assertion `GTK_IS_OBJECT (object)' failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 725
(gtk_signal_connect): assertion `GTK_IS_OBJECT (object)' failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 725
(gtk_signal_connect): assertion `GTK_IS_OBJECT (object)' failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 433
(gtk_signal_lookup): assertion `gtk_type_is_a (object_type, GTK_TYPE_OBJECT)'
failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: gtk_signal_connect_object(): could not find
signal "value_changed" in the `(null)' class ancestry

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 433
(gtk_signal_lookup): assertion `gtk_type_is_a (object_type, GTK_TYPE_OBJECT)'
failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: gtk_signal_connect_object(): could not find
signal "value_changed" in the `(null)' class ancestry

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 433
(gtk_signal_lookup): assertion `gtk_type_is_a (object_type, GTK_TYPE_OBJECT)'
failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: gtk_signal_connect_object(): could not find
signal "activate" in the `(null)' class ancestry

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 433
(gtk_signal_lookup): assertion `gtk_type_is_a (object_type, GTK_TYPE_OBJECT)'
failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: gtk_signal_connect_object(): could not find
signal "value_changed" in the `(null)' class ancestry

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 433
(gtk_signal_lookup): assertion `gtk_type_is_a (object_type, GTK_TYPE_OBJECT)'
failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: gtk_signal_connect_object(): could not find
signal "value_changed" in the `(null)' class ancestry

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-CRITICAL **: file gtksignal.c: line 433
(gtk_signal_lookup): assertion `gtk_type_is_a (object_type, GTK_TYPE_OBJECT)'
failed.

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: gtk_signal_connect_object(): could not find
signal "activate" in the `(null)' class ancestry

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'

(aumix-X11:17914): Gtk-WARNING **: invalid cast from `(unknown)' to `(unknown)'
Comment 1 Sammy 2003-07-07 15:58:58 EDT
I can confirm this 
Comment 2 Mike A. Harris 2003-07-15 00:40:03 EDT
*** Bug 98605 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2003-07-15 00:45:35 EDT
This seems to be caused because the -X11 subpackage was dropped in newer builds
however the aumix-X11 subpackage has a "Requires: aumix = %{version}", so if you
have aumix-2.7 and aumix-X11-2.7 installed and try to upgrade, the latter
package requires aumix 2.7 to be installed, but since there's no new
aumix-X11-2.8 package, the 2.7 package remains, and thus continues to require
aumix-2.7 still.

The short term fix is to manually uninstall aumix-X11 prior to upgrading to
version 2.8.  For the long term, I have added a conditionalized Obsoletes
line to the 2.8-5 package, which will be added to rawhide soon.  For builds
with aumix-X11 disabled, the "aumix" package will Obsolete any aumix-X11
packages currently installed, which will have the effect of upgrades working
as expected.

Thanks for the report.
Comment 4 Mike A. Harris 2003-07-15 00:46:43 EDT
Additional note for others:  2.8-5 has been rebuilt as 2.8-5.EL for
Red Hat Enterprise Linux development in the current developmental stream.

Note You need to log in before you can comment on or make changes to this bug.