Bug 986375 - screen corruption with kernel-3.11.0-0.rc1.git1.2.fc20.x86_64 [and kernel-3.10.2-301.fc19.x86_64]
screen corruption with kernel-3.11.0-0.rc1.git1.2.fc20.x86_64 [and kernel-3.1...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 11:25 EDT by Satish Balay
Modified: 2013-09-18 17:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 17:05:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a snapshot of one of the stages of corrupted screen (2.24 MB, image/png)
2013-07-19 11:25 EDT, Satish Balay
no flags Details

  None (edit)
Description Satish Balay 2013-07-19 11:25:43 EDT
Created attachment 775855 [details]
a snapshot of one of the stages of corrupted screen

Description of problem:

After suspend/resume - the gnome-shell session screen would be corrupted

Version-Release number of selected component (if applicable):

kernel-3.11.0-0.rc1.git1.2.fc20.x86_64 installed on fedora19

How reproducible:

I didn't notice it on the first [or second?] suspend/resume but happened consistantly after subsequent suspend/resumes

Steps to Reproduce:
1. F19 latest updates [upgraded from f18]
2. install kernel-3.11.0-0.rc1.git1.2.fc20.x86_64 rawhide-nodebug repo
3. login to gnome-shell and  suspend resume multiple times

Actual results:

continuously corrupted screen [with some flickering]

Expected results:

No screen corruption

Additional info:

Got a bunch of messages of the following type during screen corruption.

Jul 18 11:01:50 asterix /etc/gdm/Xsession[968]: (gnome-shell:1229): Clutter-WARNING **: The required ID of 3028022 does not refer to an existing actor; this usually implies that the pick() of an actor is not correctly implemented or that there is an error in the glReadPixels() implementation of the GL driver.
Jul 18 11:01:53 asterix /etc/gdm/Xsession[968]: (gnome-shell:1229): Clutter-WARNING **: The required ID of 13421772 does not refer to an existing actor; this usually implies that the pick() of a

I could recover by going to the overview mode [by hitting 'activities'] a few times - and then restarting gnome-shell [alt-f2 r]
Comment 1 Satish Balay 2013-07-19 11:27:56 EDT
Should have mentioned: This is on a thinkpad T420s with:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

And I do not see this issue with 3.9.9-302.fc19.x86_64 [so reverting back now]
Comment 2 Satish Balay 2013-07-23 22:07:18 EDT
kernel-3.10.2-301.fc19.x86_64 appears to have this issue. So changing rawhide -> f19

There was a message in /var/log/messages when this happened - but I'm not sure if its related. [as I see the same message from previous kernel-3.9 aswell.

[root@asterix ~]# egrep "(drm:i915_hangcheck_hung|Linux version)" /var/log/messages
Jul 23 01:24:06 asterix kernel: [    0.000000] Linux version 3.9.9-302.fc19.x86_64 (mockbuild@bkernel01.phx2.fedoraproject.org) (gcc version 4.8.1 20130603 (Red Hat 4.8.1-1) (GCC) ) #1 SMP Sat Jul 6 13:41:07 UTC 2013
Jul 23 01:32:32 asterix kernel: [  517.359660] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 23 02:05:47 asterix kernel: [ 2512.670224] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 23 02:08:46 asterix kernel: [ 2691.687462] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 23 02:33:22 asterix kernel: [ 4167.926745] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 23 02:37:29 asterix kernel: [ 4414.979084] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 23 08:55:55 asterix kernel: [    0.000000] Linux version 3.9.9-302.fc19.x86_64 (mockbuild@bkernel01.phx2.fedoraproject.org) (gcc version 4.8.1 20130603 (Red Hat 4.8.1-1) (GCC) ) #1 SMP Sat Jul 6 13:41:07 UTC 2013
Jul 23 11:25:17 asterix kernel: [    0.000000] Linux version 3.10.2-301.fc19.x86_64 (mockbuild@bkernel01.phx2.fedoraproject.org) (gcc version 4.8.1 20130603 (Red Hat 4.8.1-1) (GCC) ) #1 SMP Mon Jul 22 20:04:56 UTC 2013
Jul 23 13:26:37 asterix kernel: [ 7302.921759] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 23 20:47:46 asterix kernel: [27744.270469] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 23 20:48:38 asterix kernel: [27796.282986] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Comment 3 Satish Balay 2013-07-24 14:48:19 EDT
Perhaps this issue is related to bug 966441

Today my suspend resumes did not cause corruption. But I noticed constant messages of type [reported in bug 966441]

Jul 24 13:30:17 asterix /etc/gdm/Xsession[978]: Window manager warning: Log level 8: meta_screen_get_monitor_geometry: assertion `monitor >= 0 && monitor < screen->n_monitor_infos' failed

So I restarted gnome-shell [alt-f2 r] - and I'm now seeing this screen corruption again after suspend resume.
Comment 4 Satish Balay 2013-07-25 18:15:12 EDT
tried kernel-3.11.0-0.rc2.git3.2.fc20.x86_64 - and I haven't seen corruption yet. [with about 20 suspend/resume cycles]. So far so good.

And then I noticed:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=058ca4a22ebf22ea1cbedd6cc0340ed1e2e94ee1

>>>
correctly restore fences, fixes the "my screen is all messed up after resume" regression introduced in the final 3.10 pull request
<<<

So that must be the commit that fixed this issue. Presumably the fix will find its way into 3.10 stable
Comment 5 Dave P 2013-08-18 04:48:09 EDT
Bug 990565 may relate. Update 29 July started the problem. Reverting to kernel 399 302 still works.
Comment 6 Dave P 2013-08-20 05:57:06 EDT
Update to kernel 3.10.7 has no effect.
Comment 7 Josh Boyer 2013-09-18 16:32:05 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 8 Satish Balay 2013-09-18 17:05:04 EDT
per comment 4 - I haven't seen this issue in kernel-3.11.0-0.rc2.git3.2.fc20.x86_64 and newer kernels.. [which I have been using since..]
Comment 9 Josh Boyer 2013-09-18 17:05:48 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.