Bug 990565 - Software update 29 July caused screen to be unreadable
Software update 29 July caused screen to be unreadable
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2013-07-31 09:11 EDT by Dave P
Modified: 2013-08-26 03:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-26 03:35:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave P 2013-07-31 09:11:58 EDT
Description of problem: Applied all updates (software update tool) on 29 July. Thereafter majority of windows text and icons are unreadable. 

Version-Release number of selected component (if applicable):
updated from  3.9.9-302.fc19.x86_64 to 3.10.3-300.fc19.x86-64

How reproducible:
Booted into latest kernel, screen shows windows, but majority of text illegible, even cli text does not show. 
Tried with KDE, same result.
http://www.flickr.com/photos/davepawson/9398487515/ shows an example.
Trying to use screenshot caused a problem to show in bug reporter. 

Steps to Reproduce:
1. Boot into newer kernel
2. Try to read text / use the machine. 
3.  #fail

Actual results:

Expected results:

Additional info:
Comment 1 Rex Dieter 2013-07-31 11:01:06 EDT
Probably need more detailed information to triage this properly.  Seems to be video driver related somehow.

Mind sharing the relevant content of your /var/log/yum.log for the day you mention?
Comment 2 Dave P 2013-07-31 11:14:22 EDT
See http://pastebin.com/GgrTNVmB
for yum log. 

Comment 3 Rex Dieter 2013-07-31 11:49:50 EDT
Boo, looks like it included the trifecta: kernel, mesa, xorg-x11-server , could be any one of those.

What video card/driver are you using?  probably best to triage to the driver in use to start.
Comment 4 Dave P 2013-08-01 02:55:19 EDT
How to find out the driver? Graphics card is ATI Radeon HD4770.
?Triage the driver? What's that / how please?

Comment 5 Dave P 2013-08-02 08:37:07 EDT
Further updates today. Yum log at http://pastebin.com/EkdVWkt7
Booted into new kernel, 3.10.4-300.fc19.x86_64

Problem remains. E.g. no text showing in command shell.
Comment 6 Dave P 2013-08-07 01:51:50 EDT
Further updates applied.
Yum log at http://pastebin.com/ZYm6PhxL

Still no text showing in a terminal window.
Comment 7 Dave P 2013-08-11 07:19:43 EDT
Should I start again with a new install of Fedora? Do you think that would work? Or do you think  this be fixed?
Comment 8 Dave P 2013-08-14 04:56:29 EDT
Updates applied 14 Aug. 
yum log http://pastebin.com/7agT2EkC

Still no characters visible in text window.
Comment 9 Dave P 2013-08-16 09:49:05 EDT
Since no reply from Fedora devs, I tried a little experiment.
New disk. New Fedora 19 download.
 Installed from DVD.
   Window text showed fine.
Updated from repos, half a gig of udpates.

Hey presto, no text visible.

My guess? Fedora 19, more recent versions, simply does not work
with  Graphics card is ATI Radeon HD4770

Which distro next?
Comment 10 Dave P 2013-08-20 05:58:48 EDT
Update to kernel 3.10.7 has no effect.
https://bugzilla.redhat.com/show_bug.cgi?id=986375 could be related,.
Comment 11 Dave P 2013-08-26 03:35:23 EDT
No response. My options are clear now. Thanks.

Note You need to log in before you can comment on or make changes to this bug.