Bug 98638 - lvm button missing from disk druid in text install
Summary: lvm button missing from disk druid in text install
Status: CLOSED DUPLICATE of bug 76310
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-06 12:25 UTC by Greg
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 18:56:57 UTC


Attachments (Terms of Use)

Description Greg 2003-07-06 12:25:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When booting off of either the RH9 retail cds or a boot disk image created 
with those cds and selecting the "linux text" installation, choosing to 
reinstall the system (I am reinstalling over a previous rh9 install), and then 
choosing to layout partitions manually with disk druid, there is no LVM button 
on the Disk Druid screen to allow LVM setup.  The only buttons available are: 
New, Edit, Delete, RAID, OK, and Back.  Using the same images and doing a 
graphical install, the LVM button appears.

Version-Release number of selected component (if applicable):
RH9 Pro retail cd and boot disk images

How reproducible:
Always

Steps to Reproduce:
1. boot rh9 retail cd or boot floppy, choose "linux text"
2. choose reinstall system, layout partitions manually
3. Disk Druid starts - button is missing
    

Actual Results:  I was able to create LVM partitions and raid partitions with 
LVM overlayed, but could not create the physical volumes, volume groups etc.  
Note: I was able to do all of the final setup from the command line once I 
rebooted the system after completing the install

Expected Results:  I should have been able to click an "LVM" button to allow 
to perform the setup required as I can in the graphical install.

Additional info:

Comment 1 Dax Kelson 2003-07-07 05:05:36 UTC
I've noticed the same problem. I was going to file a bug and found this one.

Comment 2 Greg 2003-07-08 23:37:39 UTC
I see now the Note on page 79 of the customization guide that says you can not 
create volume groups in text mode, you can only assign mount points to 
existing volumes.  This obviously refers to the lack of an LVM button - so I 
guess this would be better classifed as an enhancement request than a bug.  I 
would like to be able to do everything in a text install that I can do in a 
GUI install.

Comment 3 Jeremy Katz 2003-07-09 04:29:53 UTC

*** This bug has been marked as a duplicate of 76310 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:56:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.