Bug 986388 - ctrl-shift based combinations do not work as input-source-switch
ctrl-shift based combinations do not work as input-source-switch
Status: CLOSED DUPLICATE of bug 976068
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 12:12 EDT by Leonid Kanter
Modified: 2013-08-19 20:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 20:43:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2013-07-19 12:12:15 EDT
Description of problem:

Following key combinations do not work as input-source-switch:

'ctrl-shift'
'ctrl-shift-l'
'ctrl-shift-r'


Version-Release number of selected component (if applicable):

1.9.1-16.fc19

How reproducible:

always

Steps to Reproduce:
1. Add second keyboard layout
2. Run command gsettings set org.gnome.settings-daemon.peripherals.keyboard input-sources-switcher 'ctrl-shift'
3. Relogin to cinnamon

Actual results:

ctrl-shift doesn't work as layout switch

Expected results:

ctrl-shift should work as a layout switch because this combination exists in gsettings range org.gnome.settings-daemon.peripherals.keyboard input-sources-switcher

Additional info:

other arguments like caps or shift-caps are ok
Comment 1 Rui Matos 2013-08-13 12:16:50 EDT
The way these shortcuts are handled changed in 3.8.3. You need to have all of mutter, gnome-shell, gnome-settings-daemon and gnome-control-center >= 3.8.3 for it to work. Is that the case?
Comment 2 Leonid Kanter 2013-08-18 16:53:20 EDT
$ rpm -q gnome-shell control-center gnome-settings-daemon mutter
gnome-shell-3.8.4-2.fc19.x86_64
control-center-3.8.3-2.fc19.x86_64
gnome-settings-daemon-3.8.4-2.fc19.x86_64
mutter-3.8.4-1.fc19.x86_64


still unable to get ctrl-shift working
Comment 3 Rui Matos 2013-08-19 12:01:36 EDT
But are you actually running GNOME or is it some other desktop? This was initially filed against cinnamon.
Comment 4 Leonid Kanter 2013-08-19 16:03:54 EDT
This issue is related to Cinnamon only. No problem with GNOME.
Comment 5 Rui Matos 2013-08-19 20:43:05 EDT

*** This bug has been marked as a duplicate of bug 976068 ***

Note You need to log in before you can comment on or make changes to this bug.