Bug 976068 - Layout switching is broken
Layout switching is broken
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
: 986388 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 16:23 EDT by Artyom Kunyov
Modified: 2013-08-19 20:43 EDT (History)
11 users (show)

See Also:
Fixed In Version: cinnamon-1.9.1-16.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 987782 (view as bug list)
Environment:
Last Closed: 2013-08-02 04:00:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My settings, if it helps in any way (2.25 MB, image/png)
2013-06-19 16:23 EDT, Artyom Kunyov
no flags Details

  None (edit)
Description Artyom Kunyov 2013-06-19 16:23:13 EDT
Created attachment 763136 [details]
My settings, if it helps in any way

Description of problem:
Starting with version 3.8.3 of gnome-settings-daemon, I can't switch layouts anymore. I've set up switching by Alt+Shift in GNOME System Settings (since there's no such option in Cinnamon Control Center), and it doesn't work now. Nothing happens when I press the combination. There's an interesting exception, though: switching works in GDM and GNOME Screensaver. It also works when I switch by mouse in system tray.

Version-Release number of selected component (if applicable):
Got broken by this update: 
https://admin.fedoraproject.org/updates/FEDORA-2013-10587/gnome-shell-3.8.3-1.fc19,mutter-3.8.3-1.fc19,gnome-settings-daemon-3.8.3-2.fc19,control-center-3.8.3-1.fc19?_csrf_token=f2030806c864bcd299b8bfe3874db2d6a0dc1f57
Worked fine before this update. There was a delay, but it was better than nothing.

How reproducible:
Always. I tried clearing settings, it doesn't help.

Steps to Reproduce:
1. Install Cinnamon.
2. Set two different layouts in GNOME Control Center (Region and Language)
3. Set Alt+Shift as a switching combination (Modifiers-only switch to next source).

Sorry for my English.
Comment 1 leigh scott 2013-07-10 14:18:51 EDT
This was removed from gnome-settings-daemon-3.8.3

https://git.gnome.org/browse/gnome-settings-daemon/commit/?h=gnome-3-8&id=ec7b1ec37e9755c304a51faea876c31c50df42f9

I have submitted a cinnamon (cinnamon-1.9.1-14.fc19) build to return this function.
Comment 2 Fedora Update System 2013-07-10 15:36:18 EDT
cinnamon-1.9.1-15.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.9.1-15.fc19
Comment 3 Fedora Update System 2013-07-11 23:19:24 EDT
Package cinnamon-1.9.1-15.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-1.9.1-15.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12859/cinnamon-1.9.1-15.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-12 09:01:36 EDT
cinnamon-1.9.1-16.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.9.1-16.fc19
Comment 5 Fedora Update System 2013-07-13 23:32:12 EDT
cinnamon-1.9.1-16.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Ilya 2013-07-18 02:31:59 EDT
update cinnamon to ver 1.9.1-15.fc19 and then 1.9.1-16.fc19. "Still dead". May be i have to do something else?
Comment 7 Ilya 2013-07-18 14:42:37 EDT
update 1.9.1-15.fc19 - same result, layout doesn't switching. Please, fix it!
Comment 8 Ilya 2013-07-18 14:44:13 EDT
sorry, i mean 1.9.1-17.fc19
Comment 9 Artyom Kunyov 2013-08-02 01:30:57 EDT
Just tried on a clean install - the bug is still not fixed in 1.9.1-19.fc19 build. Reopening.
Comment 10 leigh scott 2013-08-02 04:03:08 EDT
(In reply to Artyom Kunyov from comment #9)
> Just tried on a clean install - the bug is still not fixed in 1.9.1-19.fc19
> build. Reopening.

Without any error logs I consider this issue closed, It works for me!
Comment 11 Ilya 2013-08-02 04:05:32 EDT
(In reply to leigh scott from comment #10)
> (In reply to Artyom Kunyov from comment #9)
> > Just tried on a clean install - the bug is still not fixed in 1.9.1-19.fc19
> > build. Reopening.
> 
> Without any error logs I consider this issue closed, It works for me!

but it doesn't! nice way to close bugs, just say "it works for me". Nice. Are you really developer?
Comment 12 leigh scott 2013-08-02 04:10:01 EDT
If you wish to try cinnamon next

http://repos.fedorapeople.org/repos/leigh123linux/Cinnamon/


This is really a gnome-settings-daemon issue not cinnamon, the gnome devs (stupid wankers) shouldn't have remove a feature from a stable release (fucking morons).
Now cinnamon-settings-daemon is in the repo I have no intention of fixing their fuck ups.

Sorry if my language offends.
Comment 13 leigh scott 2013-08-02 04:14:13 EDT
(In reply to Ilya from comment #11)
> (In reply to leigh scott from comment #10)
> > (In reply to Artyom Kunyov from comment #9)
> > > Just tried on a clean install - the bug is still not fixed in 1.9.1-19.fc19
> > > build. Reopening.
> > 
> > Without any error logs I consider this issue closed, It works for me!
> 
> but it doesn't! nice way to close bugs, just say "it works for me".

Don't blame me for gnomes mistakes 

https://bugzilla.redhat.com/show_bug.cgi?id=976068#c12

I've done my best to fix this and it works fine for me.


> Are you really developer?

No I'm just a packager :-)
Comment 14 Ilya 2013-08-02 04:16:21 EDT
(In reply to leigh scott from comment #13)
> https://bugzilla.redhat.com/show_bug.cgi?id=976068#c12
> I've done my best to fix this and it works fine for me.


ok, may be you have any ideas about something like temporary solution? How it can works for you, but doesn't for me?
Comment 15 leigh scott 2013-08-02 04:33:17 EDT
(In reply to Ilya from comment #14)
> (In reply to leigh scott from comment #13)
> > https://bugzilla.redhat.com/show_bug.cgi?id=976068#c12
> > I've done my best to fix this and it works fine for me.
> 
> 
> ok, may be you have any ideas about something like temporary solution? How
> it can works for you, but doesn't for me?

Ok post any errors found in

~/.xsession-errors

related to input switching, if there's nothing there try debugging gnome-settings-daemon.

to debug run (yes you do need to kill twice as once isn't enough)


killall gnome-settings-daemon
killall gnome-settings-daemon
/usr/libexec/gnome-settings-daemon --debug
Comment 16 Ilya 2013-08-02 15:19:38 EDT
~/.xsession-errors empty.

Try to stop settings daemon and cinnamon crashes ("Something went wrong" and logout button).
Comment 17 Lukas Marek 2013-08-07 05:29:20 EDT
There is probably some conflict in configuration. If the alt+shift does not work for you try:

# gnome-control-center keyboard

Shortcuts -> Typing -> Modifiers-only... -> Disabled
Comment 18 Ilya 2013-08-07 05:32:00 EDT
and now we disabled keyboard layout switching. How it can help? It doesn't work anyway, so why disable? :)
Comment 19 leigh scott 2013-08-15 06:44:08 EDT
Reassigned to gnome-settings-daemon as they removed the code from a stable release.
Comment 20 Rui Matos 2013-08-16 12:10:31 EDT
Wow, some classy comments here. I love you too!

gnome-settings-daemon is not random-project-settings-daemon, feel free to re-open if there's any problem under GNOME.
Comment 21 Ilya 2013-08-16 12:13:07 EDT
OMG. "screw you guys i'm going home" (c)
Comment 22 Rui Matos 2013-08-19 20:43:05 EDT
*** Bug 986388 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.