Bug 986484 - [abrt] libreoffice-core-4.1.0.1-8.fc19: getRequestURI: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-4.1.0.1-8.fc19: getRequestURI: Process /usr/lib64/lib...
Status: CLOSED DUPLICATE of bug 980082
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:a74e8892cc17c504dba39c132f9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 17:48 EDT by Stephen Haffly
Modified: 2013-07-22 15:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 07:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (90.63 KB, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: core_backtrace (2.84 KB, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: dso_list (20.06 KB, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: environ (1.77 KB, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: maps (94.03 KB, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: open_fds (576 bytes, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: proc_pid_status (950 bytes, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details
File: var_log_messages (347 bytes, text/plain)
2013-07-19 17:48 EDT, Stephen Haffly
no flags Details

  None (edit)
Description Stephen Haffly 2013-07-19 17:48:07 EDT
Description of problem:
I was trying to paste information from my cell phone carrier's web page detailed billing (Verizon). When I pasted, the program crashed.

Steps:

1. Open Verizon page with cell phone information.
2. Open LibreOffice Writer to a blank page.
3. Select information from web page.
4. Go to blank document and attempt to paste selected information
5. Program crashes.

Version-Release number of selected component:
libreoffice-core-4.1.0.1-8.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin -writer --splash-pipe=5
crash_function: getRequestURI
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 getRequestURI at /usr/src/debug/libreoffice-4.1.0.1/ucb/source/ucp/webdav-neon/DAVResourceAccess.cxx:1107
 #1 webdav_ucp::DAVResourceAccess::PROPFIND at /usr/src/debug/libreoffice-4.1.0.1/ucb/source/ucp/webdav-neon/DAVResourceAccess.cxx:239
 #2 webdav_ucp::Content::getResourceType at /usr/src/debug/libreoffice-4.1.0.1/ucb/source/ucp/webdav-neon/webdavcontent.cxx:3118
 #3 getResourceType at /usr/src/debug/libreoffice-4.1.0.1/ucb/source/ucp/webdav-neon/webdavcontent.cxx:3167
 #4 webdav_ucp::Content::supportsExclusiveWriteLock at /usr/src/debug/libreoffice-4.1.0.1/ucb/source/ucp/webdav-neon/webdavcontent.cxx:2670
 #5 webdav_ucp::Content::execute at /usr/src/debug/libreoffice-4.1.0.1/ucb/source/ucp/webdav-neon/webdavcontent.cxx:505
 #6 ucbhelper::Content_Impl::executeCommand at /usr/src/debug/libreoffice-4.1.0.1/ucbhelper/source/client/content.cxx:1347
 #7 ucbhelper::Content::openStream at /usr/src/debug/libreoffice-4.1.0.1/ucbhelper/source/client/content.cxx:773
 #8 comphelper::MediaDescriptor::impl_openStreamWithURL at /usr/src/debug/libreoffice-4.1.0.1/comphelper/source/misc/mediadescriptor.cxx:675
 #9 comphelper::MediaDescriptor::impl_addInputStream at /usr/src/debug/libreoffice-4.1.0.1/comphelper/source/misc/mediadescriptor.cxx:474
Comment 1 Stephen Haffly 2013-07-19 17:48:12 EDT
Created attachment 775981 [details]
File: backtrace
Comment 2 Stephen Haffly 2013-07-19 17:48:15 EDT
Created attachment 775982 [details]
File: cgroup
Comment 3 Stephen Haffly 2013-07-19 17:48:19 EDT
Created attachment 775983 [details]
File: core_backtrace
Comment 4 Stephen Haffly 2013-07-19 17:48:22 EDT
Created attachment 775984 [details]
File: dso_list
Comment 5 Stephen Haffly 2013-07-19 17:48:26 EDT
Created attachment 775985 [details]
File: environ
Comment 6 Stephen Haffly 2013-07-19 17:48:29 EDT
Created attachment 775986 [details]
File: limits
Comment 7 Stephen Haffly 2013-07-19 17:48:33 EDT
Created attachment 775987 [details]
File: maps
Comment 8 Stephen Haffly 2013-07-19 17:48:36 EDT
Created attachment 775988 [details]
File: open_fds
Comment 9 Stephen Haffly 2013-07-19 17:48:39 EDT
Created attachment 775989 [details]
File: proc_pid_status
Comment 10 Stephen Haffly 2013-07-19 17:48:43 EDT
Created attachment 775990 [details]
File: var_log_messages
Comment 11 David Tardon 2013-07-22 03:54:08 EDT
(In reply to Stephen Haffly from comment #0)
> 1. Open Verizon page with cell phone information.

Which is ...? (It does not crash with randomly selected pages from verizon.com)
Comment 12 Stephan Bergmann 2013-07-22 07:00:54 EDT

*** This bug has been marked as a duplicate of bug 980082 ***
Comment 13 Stephen Haffly 2013-07-22 15:28:43 EDT
(In reply to David Tardon from comment #11)
> (In reply to Stephen Haffly from comment #0)
> > 1. Open Verizon page with cell phone information.
> 
> Which is ...? (It does not crash with randomly selected pages from
> verizon.com)

It was a page of my monthly statement. I had highlighted a section pertaining to one of the lines on the account and was trying to paste that information into a new LibreOffice Writer document. Since it is personal account information, I can't post the exact link since that would require login to my Verizon account.

I realize that this bug report was closed and marked as a duplicate, but I wanted to answer your information request.

Note You need to log in before you can comment on or make changes to this bug.