Bug 986562 - SELinux is preventing /opt/google/chrome/chrome from 'open' accesses on the file /home/zz/libpeerconnection.log.
SELinux is preventing /opt/google/chrome/chrome from 'open' accesses on the f...
Status: CLOSED DUPLICATE of bug 960792
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d1e61f6335d4a554c3ed77c0b6a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-20 13:08 EDT by Old Uncle
Modified: 2013-07-21 07:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-21 07:14:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Old Uncle 2013-07-20 13:08:34 EDT
Description of problem:
Just opened newly installed Chrome
SELinux is preventing /opt/google/chrome/chrome from 'open' accesses on the file /home/zz/libpeerconnection.log.

*****  Plugin restorecon (66.7 confidence) suggests  *************************

If you want to fix the label. 
/home/zz/libpeerconnection.log default label should be user_home_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /home/zz/libpeerconnection.log

*****  Plugin chrome (33.6 confidence) suggests  *****************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Chrome plugins.
Do
# setsebool unconfined_chrome_sandbox_transition 0

*****  Plugin catchall (1.16 confidence) suggests  ***************************

If you believe that chrome should be allowed open access on the libpeerconnection.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep chrome /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /home/zz/libpeerconnection.log [ file ]
Source                        chrome
Source Path                   /opt/google/chrome/chrome
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           google-chrome-stable-28.0.1500.71-209842.i386
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-63.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-302.fc19.i686 #1 SMP Sat Jul
                              6 14:02:05 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-07-20 21:07:10 GET
Last Seen                     2013-07-20 21:07:10 GET
Local ID                      ce91b27b-e398-4e8d-a10d-57b46b8fff36

Raw Audit Messages
type=AVC msg=audit(1374340030.0:938): avc:  denied  { open } for  pid=13119 comm="chrome" path="/home/zz/libpeerconnection.log" dev="dm-0" ino=2355668 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1374340030.0:938): arch=i386 syscall=open success=no exit=EACCES a0=b7da71ec a1=8441 a2=1b6 a3=b7dcbb00 items=0 ppid=0 pid=13119 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=11 tty=(none) comm=chrome exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: chrome,chrome_sandbox_t,user_home_dir_t,file,open

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-302.fc19.i686
type:           libreport

Potential duplicate: bug 979640
Comment 1 Daniel Walsh 2013-07-21 07:14:10 EDT

*** This bug has been marked as a duplicate of bug 960792 ***

Note You need to log in before you can comment on or make changes to this bug.