Bug 98664 - Chinese Font Problem
Chinese Font Problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ttfonts-zh_TW (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
Bill Huang
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-07 03:27 EDT by percy
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-05 01:34:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Google in Traditional Chinese (78.75 KB, image/png)
2003-07-07 03:40 EDT, percy
no flags Details
Bug 84034 Page (124.79 KB, image/png)
2003-07-07 03:41 EDT, percy
no flags Details

  None (edit)
Description percy 2003-07-07 03:27:35 EDT
With the default RH9 installation, the display of big5 Chinese characters looks
 very weired in many occasions in mozilla. Some characters are in normal size
while some are relatively small and so small that they may become illegible to
read. But after highlighting the text, it improved a bit but still not very
acceptable in my opinion.

I came across bug 84034 about anti alias font but don't know if they are
related. Strangely enough, when I got to this bug's page, I found a line of the
text there appears completely blackened - highlighting it will make it legible
again.

Will try to attach some screenshots for illustration.
Comment 1 percy 2003-07-07 03:40:08 EDT
Created attachment 92771 [details]
Google in Traditional Chinese

Google in Traditional Chinese (http://www.google.com/intl/zh-TW/)
Comment 3 Leon Ho 2003-07-07 20:23:18 EDT
Thanks for your report. Your bug report has two folds:

- Are you using en_US.UTF-8? Because the site are in UTF-8, so mozilla does not
know what font should be favor in, hence it is getting font from different fonts
(very simliar reason to bug 84034). Changing the preferenced font or try to use
zh_TW.Big5 should help.

- texts appear to be blackened. Please see bug 89773. It is a bug on Xft which
is fixed and awaiting for rebuild into our package.

I am putting this as duplicate to 89773 for now. 

*** This bug has been marked as a duplicate of 89773 ***
Comment 4 percy 2003-07-08 12:55:42 EDT
Thanks for hinting me about the xft problem.

As for the google page - you are correct about it, it's UTF-8 encoded. But still
changing the Unicode font preference didn't help. No matter what font I chose,
the display still looked as bad as before.

One thing that I feel strange is the behavior of Mozilla to pick up random fonts
for different characters. I mean I only specified one font for all the Unicode
font choices in the font preference - how can Mozilla got more than one font to
display at the same line of display? I really cannot understand why. 

There must be a bug somewhere - perhaps it's a mozilla problem?
Comment 5 Leon Ho 2003-07-09 01:36:57 EDT
That's called font fallback, if there are no glyphs available for the font you have 
chosen, it will use next font which available. 
 
- Have you tried to use zh_TW.Big5? If you use any locale with zh_TW then you 
will have chinese font in higher priority on the font list so it will use it first 
 
- What font did you choose? Please try and choose AR PL Mingti2L Big5 
Comment 6 percy 2003-07-19 11:26:33 EDT
I have tried every possible BIG5 font including AR PL Mingti2L Big5 - but still
the problem didn't go away.

The good news is when zh_TW.Big5 locale was used, the problem was gone. But I
usually do not want to do this for several reasons - 1. Switching locale is
troublesome enough; 2. I am not used to Chinese translation of the Mozilla menu;
3. The fonts used look ugly to me even for English!

I don't know whether the font fallback is a problem or not. All I know is my
English M$ XP can display the google page problem without any font problem in
Mozilla.
Comment 7 Leon Ho 2003-08-05 01:34:42 EDT
Yes it is about font fallback. About the changing font does not effect the font
usage - I have posted bug 99483 to confirm this with mozilla maintainer.

M$ Win XP can able to display without any problem because they bought many
unicode font and most of them covers one script range in one font. So you cannot
see any problem. If you can have a breif test by using their fonts, then it
should work.

Try Severn beta 1, it should be a bit better because one of the font
(ttfonts-ja) covers more chars in asian script range.

Thanks for your report. We can continue the conversation on bug 99483
Comment 8 percy 2003-08-06 13:51:21 EDT
OK, perhaps I will try Severn later.

Actually, I have also tried using Knoppix 3.2 - fonts look perfectly alright.
Perhaps I will take some time to take a look of what they used for their fonts.

BTW, the bug 99483 page says I am not authorzied to access it. :< Is there any
way that I can get access to it?
Comment 9 Leon Ho 2003-08-06 20:57:38 EDT
That would be great. 
 
I added you to the cc: list. you should able to access the bug for now. 

Note You need to log in before you can comment on or make changes to this bug.