Bug 986670 - ALPS Touchpad Not recognized by kernel - Lenvo w510 - ALPS
ALPS Touchpad Not recognized by kernel - Lenvo w510 - ALPS
Status: CLOSED DUPLICATE of bug 953211
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 08:31 EDT by jchinyou.public
Modified: 2013-10-15 18:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 15:02:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs Gather to help TShoot (115.57 KB, application/gzip)
2013-07-21 08:31 EDT, jchinyou.public
no flags Details

  None (edit)
Description jchinyou.public 2013-07-21 08:31:59 EDT
Created attachment 776444 [details]
Logs Gather to help TShoot

Description of problem:

I've just installed Fedora 19 on my Lenovo w510. The touchpad doesn't respond/work at all. The mouse buttons also does not respond. I've done some TShoot looking at previous bugs and this appears to be a kernel driver issue.

Errors in /var/log/message:
Jul 21 08:05:34 jchinyou-linux kernel: [    1.716005] psmouse serio1: alps: Unknown ALPS touchpad: E7=10 00 64, EC=10 00 64

The device fails to appear in /proc/bus/input/devices list (attached)


Version-Release number of selected component (if applicable):

3.9.9-302.fc19.x86_64


How reproducible:

This should be easy to reproduce, unfortunately, I only have one w510 at the moment. 


Additional info:

Please let me know if I can help gather any info to help fixing this one.
Comment 1 Josh Boyer 2013-07-22 15:02:14 EDT

*** This bug has been marked as a duplicate of bug 953211 ***
Comment 2 Arnaud Lacombe 2013-10-15 18:16:48 EDT
@OP: could you post the output of:

% dmesg | grep psmouse

I have the same output as you, but my touchpad is recognized as an "ETPS/2 Elantech Touchpad", and is not working either, cf comment #27 of bug 953211.

@Josh: this issue might not be a duplicate of bug 953211 after all.
Comment 3 Arnaud Lacombe 2013-10-15 18:20:00 EDT
ok, I missed the log attached. I checked the dmesg, you issue seems to be yet different than mine, as in my case, the touchpad shows up in `/proc/bus/input/devices':

I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio2/input0
S: Sysfs=/devices/platform/i8042/serio2/input/input7
U: Uniq=
H: Handlers=mouse0 event7 
B: PROP=5
B: EV=b
B: KEY=e420 10000 0 0 0 0
B: ABS=661800011000003
Comment 4 Arnaud Lacombe 2013-10-15 18:36:26 EDT
Bug 848270 provided me hints with what was wrong with the touchpad, and I got it to work.

Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.