Bug 953211 - input/alps: ALPS touchpad (Dolphin v2) recognized as PS/2 Mouse instead of touchpad
Summary: input/alps: ALPS touchpad (Dolphin v2) recognized as PS/2 Mouse instead of to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 959489 986670 1008081 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-17 15:56 UTC by Stanislav Datskevich
Modified: 2014-10-25 16:03 UTC (History)
25 users (show)

Fixed In Version: kernel-3.12.7-300.fc20
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-14 08:33:55 UTC
Type: Bug


Attachments (Terms of Use)
Gnome3 settings screenshot showing touchpad (32.16 KB, image/png)
2013-09-20 14:19 UTC, Justin Clift
no flags Details
[WIP 3/3] Input: ALPS - Add "Dolphin V2" touchpad support (4.67 KB, patch)
2013-09-20 16:23 UTC, Niels de Vos
no flags Details | Diff
Most recent posted patch that adds support for this ALPS model (22.35 KB, patch)
2013-10-15 07:13 UTC, Niels de Vos
no flags Details | Diff
Screenshot of KDE settings for Vertical Scrolling, from Pentarh Udi (41.61 KB, image/jpeg)
2013-10-15 14:44 UTC, Justin Clift
no flags Details

Description Stanislav Datskevich 2013-04-17 15:56:51 UTC
Description of problem:
Dell Vostro 3360 touchpad is recognized by Fedora as PS/2 mouse.
Bug 812111 describes similiar problem, but with GlidePoint. In Vostro 3360, as far as I know, touchpad model is Dolphin V2.

Version-Release number of selected component (if applicable):
Fedora 18, kernel 3.8.7-201.fc18.x86_64

How reproducible:
Install Fedora 18 in notebook with Dolphin v2 touchpad. Try to use sidescroll or two-fingers scroll. xinput command will show your touchpad named "PS/2 Generic Mouse".

Steps to Reproduce:
1. Use Fedora 18 in notebook with Dolphin v2 touchpad.
2. Run 'xinput'.
3. In output you will see 'PS/2 Generic Mouse'.
  
Actual results:
Touchpad recognized as mouse, so touchpad features like sidescroll, twofingers scroll is unavailable.

Expected results:
Touchpad recognized as touchpad.

Additional info:

Comment 1 einheit47 2013-05-08 02:08:57 UTC
Still doesn't work in 3.8.11-200.fc18.x86_64

For what it's worth, this touchpad works in Ubuntu with the patch found here: https://www.dahetral.com/public-download

With it, it gets recognized as an Alps GlidePoint. It is not perfect, but it works well enough- at least two-finger scroll functions.

Comment 2 Stanislav Datskevich 2013-05-08 14:17:12 UTC
I confirm that dkms module from https://www.dahetral.com/public-download works fine on Vostro 3360.
But before installing that module you need to recompile kernel with psmouse as module (config option CONFIG_MOUSE_PS2=m).

Maybe Fedora kernel maintainers will include this patch to default Fedora kernel?

Comment 3 Josh Boyer 2013-05-08 17:12:34 UTC
We'll look upstream to see what patches are coming for this particular touchpad type.

Comment 4 Josh Boyer 2013-07-02 15:21:25 UTC
*** Bug 959489 has been marked as a duplicate of this bug. ***

Comment 5 Igor Gnatenko 2013-07-05 17:25:13 UTC
@Murzik2142 speaks this patch http://thread.gmane.org/gmane.linux.kernel.input/29273/focus=29275 works for him.

Comment 6 einheit47 2013-07-10 20:03:56 UTC
I am confirming that this issue is still not resolved in the Fedora 19 default installation.

Comment 7 Josh Boyer 2013-07-22 19:02:14 UTC
*** Bug 986670 has been marked as a duplicate of this bug. ***

Comment 8 Justin Clift 2013-09-11 18:13:36 UTC
As a data point, the Dell Inspiron 17R Special Edition also has this type of touchpad and experiences the same problem.  Touchpad seen as PS/2 mouse only, and also keeps on picking up spurious mouse inputs when my palms are typing anywhere near it. (very annoying)

Comment 9 Justin Clift 2013-09-11 19:16:13 UTC
Additional data point, I tried to compile the ALPS touchpoint tarball using dkms on F19 (https://www.dahetral.com/public-download/alps-psmouse-dlkm-for-3-2-and-3-5/at_download/file), but compilation always fails.

This isn't an area of stuff I have any real knowledge of, so no idea why. :(

  # dkms build -m psmouse-alps -v 1.3

  Kernel preparation unnecessary for this kernel.  Skipping...

  Building module:
  cleaning build area...
  make KERNELRELEASE=3.10.10-200.fc19.x86_64 -C /lib/modules/3.10.10-200.fc19.x86_64/build M=/var/lib/dkms/psmouse-alps/1.3/build.....
  Error!  Build of psmouse-alps.ko failed for: 3.10.10-200.fc19.x86_64 (x86_64)
  Consult the make.log in the build directory
  /var/lib/dkms/psmouse-alps/1.3/build/ for more information.

  # cat /var/lib/dkms/psmouse-alps/1.3/build/make.log
  DKMS make.log for psmouse-alps-1.3 for kernel 3.10.10-200.fc19.x86_64 (x86_64)
  Wed Sep 11 20:02:58 BST 2013
  make: Entering directory `/usr/src/kernels/3.10.10-200.fc19.x86_64'
    CC      /var/lib/dkms/psmouse/alps-1.3/build/psmouse-base.o
    CC      /var/lib/dkms/psmouse/alps-1.3/build/synaptics.o
    CC      /var/lib/dkms/psmouse/alps-1.3/build/alps.o
    CC      /var/lib/dkms/psmouse/alps-1.3/build/elantech.o
    CC      /var/lib/dkms/psmouse/alps-1.3/build/logips2pp.o
    CC      /var/lib/dkms/psmouse/alps-1.3/build/lifebook.o
    CC      /var/lib/dkms/psmouse/alps-1.3/build/sentelic.o
    CC      /var/lib/dkms/psmouse/alps-1.3/build/trackpoint.o
    LD      /var/lib/dkms/psmouse/alps-1.3/build/psmouse.o
    LD      /var/lib/dkms/psmouse/alps-1.3/build/built-in.o
    CC [M]  /var/lib/dkms/psmouse/alps-1.3/build/appletouch.o
    CC [M]  /var/lib/dkms/psmouse/alps-1.3/build/sermouse.o
    CC [M]  /var/lib/dkms/psmouse/alps-1.3/build/synaptics_usb.o
    CC [M]  /var/lib/dkms/psmouse/alps-1.3/build/vsxxxaa.o
    Building modules, stage 2.
    MODPOST 4 modules
    CC      /var/lib/dkms/psmouse/alps-1.3/build/appletouch.mod.o
    LD [M]  /var/lib/dkms/psmouse/alps-1.3/build/appletouch.ko
    CC      /var/lib/dkms/psmouse/alps-1.3/build/sermouse.mod.o
    LD [M]  /var/lib/dkms/psmouse/alps-1.3/build/sermouse.ko
    CC      /var/lib/dkms/psmouse/alps-1.3/build/synaptics_usb.mod.o
    LD [M]  /var/lib/dkms/psmouse/alps-1.3/build/synaptics_usb.ko
    CC      /var/lib/dkms/psmouse/alps-1.3/build/vsxxxaa.mod.o
    LD [M]  /var/lib/dkms/psmouse/alps-1.3/build/vsxxxaa.ko
  make: Leaving directory `/usr/src/kernels/3.10.10-200.fc19.x86_64'
  #

Comment 10 einheit47 2013-09-12 02:42:02 UTC
Fedora (and many other distributions including openSUSE and apparently Mageiea) have psmouse support compiled into the kernel and not as a kernel module, so for that to work you would need to recompile your kernel. Lack of interest in doing this (and the need to manually keep up with updates) has meant my laptop is stuck with one of the *buntus or Debian. I've been hoping that work would be moving along on getting the patch accepted into the upstream kernel, since even though it is not perfect, it is good enough. But work on this seems to have stalled I fear...

Comment 11 Josh Boyer 2013-09-16 13:11:14 UTC
*** Bug 1008081 has been marked as a duplicate of this bug. ***

Comment 12 Justin Clift 2013-09-16 14:10:38 UTC
Sounds like we really need the psmouse changes incorporated into Fedora 19/20/etc directly then, if it's not suitable for upstream inclusion.

Comment 13 Stanislav Datskevich 2013-09-16 18:59:50 UTC
(In reply to Justin Clift from comment #12)
> Sounds like we really need the psmouse changes incorporated into Fedora
> 19/20/etc directly then, if it's not suitable for upstream inclusion.

It will be very nice because I tired to rebuild kernel just for setting psmouse as module then install psmouse module from https://www.dahetral.com/public-download .

Comment 14 Justin Clift 2013-09-20 14:13:25 UTC
Niels de Vos has been kind enough to compile a Fedora kernel with the ALPS pieces from https://www.dahetral.com/public-download/alps-psmouse-dlkm-for-3-2-and-3-5/at_download/file.

The kernel and associated pieces can be downloaded here:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=5955068

I'm not sure how long koji keeps stuff around, so it's mirrored here as a backup, just in case:

  http://justinclift.fedorapeople.org/alps_enabled_kernel/

For me, using a Dell Inspiron 17R SE, the ALPS touchpad now works "out of the box":

  $ xinput
  ⎡ Virtual core pointer                          id=2    [master pointer  (3)]
  ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
  ⎜   ↳ AlpsPS/2 ALPS GlidePoint                  id=13   [slave  pointer  (2)]
  ⎜   ↳ PS/2 Mouse                                id=14   [slave  pointer  (2)]
  ⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
      ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
      ↳ Power Button                              id=6    [slave  keyboard (3)]
      ↳ Video Bus                                 id=7    [slave  keyboard (3)]
      ↳ Video Bus                                 id=8    [slave  keyboard (3)]
      ↳ Power Button                              id=9    [slave  keyboard (3)]
      ↳ Sleep Button                              id=10   [slave  keyboard (3)]
      ↳ Laptop_Integrated_Webcam_HD               id=11   [slave  keyboard (3)]
      ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
      ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]

The touchpad also shows up in the Gnome3 Settings (screenshot attached).  You'll notice in the screenshot that 2 finger scrolling can be enabled, and it works in practise, which is really good.

Comment 15 Justin Clift 2013-09-20 14:15:53 UTC
As a data point, you don't need to install every rpm from the above list.  You just need the ones relevant to your system (and what you're doing with it).

For example, this is the install command I used:

  sudo yum install kernel-3.11.1-200.0.bz953211.fc19.x86_64.rpm kernel-devel-3.11.1-200.0.bz953211.fc19.x86_64.rpm kernel-headers-3.11.1-200.0.bz953211.fc19.x86_64.rpm kernel-modules-extra-3.11.1-200.0.bz953211.fc19.x86_64.rpm

Hope that helps. :)

Comment 16 Justin Clift 2013-09-20 14:19:28 UTC
Created attachment 800519 [details]
Gnome3 settings screenshot showing touchpad

This is a screenshot of Gnome3's "Mouse & Touchpad" Settings, with the ALPS touchpad kernel installed.  There is a "Touchpad" section available which isn't there otherwise.

Comment 17 Ozgur Gundogan 2013-09-20 14:38:26 UTC
(In reply to Justin Clift from comment #16)
> Created attachment 800519 [details]
> Gnome3 settings screenshot showing touchpad
> 
> This is a screenshot of Gnome3's "Mouse & Touchpad" Settings, with the ALPS
> touchpad kernel installed.  There is a "Touchpad" section available which
> isn't there otherwise.

It worked in my case too. Touchpad section also available. Thank you.
Fujitsu Lifebook AH532

Comment 18 Niels de Vos 2013-09-20 16:23:53 UTC
Created attachment 800566 [details]
[WIP 3/3] Input: ALPS - Add "Dolphin V2" touchpad support

This is the patch that has been applied to the test-kernel from comment #14. The kernel also makes psmouse a module instead of being built-in. This should not change the supported devices, but would allow dkms to be used if the psmouse module does not support this certain ALPS touchpad (wrong patch?).

The patch itself comes from http://thread.gmane.org/gmane.linux.kernel.input/29275.

I suggest that someone contacts Kevin Cernekee who wrote that patch and get a current status update. It is much preferred to have the patch in an upstream git repository before including it in the standard Fedora kernel package.

Comment 19 Niels de Vos 2013-10-15 07:13:18 UTC
Created attachment 812363 [details]
Most recent posted patch that adds support for this ALPS model

From http://thread.gmane.org/gmane.linux.kernel.input/31920

Updated kernel with most recent posted patch:
- http://koji.fedoraproject.org/koji/taskinfo?taskID=6058052
  (koji will delete the rpms soon)

Justin will provide a more durable download location so that others can test.

Comment 20 Justin Clift 2013-10-15 11:41:56 UTC
The location for the new ALPS touchpad patched F19 kernel is here:

  http://justinclift.fedorapeople.org/alps_enabled_kernel_v2/

Can everyone who tried the previous kernel, please try this one and report back whether it sees the touchpad (as a touchpad) or not?

Comment 21 Stanislav Datskevich 2013-10-15 12:58:54 UTC
(In reply to Justin Clift from comment #20)
> The location for the new ALPS touchpad patched F19 kernel is here:
> 
>   http://justinclift.fedorapeople.org/alps_enabled_kernel_v2/
> 
> Can everyone who tried the previous kernel, please try this one and report
> back whether it sees the touchpad (as a touchpad) or not?

Hi.
Just rebooted to that kernel.
It seems to work fine now. Here is my xinput output:
[stas@laptop-dell ~]$ xinput
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse             id=10    [slave  pointer  (2)]
⎜   ↳ ALPS PS/2 Device                            id=14    [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                    id=13    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ Sleep Button                                id=9    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD                 id=11    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=12    [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                            id=15    [slave  keyboard (3)]

But I don't understand why it's two ALPS devices now. If I disable "ALPS PS/2 Device" touchpad still work correctly, so I suppose it is some sort of 'dummy device'.

Comment 22 Pentarh Udi 2013-10-15 13:46:51 UTC
(In reply to Justin Clift from comment #20)
> The location for the new ALPS touchpad patched F19 kernel is here:
> 
>   http://justinclift.fedorapeople.org/alps_enabled_kernel_v2/
> 
> Can everyone who tried the previous kernel, please try this one and report
> back whether it sees the touchpad (as a touchpad) or not?

It works. But I wasn't success to get vertical scrolling working.

Comment 23 Justin Clift 2013-10-15 13:57:23 UTC
Thanks Pentarh. :)

Does the previous test kernel work any better than the new one?

  http://justinclift.fedorapeople.org/alps_enabled_kernel/

Comment 24 Pentarh Udi 2013-10-15 14:23:17 UTC
(In reply to Justin Clift from comment #23)
> Thanks Pentarh. :)
> 
> Does the previous test kernel work any better than the new one?
> 
>   http://justinclift.fedorapeople.org/alps_enabled_kernel/

Yes, It works better. Vertical scroll is okay (move finger on right edge of touchpad)

Comment 25 Justin Clift 2013-10-15 14:44:51 UTC
Created attachment 812562 [details]
Screenshot of KDE settings for Vertical Scrolling, from Pentarh Udi

This is a screenshot of KDE settings for Vertical Scrolling, from Pentarh Udi.

Comment 26 Gaspard Jankowiak 2013-10-15 16:35:26 UTC
I'm not sure if my laptop uses this kind of trackpad, but it's a Dell XT2 and the trackpad is only recognized as a PS/2 Mouse (shows as "↳ PS/2 Generic Mouse") in xinput.

This last build does not change that (thanks for providing it!)

Here are some relevant lines from dmesg:

psmouse serio1: alps: Unknown ALPS touchpad: E7=73 00 14, EC=10 00 64
psmouse serio1: Failed to enable mouse on isa0060/serio1
input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input10

Sorry for the noise if this is not relevant to the issue at hand.

Comment 27 Arnaud Lacombe 2013-10-15 22:09:42 UTC
No luck on my hardware:

psmouse serio2: alps: Unknown ALPS touchpad: E7=10 00 64, EC=10 00 64
psmouse serio2: elantech: assuming hardware version 4 (with firmware version 0x461f08)
psmouse serio2: elantech: Synaptics capabilities query result 0x10, 0x15, 0x0e.
input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio2/input/input7

though I originally CC'ed to this issue because of https://bugzilla.redhat.com/show_bug.cgi?id=986670. I am starting to think this is a different issue, and the DUPLICATE status is erroneous.

Comment 28 Arnaud Lacombe 2013-10-15 22:36:55 UTC
Bug 848270 provided me hints with what was wrong with the touchpad, and I got it to work.

Sorry for the noise.

Comment 29 Justin Clift 2013-10-16 07:50:41 UTC
Arnaud, no worries at all.  Thanks for testing. :)

Comment 30 Alexander Volovics 2013-10-16 18:51:27 UTC
After installing kernel-3.11.4-201.0.bz953211.fc19.x86_64.rpm the ALPS
touchpad on my Inspiron 17R SE can now at last scroll vertically.

Thanks to everybody who contributed to the solution.

Comment 31 einheit47 2013-10-17 02:22:43 UTC
I am happy to report that after installing kernel-3.11.4-201.0.bz953211.fc19.x86_64.rpm my ALPS touchpad (for a Dell Vostro 3360) is detected as a touchpad. Vertical scroll works and I can choose between two-finger or edge mode in KDE options. Everything else seems to be working great!

Comment 32 Justin Clift 2013-10-17 08:02:34 UTC
Alexander and Thane, thank you for testing and reporting back.  It helps a lot. :)

Comment 33 Daniel Wang 2013-10-19 02:16:42 UTC
I tried Justin's kernel-3.11.4-201.0.bz953211.fc19.x86_64.rpm and it seems to work on my Fujitsu Lifebook AH532. I've tried two-finger scrolling vertically and horizontally, successfully. If I disable two-finger scrolling in the gnome settings panel, edge scrolling works in both directions as well. It's great!

(side note: edge scrolling horizontally on my laptop is rather poor by design because there's no plastic lip or well to help align your thumb/finger on the bottom edge)

Comment 34 Justin Clift 2013-10-22 09:55:32 UTC
New kernel from Niels for testing:

  http://justinclift.fedorapeople.org/alps_enabled_kernel_v4/

This uses the very latest patches, submitted upstream yesterday:

  http://article.gmane.org/gmane.linux.kernel.input/32344

Hoping everyone who tried the previous kernels can try this one today, and report back whether it works properly or not.  We'll feed the results back through to the patch author. :)

Comment 35 Josh Boyer 2013-10-22 12:58:08 UTC
Thanks for doing the builds and patch tracking Justin and Niels.  And thanks for everyone that is testing.  As soon as something is committed to the input tree upstream, we'll backport that to Fedora.

Comment 36 einheit47 2013-10-23 03:13:07 UTC
I tried the kernel linked in comment #34 with the latest patches. Everything appears to be functioning, at least as well as with the previous patched kernel. Thanks everyone for the hard work!

Comment 37 Alexander Volovics 2013-10-23 07:47:50 UTC
Installed kernel from comment #34 and everything still appears to be working
as it should. I can scroll horizontally and vertically with the touchpad.
Everyone thanks for all the work to get this functioning.

Comment 38 Justin Clift 2013-10-23 19:46:13 UTC
Thanks guys. :)

The hardware testing results with our laptops, for the 4th version of the ALPS patch have been fed back through to the upstream linux-input mailing list:

  http://www.spinics.net/lists/linux-input/msg27923.html

Comment 39 Eric Eisenhart 2013-10-28 05:43:09 UTC
Kernel from comment #34 working great on Dell Inspiron 5720. Shows up as "AlpsPS/2 ALPS GlidePoint".

Comment 40 Justin Clift 2013-10-28 08:30:46 UTC
Excellent Eric, thanks for testing. :)

Comment 41 Gennadiy Mykhailiuta 2013-11-02 11:31:37 UTC
Works well on Fujitsu AH552 too: scrolling, tapping. Recognized as "AlpsPS/2 ALPS GlidePoint". Thanks a lot!! When this patch is expected to be integrated into kernel?

Comment 42 Eric Eisenhart 2013-12-16 04:23:21 UTC
Anything we can do to help get this on track for integration into a regular kernel release?

Comment 43 Justin Clift 2014-01-06 10:59:42 UTC
[apologies for the delay, I've been on leave and just got back]

While I was away Yunkang Tang / Tommy Will from ALPS made a v5 patch (improving on his v4 one), and submitted it upstream to the Linux-input kernel guys.

It was accepted into the Linux-input kernel tree here:

  http://www.spinics.net/lists/linux-input/msg28820.html

The Fedora kernel guys should probably be ok to pull this into main Fedora 19 (etc) kernels now.

Comment 44 Josh Boyer 2014-01-06 13:06:31 UTC
We'll try to get to it this week.  The bug backlog is rather large at the moment, but this one should be fairly simple.  Thanks to all that helped push this bug along!

Comment 45 Josh Boyer 2014-01-08 15:16:46 UTC
Please test this scratch build when it completes and let me know if it works.  The patch needed a bit of tweaking to work on a 3.12 kernel and I want to get some testing before committing it.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6374372

Comment 46 Justin Clift 2014-01-08 17:21:17 UTC
Thanks Josh, that's excellent. :)

Are you able to kick off an F19 build of that?

Just tried installing the F20 x86_64 kernel on my F19 system (with the ALPS touchpad), and F19 doesn't like the F20 kernel rpm format.

If you can't, I'll manually rebuild an F19 version from the src.rpm tomorrow and try it out. :)

Comment 47 Josh Boyer 2014-01-08 17:25:02 UTC
Er... what do you mean F19 doesn't like the F20 kernel rpm format?  Nothing in the RPM payload changed between F19 and F20.  It should work just fine as I ran that kind of setup several times.

Comment 48 Justin Clift 2014-01-08 18:22:33 UTC
Heh, you're completely right.  Turned out to be a mis-downloaded kernel rpm, that was causing errors when attempting install.

Redownloaded, and it installed properly.

Now rebooted into it, and the touchpad is working fine. :)

Two finger scrolling is working as expected, with the touchpad settings showing up properly in Gnome.

For reference, this is how xinput looks:

  $ cat /etc/redhat-release 
  Fedora release 19 (Schrödinger’s Cat)
  $ uname -r
  3.12.6-300.3.fc20.x86_64
  $ xinput
  ⎡ Virtual core pointer                          id=2    [master pointer  (3)]
  ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
  ⎜   ↳ AlpsPS/2 ALPS GlidePoint                  id=13   [slave  pointer  (2)]
  ⎜   ↳ PS/2 Mouse                                id=14   [slave  pointer  (2)]
  ⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
      ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
      ↳ Power Button                              id=6    [slave  keyboard (3)]
      ↳ Video Bus                                 id=7    [slave  keyboard (3)]
      ↳ Video Bus                                 id=8    [slave  keyboard (3)]
      ↳ Power Button                              id=9    [slave  keyboard (3)]
      ↳ Sleep Button                              id=10   [slave  keyboard (3)]
      ↳ Laptop_Integrated_Webcam_HD               id=11   [slave  keyboard (3)]
      ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
      ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]

Looks like a winner Josh. :)

Comment 49 Josh Boyer 2014-01-08 18:24:02 UTC
Great!  Thanks for testing.  I'll get the fixes into Fedora git shortly.

Comment 50 Justin Clift 2014-01-10 10:58:12 UTC
As a data point, I just installed the new Fedora 21 kernel that has the ALPS patch in it, onto my F19 laptop.  Touchpad is working fine:

  http://koji.fedoraproject.org/koji/buildinfo?buildID=489251

Hopefully the patch makes its way into F19/F20 kernels too shortly. :)

Comment 51 Josh Boyer 2014-01-10 12:43:24 UTC
It's in Fedora git for F19 and F20.  Should be in the first 3.12.7 build.

Comment 52 Fedora Update System 2014-01-11 16:16:23 UTC
kernel-3.12.7-300.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.12.7-300.fc20

Comment 53 Fedora Update System 2014-01-11 16:20:01 UTC
kernel-3.12.7-200.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.12.7-200.fc19

Comment 54 Fedora Update System 2014-01-12 04:59:16 UTC
Package kernel-3.12.7-200.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.12.7-200.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0684/kernel-3.12.7-200.fc19
then log in and leave karma (feedback).

Comment 55 Fedora Update System 2014-01-14 08:33:55 UTC
kernel-3.12.7-200.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 56 Fedora Update System 2014-01-14 08:37:24 UTC
kernel-3.12.7-300.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 57 Markas Rapoportas 2014-01-29 09:12:31 UTC
Hi there. I have a Dell XPS M1530 with an ALPS GlidePoint device. The
touchpad does not work properly with kernel-3.12.8-300.fc20.x86_64. In
short, even though the device is not called "PS/2 Generic", the symptoms
are the same as in comment 0. My issue is described at length in bug
969834, where you can find two separate accounts of the issue, both from
an M1530. What is perhaps special about my case is that the touchpad
starts working once you suspend and resume for the first time, which is my
workaround. I am guessing it is not a Dolphin v2 as the touchpad used to
work well in Fedora 16, but the work incorporated into Fedora thanks to
bug 812111 clearly did not resolve the issue.

Comment 58 Counalakis Dimitris 2014-04-25 10:31:49 UTC
Hi all, 
I have a Fujitsu Lifebook E754 QM87 with F20 and touchpad is not working at all,
even with the latest kernel (testing version, rawhide etc):

Unknown ALPS touchpad: E7=10 00 64, EC=10 00 64

But: with kernel 3.13.10-200.fc20.x86_64 and the psmouse-alps-driver driver from https://github.com/he1per/psmouse-dkms-alpsv7 seems to work, as long as 
{ 0x10, 0x00, 0x64 } is added into alps_model_data[].

The output from /proc/bus/input/devices is as follows:
I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="ALPS PS/2 Device"
P: Phys=synaptics-pt/serio0/input1
S: Sysfs=/devices/platform/i8042/serio2/serio9/input/input48
U: Uniq=
H: Handlers=mouse1 event16 
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=0200
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=synaptics-pt/serio0/input0
S: Sysfs=/devices/platform/i8042/serio2/serio9/input/input47
U: Uniq=
H: Handlers=mouse2 event17 
B: PROP=0
B: EV=b
B: KEY=420 670000 0 0 0 0
B: ABS=1000003


It will probably work with newer kernels as well, as long as alps.c is patched.

Comment 59 Justin Clift 2014-04-25 11:06:46 UTC
Thanks, that's good info. :)

Personally, I'm keeping an eye on the progress of that ALPS protocol v7 patch (I'm on the CC list).

That patch is still undergoing development and review upstream on the linux-input mailing list, so it's not *yet* quite ready for inclusion into the Linux kernel.

It probably will be within a few iterations though.  Hopefully a few weeks maximum.

Once it has been accepted and merged upstream, the Fedora kernel team can consider it for backporting into current kernels.  (it mostly depends on how drop-in-nicely vs intrusive the patch would be)

In the meantime, you are *definitely* encouraged to provide feedback to Qiting / Elaine on her patch.  Specifically let her know if it *does* or *doesn't* work for you, any weirdness at all, etc.  She's responsive and the feedback *greatly* helps ensure the patch will work for your hardware. :)

Comment 60 Justin Clift 2014-04-25 11:08:40 UTC
This might help too (the page for subscribing to the Linux-input mailing list):

  http://vger.kernel.org/vger-lists.html#linux-input

Comment 61 Counalakis Dimitris 2014-04-25 11:13:39 UTC
(In reply to Justin Clift from comment #59)
> Thanks, that's good info. :)
> 
> Personally, I'm keeping an eye on the progress of that ALPS protocol v7
> patch (I'm on the CC list).
> 
> That patch is still undergoing development and review upstream on the
> linux-input mailing list, so it's not *yet* quite ready for inclusion into
> the Linux kernel.
> 
> It probably will be within a few iterations though.  Hopefully a few weeks
> maximum.
> 
> Once it has been accepted and merged upstream, the Fedora kernel team can
> consider it for backporting into current kernels.  (it mostly depends on how
> drop-in-nicely vs intrusive the patch would be)
> 
> In the meantime, you are *definitely* encouraged to provide feedback to
> Qiting / Elaine on her patch.  Specifically let her know if it *does* or
> *doesn't* work for you, any weirdness at all, etc.  She's responsive and the
> feedback *greatly* helps ensure the patch will work for your hardware. :)

ok :) I'll try to spend some more time on it and provide you with feedback.
In the mean time, I'm going to check thoroughly the features/gestures supposed to work with alps-v7 and this particular touchpad.


Note You need to log in before you can comment on or make changes to this bug.