Bug 98706 - procinfo -a segfaults.
procinfo -a segfaults.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: procinfo (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-07 15:25 EDT by James Olin Oden
Modified: 2015-01-07 19:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-15 07:06:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Olin Oden 2003-07-07 15:25:39 EDT
Description of problem:
If you run:

   procinfo -a

A segfault will occur.  A stack trace of the core file looks like:

  (gdb) bt
   #0  0x4207a6db in strlen () from /lib/tls/libc.so.6
   #1  0x420477ed in vfprintf () from /lib/tls/libc.so.6
   #2  0x4204f3e2 in printf () from /lib/tls/libc.so.6
   #3  0x0804c683 in strcpy () 
   #4  0x0804d20a in strcpy ()
   #5  0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6


Version-Release number of selected component (if applicable):
18-8

How reproducible:
Always

Steps to Reproduce:
1.  Run:

   procinfo -a

Actual results:
A segfault occurs.

Expected results:
Not that (-;

Additional info:
Comment 1 Mike A. Harris 2003-07-17 07:15:00 EDT
This problem isn't reproduceable on any machines I have available, which
implies that it only happens with the specific contents of the /proc files
on your system, or something in them is triggering this.  In order to fix
it however, we'll need you to narrow down the problem.  Can you install
the -debuginfo packages for procinfo after rebuilding it and then run it
in gdb to find where the exact failure is?
Comment 2 Mike A. Harris 2004-01-13 11:46:04 EST
I can't really proceed with this bug report unless I can personally
reproduce the problem, or receive more information from you.  I have
tried to reproduce this on numerous systems to no avail.

There are other currently open procinfo bugs of which yours might
be a duplicate, however I can't conclude that without further
feedback from you on this problem.

Please examine bug #89176, bug #112533 to see if either of them are
the same problem you are encountering, which in both cases seems
to be due to procinfo assuming the wrong maximum number of
character devices available.  How many char devices does your
system have present when this problem occurs?

Please respond ASAP, so I can clear out these issues and update
procinfo.
Comment 3 Mike A. Harris 2004-03-15 07:06:34 EST
Closing bug as 'WORKSFORME' state, as I'm unable to reproduce this
problem locally.

Note You need to log in before you can comment on or make changes to this bug.