Bug 987120 - Storage node start script fails on Solaris
Storage node start script fails on Solaris
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Launch Scripts (Show other bugs)
4.8
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: RHQ 4.9
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-07-22 14:12 EDT by John Sanda
Modified: 2014-04-15 19:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 15:25:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 791213 None None None Never

  None (edit)
Description John Sanda 2013-07-22 14:12:49 EDT
Description of problem:
A community user reported a problem with the cassandra shell script prevents Cassandra from starting up. The error is,

bash-3.2$ bin/rhqctl start --storage 11:56:15,477 INFO  [org.jboss.modules] JBoss Modules version 1.2.0.CR1 ./cassandra: numactl: not found ./cassandra: bad substitution 11:56:15,853 ERROR [org.rhq.server.control.RHQControl] Failed to stop services [Cause: org.apache.commons.exec.ExecuteException: Process exited with an error: 1 (Exit value: 1)]

The error stems (in part) from the numactl command not being available on his platform. He is running on 5.10 Generic_148889-01 i86pc i386 i86pc.

I do not know whether or not this is an issue on other versions of Solaris. The problem is more than the numactl not being available because I do not have numactl on my Mac and do not get any such error. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Heiko W. Rupp 2013-08-22 16:23:58 EDT
I have just tried that on OpenSolaris 11.1 inside a virtualbox from master 

hrupp@solaris:~/rhq-server-4.9.0-SNAPSHOT$ uname -a
SunOS solaris 5.11 11.1 i86pc i386 i86pc

and it worked as expected.
Comment 3 Filip Brychta 2013-09-02 10:15:38 EDT
Works for me on SunOS solaris11 5.11 11.1 i86pc i386 i86pc 

RHQ version:
Version: 4.9.0-SNAPSHOT
Build Number: a9245fd
Comment 4 Mike Foley 2013-09-09 14:50:41 EDT
based on comments #2 and #3 ... marking this verified.
Comment 5 Heiko W. Rupp 2013-09-09 14:58:58 EDT
To amend my comment:
detection of 32/64 bit mode can't be done via uname, but needs

# isainfo -kv

Note You need to log in before you can comment on or make changes to this bug.