Bug 98717 - kernel-smp hangs install if symlink not present...
kernel-smp hangs install if symlink not present...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
: 98718 98719 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-07 18:23 EDT by Thomas Wiest
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 21:51:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Wiest 2003-07-07 18:23:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
When installing kernel-smp it seems that it's expecting this symlink to be there:
/lib/kernel/2.4.9-e.24smp/libredhat-kernel.so.1 ->
/lib/kernel/2.4.9-e.24smp/libredhat-kernel.so.1.0.1

that isn't there. In the install.log file located in /mnt/sysimage/tmp, the last
line is:

"tar: error while loading shared libraries: libredhat-kernel.so.1: cannot open
shared object file: No such file or directory"

Also, I am not doing a full install (see below for the ks.cfg script that
specifies the RPMS that are being install).

Additional Info (May be helpful, may not)
-----------------------------------------
Hardware: Dell Poweredge 1600SC
Installation type: Network install using Kickstart script

ks.cfg script:
--------------
install
rootpw novell
nfs --server apt.provo.novell.com --dir /inet/ftp/pub/redhat/2.1AS/i386/
interactive
lang en_US
langsupport --default en_US en_US
firewall --disabled
authconfig --enableshadow --enablemd5
timezone America/Denver
bootloader
clearpart --all
part swap --size 1 --maxsize 512 --grow --asprimary --fstype swap
part / --size 1 --grow --asprimary --fstype ext3

%packages
libaio
@ Classic X Window System
@ X Window System
@ GNOME
@ KDE
@ Network Support
@ Utilities
@ Advanced Server

%post

Version-Release number of selected component (if applicable):
kernel-smp-2.4.9-e.24.i686.rpm

How reproducible:
Always

Steps to Reproduce:
Steps to recreate:
------------------
1. do a kickstart install with a ks.cfg file that has the same package list as
the ks.cfg file from the description.
2. wait until the kernel-smp rpm is trying to be installed.
3. notice that the installer hangs and that you see the same error message as
above in the install.log file.  

Actual Results:  the installer hangs while installing the kernel-smp rpm and
can't recover.

Expected Results:  it should finish installing the kernel-smp rpm

Additional info:
Comment 1 Bill Nottingham 2003-07-09 22:02:54 EDT
*** Bug 98718 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-07-09 22:03:06 EDT
*** Bug 98719 has been marked as a duplicate of this bug. ***
Comment 3 Larry Woodman 2005-09-28 21:51:44 EDT
This problem was fixed long ago.

Larry Woodman

Note You need to log in before you can comment on or make changes to this bug.