Bug 98719 - kernel-smp hangs install if symlink not present...
kernel-smp hangs install if symlink not present...
Status: CLOSED DUPLICATE of bug 98717
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-07 18:38 EDT by Thomas Wiest
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log file from a successfull CD install using the same ks.cfg file (9.36 KB, text/plain)
2003-07-07 19:04 EDT, Thomas Wiest
no flags Details
install.log file from an unsuccessfull NFS install using the same ks.cfg file (5.27 KB, text/plain)
2003-07-07 19:04 EDT, Thomas Wiest
no flags Details

  None (edit)
Description Thomas Wiest 2003-07-07 18:38:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
When installing kernel-smp it seems that it's expecting this symlink to be there:
/lib/kernel/2.4.9-e.24smp/libredhat-kernel.so.1 ->
/lib/kernel/2.4.9-e.24smp/libredhat-kernel.so.1.0.1

that isn't there. In the install.log file located in /mnt/sysimage/tmp, the last
line is:

"tar: error while loading shared libraries: libredhat-kernel.so.1: cannot open
shared object file: No such file or directory"

Also, I am not doing a full install (see below for the ks.cfg script that
specifies the RPMS that are being install).

Additional Info (May be helpful, may not)
-----------------------------------------
Hardware: Dell Poweredge 1600SC
Installation type: Network install using Kickstart script

ks.cfg script:
--------------
install
rootpw novell
nfs --server apt.provo.novell.com --dir /inet/ftp/pub/redhat/2.1AS/i386/
interactive
lang en_US
langsupport --default en_US en_US
firewall --disabled
authconfig --enableshadow --enablemd5
timezone America/Denver
bootloader
clearpart --all
part swap --size 1 --maxsize 512 --grow --asprimary --fstype swap
part / --size 1 --grow --asprimary --fstype ext3

%packages
libaio
@ Classic X Window System
@ X Window System
@ GNOME
@ KDE
@ Network Support
@ Utilities
@ Advanced Server

%post

Version-Release number of selected component (if applicable):
kernel-smp-2.4.9-e.24.i686.rpm

How reproducible:
Always

Steps to Reproduce:
Steps to recreate:
------------------
1. do a kickstart install with a ks.cfg file that has the same package list as
the ks.cfg file from the description.
2. wait until the kernel-smp rpm is trying to be installed.
3. notice that the installer hangs and that you see the same error message as
above in the install.log file.  

Actual Results:  the installer hangs while installing the kernel-smp rpm and
can't recover.

Expected Results:  it should finish installing the kernel-smp rpm

Additional info:
Comment 1 Thomas Wiest 2003-07-07 18:52:43 EDT
Ok, I just did a CD install using the same ks.cfg file and it installed just
fine, so it seems to be only on NFS installs that it has problems.

My Symlink conclusion could be wrong. Looking at the filesystem from a
successful cd install with the same ks.cfg file, I've noticed that it doesn't
contain a symlink either. So I'm really not sure what's causing this.
Comment 2 Thomas Wiest 2003-07-07 18:55:43 EDT
One more thing, this is using all update-2 stuff. When I'm doing the NFS
install, I'm using bootnet.img and drvnet.img (both update-2 of course).
Comment 3 Thomas Wiest 2003-07-07 19:04:07 EDT
Created attachment 92785 [details]
install.log file from a successfull CD install using the same ks.cfg file
Comment 4 Thomas Wiest 2003-07-07 19:04:54 EDT
Created attachment 92786 [details]
install.log file from an unsuccessfull NFS install using the same ks.cfg file
Comment 5 Bill Nottingham 2003-07-09 22:03:03 EDT

*** This bug has been marked as a duplicate of 98717 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:56:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.