Bug 987224 - Bug: Rendering Diffs on CSP Map makes revision tab buttons useless
Bug: Rendering Diffs on CSP Map makes revision tab buttons useless
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 22:56 EDT by Misha H. Ali
Modified: 2013-09-16 23:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 23:29:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the described problem (109.45 KB, image/png)
2013-07-22 23:00 EDT, Misha H. Ali
no flags Details

  None (edit)
Description Misha H. Ali 2013-07-22 22:56:52 EDT
On the CCMS.next interface, if you are viewing revisions of a CSP map and accidentally click on "Rendered Diff", nothing appears in the rendered view (as expected) but there is no way to cancel the rendering view. Until this cancellation occurs, the user is stuck because all the buttons on the Diff view are grayed out.

Normally, I would click on one of the other tabs, for example "XML Editing" or "Properties", etc. and then switch back to find the rendering process cancelled but switching back and forth does not do anything in this case.

If there is a way to return to viewing diffs from this point, I can't find it so it is at the very least non-obvious.
Comment 1 Misha H. Ali 2013-07-22 23:00:47 EDT
Created attachment 777146 [details]
Screenshot of the described problem

Adding a screenshot to illustrate the problem.
Comment 2 Lee Newson 2013-09-16 23:29:51 EDT
Since Content Specs have their own editor now, this really isn't a problem anymore so I'm marking this as won't fix.

I also have a very high suspicion that the cause of this is the same as BZ#1006123

Note You need to log in before you can comment on or make changes to this bug.