Bug 987293 - [RHEV+RHS] - On adding RHS server node to Gluster Enabled Cluster on RHEVM 3.2, boot-strapping sets the wrong profile for tuned
[RHEV+RHS] - On adding RHS server node to Gluster Enabled Cluster on RHEVM 3....
Status: CLOSED CURRENTRELEASE
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.tune (Show other bugs)
1.0.0
All Linux
unspecified Severity high (vote)
: ---
: 1.1.0
Assigned To: Alon Bar-Lev
SATHEESARAN
gluster
:
: 987077 (view as bug list)
Depends On:
Blocks: 994486
  Show dependency treegraph
 
Reported: 2013-07-23 03:41 EDT by Rejy M Cyriac
Modified: 2016-02-10 13:59 EST (History)
16 users (show)

See Also:
Fixed In Version: is10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 994486 (view as bug list)
Environment:
virt rhev integration
Last Closed: 2014-01-21 17:17:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
alonbl: devel_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17265 None None None Never

  None (edit)
Description Rejy M Cyriac 2013-07-23 03:41:10 EDT
Description of problem:
When an RHS server node is added to a Gluster Enabled Cluster in RHEVM 3.2, the boot-strapping process sets the profile 'virtual-host' for tuned. This profile is wrong, as the profile expected to be set for tuned, on an RHS node added to RHEVM, is 'rhs-virtualization'

The issue is reproducible irrespective of Gluster Enabled Cluster Compatibility version

-------------------------------------------------

2013-07-23 12:54:11 DEBUG otopi.plugins.ovirt_host_deploy.tune.tuned plugin.executeRaw:347 execute: ('/usr/bin/tuned-adm', 'profile', 'virtual-host'), executable='None', cwd='None', env=None
2013-07-23 12:54:12 DEBUG otopi.plugins.ovirt_host_deploy.tune.tuned plugin.executeRaw:364 execute-result: ('/usr/bin/tuned-adm', 'profile', 'virtual-host'), rc=0
2013-07-23 12:54:12 DEBUG otopi.plugins.ovirt_host_deploy.tune.tuned plugin.execute:412 execute-output: ('/usr/bin/tuned-adm', 'profile', 'virtual-host') stdout:
Stopping tuned: [  OK  ]
Applying ktune sysctl settings:
/etc/ktune.d/tunedadm.conf: [  OK  ]
Calling '/etc/ktune.d/tunedadm.sh start': [  OK  ]
Applying sysctl settings from /etc/sysctl.conf
Applying deadline elevator: sda sdb [  OK  ]
Starting tuned: [  OK  ]

2013-07-23 12:54:12 DEBUG otopi.plugins.ovirt_host_deploy.tune.tuned plugin.execute:417 execute-output: ('/usr/bin/tuned-adm', 'profile', 'virtual-host') stderr:
Switching to profile 'virtual-host'

2013-07-23 12:54:12 DEBUG otopi.plugins.otopi.services.rhel rhel.startup:151 set service tuned startup to True

-------------------------------------------------

-------------------------------------------------

On RHS 2.0 Update 5:

# ls /etc/tune-profiles/
active-profile  desktop-powersave   functions            laptop-battery-powersave  rhs-high-throughput  server-powersave  throughput-performance
default         enterprise-storage  laptop-ac-powersave  latency-performance       rhs-virtualization   spindown-disk

# tuned-adm active
Current active profile: default
Service tuned: enabled, running
Service ktune: disabled, stopped


On RHS 2.1

# ls /etc/tune-profiles/
active-profile  desktop-powersave   functions            laptop-battery-powersave  rhs-high-throughput  server-powersave  throughput-performance  virtual-host
default         enterprise-storage  laptop-ac-powersave  latency-performance       rhs-virtualization   spindown-disk     virtual-guest

# tuned-adm active
Current active profile: virtual-host
Service tuned: enabled, running
Service ktune: enabled, running

-------------------------------------------------

Version-Release number of selected component (if applicable):
RHEVM 3.2 - 3.2.1-0.39.el6ev
RHS 2.0 Update5 - glusterfs-server-3.3.0.11rhs-1.el6rhs.x86_64
RHS 2.1 - glusterfs-server-3.4.0.12rhs.beta5-2.el6rhs.x86_64

How reproducible:

Steps to Reproduce:
1.On RHEVM 3.2, create POSIX compliant FS type Data Center
2.Create Gluster Enabled Cluster
3.Add RHS server node to cluster

Actual results:
Boot-strapping process sets the wrong profile of 'virtual-host' for tuned, when an RHS server node is added to a Gluster Enabled Cluster on RHEVM 3.2

Expected results:
Boot-strapping process should set the expected profile of 'rhs-virtualization' for tuned, when an RHS server node is added to a Gluster Enabled Cluster on RHEVM 3.2

Additional info:

When an RHS 2.0 server node is added to Gluster Enabled Cluster of Compatibility version 3.1, the profile setting currently fails, as reported in BZ 987077 . It would succeed if the profile being set is the expected one of 'rhs-virtualization'
Comment 1 Bala.FA 2013-07-23 06:39:31 EDT
I am not sure what profile needs to be set in case of gluster only cluster.  Options are
1. rhs-high-throughput
2. rhs-virtualization
3. none

Note: RHS installation doesn't set any profile by default.  Its user choice.
Comment 2 Barak 2013-08-01 09:27:26 EDT
is this is a gluster only cluster ?
Comment 3 Rejy M Cyriac 2013-08-01 10:04:49 EDT
(In reply to Barak from comment #2)
> is this is a gluster only cluster ?

Yes, the issue was observed on a gluster only cluster.

- rejy (rmc)
Comment 4 Bala.FA 2013-08-01 21:19:15 EDT
Setting needinfo? as i haven't got a reply for comment #1
Comment 5 Tushar Katarki 2013-08-02 10:59:54 EDT
Default should be rhs-high-throughput.
Comment 6 Tushar Katarki 2013-08-06 08:08:24 EDT
(In reply to Tushar Katarki from comment #5)
> Default should be rhs-high-throughput.

Actually now that I re-read the bug, the filer makes it clear in the descriptin that the newly added rhs node should have a tuned profile of rhs-virtualization instead of virtual-host. rhs-virtualization is indeed correct. Please ignore comment #5.
Comment 7 Bala.FA 2013-08-06 08:33:52 EDT
Problem here is when adding a node to engine, bootstrap has no clue whether the node is used as vm store or data store.  Setting rhs-virtualization will not be correct in case of data store.

As tuned profile setting is treated as user's task, I would think that setting it as none (no tuned profile will be set) in bootstrap for rhs is good enough.

Please let me know your thoughts before changing the code.
Comment 8 Bala.FA 2013-08-19 01:36:25 EDT
After some discussion internally, we are asked to set 'rhs-virtualization' tuned profile
Comment 9 Alon Bar-Lev 2013-08-19 02:15:37 EDT
(In reply to Bala.FA from comment #8)
> After some discussion internally, we are asked to set 'rhs-virtualization'
> tuned profile

Wasn't that already done[1]?

[1] http://gerrit.ovirt.org/#/c/17265/
Comment 10 Bala.FA 2013-08-19 02:21:51 EDT
Yes.  comment#8 is a just tracker note.  You could move to ON_QA once the build is ready.
Comment 11 Alon Bar-Lev 2013-08-19 02:47:13 EDT
*** Bug 987077 has been marked as a duplicate of this bug. ***
Comment 12 Alon Bar-Lev 2013-08-19 03:00:27 EDT
And this and bug#994486 are duplicates.

ovirt-host-deploy-1.1.0-0.8.master.el6ev
Comment 13 SATHEESARAN 2013-10-07 13:36:58 EDT
Verified with RHEVM 3.3 IS16

RHS 2.1, RHS 2.0 U5, RHS 2.0 U6 nodes gets "rhs-virtualization" profile when added to gluster-cluster.
Comment 14 Itamar Heim 2014-01-21 17:17:19 EST
Closing - RHEV 3.3 Released
Comment 15 Itamar Heim 2014-01-21 17:23:59 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.