Bug 994486 - [RHSC] - On adding RHS server node to a cluster via the Console, boot-strapping sets the wrong profile for tuned
[RHSC] - On adding RHS server node to a cluster via the Console, boot-strappi...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
All Linux
high Severity high
: ---
: ---
Assigned To: Alon Bar-Lev
Shruti Sampat
gluster
:
Depends On: 987293
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 07:24 EDT by Shruti Sampat
Modified: 2013-09-23 18:25 EDT (History)
20 users (show)

See Also:
Fixed In Version: is10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 987293
Environment:
Last Closed: 2013-09-23 18:25:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2013-08-07 07:24:58 EDT
+++ This bug was initially created as a clone of Bug #987293 +++

Description of problem:
When an RHS server node is added to a cluster via the Console, the boot-strapping process sets the profile 'virtual-host' for tuned.

Before adding the node to a cluster via the Console, the active tuned profile is 'default'

Before adding the node:

[root@rhs ~]# tuned-adm active
Current active profile: default
Service tuned: disabled, stopped
Service ktune: disabled, stopped

After adding the node:

[root@rhs ~]# tuned-adm active
Current active profile: virtual-host
Service tuned: enabled, running
Service ktune: enabled, running

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb8.el6rhs 
RHS 2.1 : glusterfs-3.4.0.17rhs-1.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Create a 3.2 compatible cluster via the Console
2.Add a RHS server to the cluster

Actual results:
Boot-strapping process sets the wrong profile of 'virtual-host' for tuned, when an RHS server node is added to a cluster via the Console.

Expected results:
Boot-strapping should not set the profile as 'virtual-host' for a RHS node which is added to a cluster.

Additional info:
Comment 1 Kanagaraj 2013-08-14 07:50:04 EDT
fixed in ovirt-host-deploy-1.1.0-0.8.master.el6ev
Comment 2 Shruti Sampat 2013-08-16 02:21:07 EDT
Verfied as fixed in ovirt-host-deploy-1.1.0-0.8.master.el6ev.noarch. 

After bootstrapping -

[root@rhs ~]# tuned-adm active                                             │                                                                          
Current active profile: rhs-virtualization                                 │                                                                          
Service tuned: enabled, running                                            │                                                                          
Service ktune: enabled, running
Comment 3 Scott Haines 2013-09-23 18:25:53 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.