Bug 987432 - mark dht_linkfile creation/deletion fop's as internal
mark dht_linkfile creation/deletion fop's as internal
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: shishir gowda
shishir gowda
:
Depends On: 987428
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 07:29 EDT by shishir gowda
Modified: 2013-12-08 20:36 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 987428
Environment:
Last Closed: 2013-09-23 18:35:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shishir gowda 2013-07-23 07:29:45 EDT
+++ This bug was initially created as a clone of Bug #987428 +++

Description of problem:

Currently dht creates/deletes linkfiles for various ops like
rename/linking and when layout changes. dht_linkfile_create
already sends a key GLUSTERFS_INTERNAL_FOP_KEY in dict to
identify this as an internal fop and not user based op.

Enhancing rename related links/unlinks to send this key too.
Marker/changelog or other xlators can now identify these as
internal fops and handle them accordingly

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2013-07-23 07:27:28 EDT ---

REVIEW: http://review.gluster.org/5335 (cluster/dht: mark linkfile creation/deletion as internal fop) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 3 Amar Tumballi 2013-08-09 03:14:54 EDT
This is a change in the code, not visible to the users. Hence, doesn't have any proper use-cases to test against.
Comment 6 shishir gowda 2013-08-27 05:17:06 EDT
This is an internal fix of sending additional flag in xdata argument of few fops to identify the fop as being done internally.
Moving the bug to verified state.
Comment 7 Scott Haines 2013-09-23 18:35:56 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.