Bug 987495 - nullpointer dereference causes xorg-server segfault when nouveau DRI driver is loaded
nullpointer dereference causes xorg-server segfault when nouveau DRI driver i...
Status: CLOSED DUPLICATE of bug 957790
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mesa (Show other bugs)
Unspecified Unspecified
medium Severity medium
: rc
: 6.5
Assigned To: Dave Airlie
Desktop QE
Depends On:
  Show dependency treegraph
Reported: 2013-07-23 09:53 EDT by Martin Schuppert
Modified: 2013-11-25 10:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 862466
Last Closed: 2013-11-25 10:25:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
upstream patch (522 bytes, patch)
2013-07-23 09:56 EDT, Martin Schuppert
no flags Details | Diff

  None (edit)
Description Martin Schuppert 2013-07-23 09:53:41 EDT
Description of problem:
Application can crash Xorg when the nouveau DRI driver is loaded. This is due to a nullpointer dereference.

Upstream BUG:

Upstream bug 61947 is fixed in mesa 9.1.2. This bug causes a crash in LabVIEW when dealing with the 3D Math Plot controls. The fix does stop the crash from happening in LabVIEW and restarting X. Upstream bug mention same thing using Chromium.

Version-Release number of selected component (if applicable):

     69                 __DRIdri2LoaderExtension *dri2 = screen->dri2.loader;
     70                 __DRIdrawable *drawable = nctx->dri_context->driDrawablePriv;
     72                 dri2->flushFrontBuffer(drawable, drawable->loaderPrivate);
     73         }
     74 }

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:
no crash

Additional info:
* Upstream patch:

--- Mesa-9.1/src/mesa/drivers/dri/nouveau/nouveau_driver.c.orig	2013-03-05 22:45:04.381790793 +0000
+++ Mesa-9.1/src/mesa/drivers/dri/nouveau/nouveau_driver.c	2013-03-05 22:47:45.307338871 +0000
@@ -69,7 +69,9 @@
 		__DRIdri2LoaderExtension *dri2 = screen->dri2.loader;
 		__DRIdrawable *drawable = nctx->dri_context->driDrawablePriv;
-		dri2->flushFrontBuffer(drawable, drawable->loaderPrivate);
+		if (drawable && drawable->loaderPrivate) {
+			dri2->flushFrontBuffer(drawable, drawable->loaderPrivate);
+		}

* Bug 862466 - [abrt] firefox-15.0.1-1.fc17: nouveau_flush: Process /usr/lib/firefox/firefox was killed by signal 11 (SIGSEGV)
Comment 2 Martin Schuppert 2013-07-23 09:56:55 EDT
Created attachment 777332 [details]
upstream patch
Comment 4 RHEL Product and Program Management 2013-10-13 23:03:29 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.