Bug 987511 - gluster-cli: Format the output of 'gluster pool list' properly
gluster-cli: Format the output of 'gluster pool list' properly
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
low Severity low
: ---
: RHGS 3.0.4
Assigned To: Vijaikumar Mallikarjuna
Triveni Rao
: ZStream
Depends On:
Blocks: 1028871 1182947
  Show dependency treegraph
 
Reported: 2013-07-23 10:39 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:56 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0.46-1
Doc Type: Bug Fix
Doc Text:
Previously, the 'gluster pool list' output indentation was not proper when the hostname was greater that 8 characters. This issue is now fixed.
Story Points: ---
Clone Of:
: 1028871 (view as bug list)
Environment:
Last Closed: 2015-03-26 02:33:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M S Vishwanath Bhat 2013-07-23 10:39:54 EDT
Description of problem:
The output of gluster pool list is not properly formatted. Please format it properly.

Version-Release number of selected component (if applicable):
glusterfs 3.4.0.12rhs.beta5

How reproducible:
Always

Steps to Reproduce:
1. gluster pool list

Actual results:
[root@spitfire glusterfs-deploy-scripts]# gluster pool list
UUID                                    Hostname        State
878a0b9c-8936-413b-a3a1-2d0bf530bf21    mustang Connected 
501cad4a-1909-49c6-bd22-342aa6095a65    harrier Connected 
50462323-b32f-4c43-a6e6-ce520b958f51    typhoon Connected 
8f85482a-34f8-4ff3-9baa-ed1b83e88058    localhost       Connected 


[root@mustang ~]# gluster pool list
UUID                                    Hostname        State
8f85482a-34f8-4ff3-9baa-ed1b83e88058    spitfire        Connected 
501cad4a-1909-49c6-bd22-342aa6095a65    harrier Connected 
50462323-b32f-4c43-a6e6-ce520b958f51    typhoon Connected 
878a0b9c-8936-413b-a3a1-2d0bf530bf21    localhost       Connected 


Expected results:


Additional info:
Comment 2 Vijaikumar Mallikarjuna 2014-05-13 05:13:36 EDT
Patch http://review.gluster.org/#/c/6245/ fixes the issue
Comment 3 Vivek Agarwal 2014-05-22 07:51:05 EDT
Merged as a part of rebase
Comment 4 M S Vishwanath Bhat 2014-06-16 08:25:11 EDT
Looks like it is not fixed completely.

[root@rhsauto023 ~]# gluster pool list
UUID                                    Hostname        State
e3aea7f5-7cce-43a5-958d-668723481746    rhsauto024.lab.eng.blr.redhat.com       Connected 
74c3fbc5-cd98-4e56-96ad-581c6ccd909b    rhsauto028.lab.eng.blr.redhat.com       Connected 
52e74907-b256-41c1-b2dc-f1ae3df4433d    rhsauto029.lab.eng.blr.redhat.com       Connected 
44c5258e-2db1-482a-9521-1d768b7c7df5    localhost       Connected 


But now it looks better than before. But it would be great to have last thing here fixed.

UUID                                    Hostname        State
e3aea7f5-7cce-43a5-958d-668723481746    rhsauto024.lab.eng.blr.redhat.com       Connected 
44c5258e-2db1-482a-9521-1d768b7c7df5    10.70.36.253    Connected 
52e74907-b256-41c1-b2dc-f1ae3df4433d    rhsauto029.lab.eng.blr.redhat.com       Connected 
74c3fbc5-cd98-4e56-96ad-581c6ccd909b    localhost       Connected 


Re-opening it for now. But this is very low priority. So if you think that output is just fine, please move the bug to verified.


Tested in version: glusterfs-3.6.0.14-1.el6rhs.x86_64
Comment 5 Vijaikumar Mallikarjuna 2014-06-20 06:25:09 EDT
Patch submitted upstream
Comment 7 Vijaikumar Mallikarjuna 2014-07-02 07:13:01 EDT
Patch https://code.engineering.redhat.com/gerrit/28335 posted
Comment 11 Triveni Rao 2015-02-18 08:23:18 EST
This bug is not fixed in RHS3.0.4 build 44 also

[root@rhsauto032 bug]# glsterfsd --version
bash: glsterfsd: command not found
[root@rhsauto032 bug]# glusterfsd --version
glusterfs 3.6.0.44 built on Feb  9 2015 01:27:51
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2013 Red Hat, Inc. <http://www.redhat.com/>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
It is licensed to you under your choice of the GNU Lesser
General Public License, version 3 or any later version (LGPLv3
or later), or the GNU General Public License, version 2 (GPLv2),
in all cases as published by the Free Software Foundation.
[root@rhsauto032 bug]# 

[root@rhsauto032 bug]# rpm -qa | grep gluster
gluster-nagios-common-0.1.4-1.el6rhs.noarch
glusterfs-api-3.6.0.44-1.el6rhs.x86_64
glusterfs-server-3.6.0.44-1.el6rhs.x86_64
gluster-nagios-addons-0.1.14-1.el6rhs.x86_64
samba-glusterfs-3.6.509-169.4.el6rhs.x86_64
glusterfs-libs-3.6.0.44-1.el6rhs.x86_64
glusterfs-3.6.0.44-1.el6rhs.x86_64
glusterfs-cli-3.6.0.44-1.el6rhs.x86_64
glusterfs-geo-replication-3.6.0.44-1.el6rhs.x86_64
vdsm-gluster-4.14.7.3-1.el6rhs.noarch
glusterfs-fuse-3.6.0.44-1.el6rhs.x86_64
glusterfs-rdma-3.6.0.44-1.el6rhs.x86_64
[root@rhsauto032 bug]# 

[root@rhsauto032 bug]# gluster pool list
UUID                                    Hostname        State
405f2e37-ed9a-4cc0-8c60-32e66670970d    rhsauto040.lab.eng.blr.redhat.com       Connected 
35466896-5fca-4ee9-8e89-ae6ed0933c2f    rhsauto034.lab.eng.blr.redhat.com       Connected 
6f83d7db-2305-458d-8fbf-01c6c7ccf318    localhost       Connected 
[root@rhsauto032 bug]# 

hence re-opening the bug.
Comment 12 Atin Mukherjee 2015-02-23 00:11:38 EST
From the recent comment history it looks like the fix is incomplete and its not feasible to take this BZ for 3.0.4 at this moment. Moving the target milestone to 3.1
Comment 13 Vijaikumar Mallikarjuna 2015-02-23 01:06:07 EST
Hi Triveni,

From the gluster version in comment# 11. glusterfs-3.6.0.44 was built on Feb-09

> [root@rhsauto032 bug]# glusterfsd --version
> glusterfs 3.6.0.44 built on Feb  9 2015 01:27:51
> Repository revision: git://git.gluster.com/glusterfs.git


But the fix for this bug patch# 28335 was merged on Feb-17 9:16am.
I think you have tested with a build where the fix is not available. Can you please try the test with 'glusterfs-3.6.0.46-1'
Comment 14 Triveni Rao 2015-02-24 04:09:19 EST
This bug has been verified. no issues found.

[root@rhsauto032 ~]# gluster pool list
UUID                                    Hostname                                State
e56dca30-54cd-45ba-bd7b-6838d2e1c003    rhsauto034.lab.eng.blr.redhat.com       Connected 
a2bcb4c3-a2c4-4b8a-903c-14c9aa45ceab    rhsauto040.lab.eng.blr.redhat.com       Connected 
86741341-4584-4a10-ac2a-32cf9230c967    localhost                               Connected 
[root@rhsauto032 ~]# 

[root@rhsauto032 ~]# glsterfsd --version
bash: glsterfsd: command not found
[root@rhsauto032 ~]# glusterfsd --version
glusterfs 3.6.0.46 built on Feb 20 2015 12:32:38
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2013 Red Hat, Inc. <http://www.redhat.com/>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
It is licensed to you under your choice of the GNU Lesser
General Public License, version 3 or any later version (LGPLv3
or later), or the GNU General Public License, version 2 (GPLv2),
in all cases as published by the Free Software Foundation.
[root@rhsauto032 ~]# 

[root@rhsauto032 ~]# rpm -qa | grep gluster
gluster-nagios-common-0.1.4-1.el6rhs.noarch
glusterfs-3.6.0.46-1.el6rhs.x86_64
glusterfs-server-3.6.0.46-1.el6rhs.x86_64
gluster-nagios-addons-0.1.14-1.el6rhs.x86_64
samba-glusterfs-3.6.509-169.4.el6rhs.x86_64
glusterfs-libs-3.6.0.46-1.el6rhs.x86_64
glusterfs-api-3.6.0.46-1.el6rhs.x86_64
glusterfs-cli-3.6.0.46-1.el6rhs.x86_64
glusterfs-geo-replication-3.6.0.46-1.el6rhs.x86_64
vdsm-gluster-4.14.7.3-1.el6rhs.noarch
glusterfs-fuse-3.6.0.46-1.el6rhs.x86_64
glusterfs-rdma-3.6.0.46-1.el6rhs.x86_64
[root@rhsauto032 ~]#
Comment 15 Bhavana 2015-03-23 16:55:00 EDT
updated the doc text.
Comment 17 errata-xmlrpc 2015-03-26 02:33:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0682.html

Note You need to log in before you can comment on or make changes to this bug.