Bug 987549 - ctrl-[+-0] zoom in/out/native keyboard shortcuts don't work in fullscreen (with mouse over the control bar)
ctrl-[+-0] zoom in/out/native keyboard shortcuts don't work in fullscreen (wi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity low
: beta
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
:
Depends On: 1179477
Blocks: 989407
  Show dependency treegraph
 
Reported: 2013-07-23 11:53 EDT by David Jaša
Modified: 2015-07-22 02:30 EDT (History)
8 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-1.el6
Doc Type: Bug Fix
Doc Text:
No doc needed
Story Points: ---
Clone Of:
: 989407 (view as bug list)
Environment:
Last Closed: 2015-07-22 02:30:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1322 normal SHIPPED_LIVE virt-viewer and spice-gtk bug fix and enhancement update 2015-07-20 13:53:14 EDT

  None (edit)
Description David Jaša 2013-07-23 11:53:59 EDT
Description of problem:
ctrl-[+-0] zoom in/out/native keyboard shortcuts don't work in fullscreen (with mouse over the control bar)

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-2.el6.x86_64
spice-gtk-0.20-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. connect to a VM
2. make sure that zoom keyboard shortcuts work when windowed: with mouse cursor outside of guest area, press ctrl and minus keyboard shortcut (the guest is zoomed out); press ctrl and zero to get to normal size
3. put the guest in full screen
4. move the mouse pointer of top of "leave fullscreen"/.../exit control bar
5. press ctrl with minus again

Actual results:
nothing happens

Expected results:
guest should get zoomed out

Additional info:
Comment 1 Andrew Cathrow 2013-07-24 08:37:19 EDT
Need to ensure that we have appropriate documentation on this as it's not immediately clear
Comment 2 David Jaša 2013-07-24 08:57:46 EDT
(In reply to Andrew Cathrow from comment #1)
> Need to ensure that we have appropriate documentation on this as it's not
> immediately clear

The shortcuts are indicated right in the menu, so no other documentation is necessary and this is not a future feature.
Comment 3 Marc-Andre Lureau 2013-07-25 06:01:23 EDT
David, there is a slight difference between the keyboard accelerator indicated in the gtk menu and "global" key binding (when the menu is not visibile).

I sent ctrl-0 patches to ML a few days ago, adding ctrl+ and ctrl- should be trivial now.
Comment 4 hyao@redhat.com 2013-07-29 05:12:19 EDT
I can reproduce this bug with the following packages: 
# rpm -qa virt-viewer spice-gtk
virt-viewer-0.5.2-18.el6_4.2.x86_64
spice-gtk-0.14-7.el6.x86_64
Comment 7 Jonathon Jongsma 2015-02-09 11:40:19 EST
Will be fixed by rebase to 2.0
Comment 9 CongDong 2015-03-10 04:52:00 EDT
Can reproduce with virt-viewer-0.6.0-11.el6.x86_64

Verify with virt-viewer-2.0-2.el6.x86_64

Steps:
1. virt-viewer $vm
2. make sure that zoom keyboard shortcuts work when windowed: with mouse cursor outside of guest area, press ctrl and minus keyboard shortcut (the guest is zoomed out); press ctrl and zero to get to normal size
3. put the guest in full screen
4. move the mouse pointer of top of "leave fullscreen"/.../exit control bar
5. press "ctrl_+ ", "ctrl_-" and "ctrl_0"

Result:
Step 5, ctrl +/-/0 worked when make the guest fullscreen by move mouse to the top bar of the window.

As the result, move to VERIFIED
Comment 11 errata-xmlrpc 2015-07-22 02:30:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html

Note You need to log in before you can comment on or make changes to this bug.