Bug 987579 - Adjusting Preferences Dialog
Adjusting Preferences Dialog
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-23 13:34 EDT by Cory Scheviak
Modified: 2013-09-30 19:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:15:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preference-dialog enable option on left (340.43 KB, image/png)
2013-08-07 13:32 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Cory Scheviak 2013-07-23 13:34:58 EDT
Description of problem:
Originally, the preferences dialog had a text label on the right side of the top of the window which changed from "Enabled" to "Disabled" depending upon the state of the toggle button representing the state of auto-healing for the client. It was decided the button should go in the top left and the label in the top middle/right, and the label become static.

Version-Release number of selected component (if applicable):
# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.17-1
subscription-manager: 1.8.13-1.git.2.a8754ee.fc18
python-rhsm: 1.8.14-1.git.1.c54203f.fc18


How reproducible:
Always

Steps to Reproduce:
1. Register with subscription manager
2. Run subscription-manager-gui
3. Open preferences dialog from menu

Actual results:
Button on right text on left

Expected results:
Button on left text on right

Additional info:
Comment 1 RHEL Product and Program Management 2013-07-23 13:48:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Cory Scheviak 2013-07-31 10:33:18 EDT
6d4c9f1808d8da613caf7a9781a4bce940ad19fc

subscription-manager.git
Comment 6 John Sefler 2013-08-05 11:40:56 EDT
FailedQA.  The expected changes do not appear to have been fully merged to axiom RHEL5.10 branch.  The checkbox is still behaving as a check-toggle-box-button.

[root@jsefler-5 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.18-1
subscription-manager: 1.8.16-1.el5
python-rhsm: 1.8.16-1.el5
Comment 7 Jesus M. Rodriguez 2013-08-07 11:16:10 EDT
fixed on axiom: ea5fd0409b2af6545ba00d5ab895f85c0cc8037b

Version 1.8.17-1
Comment 8 Sharath Dwaral 2013-08-07 13:32:18 EDT
Created attachment 784012 [details]
preference-dialog enable option on left

Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.8.18-1.el5
subscription-manager-migration-data-1.11.3.2-1.git.0.14f9d59.el5
python-rhsm-1.8.16-1.el5
subscription-manager-migration-1.8.18-1.el5
subscription-manager-1.8.18-1.el5
subscription-manager-firstboot-1.8.18-1.el5
python-rhsm-debuginfo-1.8.16-1.el5
subscription-manager-debuginfo-1.8.18-1.el5

Verification:
See attachment

VERIFIED
Comment 12 errata-xmlrpc 2013-09-30 19:15:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.