This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 987598 - SELinux is preventing systemd-tmpfile from 'setattr' accesses on the directory snd.
SELinux is preventing systemd-tmpfile from 'setattr' accesses on the director...
Status: CLOSED DUPLICATE of bug 987597
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:443398bc1b33573e97d77938dad...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 14:38 EDT by Nicolas Mailhot
Modified: 2013-07-24 18:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 18:23:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-07-23 14:38:45 EDT
Description of problem:
SELinux is preventing systemd-tmpfile from 'setattr' accesses on the directory snd.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que systemd-tmpfile devrait être autorisé à accéder setattr sur snd directory par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_tmpfiles_t:s0
Target Context                system_u:object_r:device_t:s0
Target Objects                snd [ dir ]
Source                        systemd-tmpfile
Source Path                   systemd-tmpfile
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.0-0.rc2.git1.1.fc20.x86_64 #1
                              SMP Tue Jul 23 14:24:16 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-23 20:26:28 CEST
Last Seen                     2013-07-23 20:26:28 CEST
Local ID                      bd288990-845b-43a3-b48d-afba2b9d3e92

Raw Audit Messages
type=AVC msg=audit(1374603988.542:24): avc:  denied  { setattr } for  pid=570 comm="systemd-tmpfile" name="snd" dev="devtmpfs" ino=10539 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=dir


Hash: systemd-tmpfile,systemd_tmpfiles_t,device_t,dir,setattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.11.0-0.rc0.git3.1.fc20.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-07-24 18:23:21 EDT

*** This bug has been marked as a duplicate of bug 987597 ***

Note You need to log in before you can comment on or make changes to this bug.