Bug 987782 - Layout switching is still broken
Layout switching is still broken
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 03:20 EDT by Ilya
Modified: 2015-02-17 11:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 976068
Environment:
Last Closed: 2015-02-17 11:19:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilya 2013-07-24 03:20:34 EDT
Bug was closed with 1.9.1-16.fc19 update, but it still here, and wasn't fixed. Also, bug reproduces in 1.9.1-17.fc19. 

+++ This bug was initially created as a clone of Bug #976068 +++

Description of problem:
Starting with version 3.8.3 of gnome-settings-daemon, I can't switch layouts anymore. I've set up switching by Alt+Shift in GNOME System Settings (since there's no such option in Cinnamon Control Center), and it doesn't work now. Nothing happens when I press the combination. There's an interesting exception, though: switching works in GDM and GNOME Screensaver. It also works when I switch by mouse in system tray.

Version-Release number of selected component (if applicable):
Got broken by this update: 
https://admin.fedoraproject.org/updates/FEDORA-2013-10587/gnome-shell-3.8.3-1.fc19,mutter-3.8.3-1.fc19,gnome-settings-daemon-3.8.3-2.fc19,control-center-3.8.3-1.fc19?_csrf_token=f2030806c864bcd299b8bfe3874db2d6a0dc1f57
Worked fine before this update. There was a delay, but it was better than nothing.

How reproducible:
Always. I tried clearing settings, it doesn't help.

Steps to Reproduce:
1. Install Cinnamon.
2. Set two different layouts in GNOME Control Center (Region and Language)
3. Set Alt+Shift as a switching combination (Modifiers-only switch to next source).

Sorry for my English.

--- Additional comment from leigh scott on 2013-07-10 14:18:51 EDT ---

This was removed from gnome-settings-daemon-3.8.3

https://git.gnome.org/browse/gnome-settings-daemon/commit/?h=gnome-3-8&id=ec7b1ec37e9755c304a51faea876c31c50df42f9

I have submitted a cinnamon (cinnamon-1.9.1-14.fc19) build to return this function.

--- Additional comment from Fedora Update System on 2013-07-10 15:36:18 EDT ---

cinnamon-1.9.1-15.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.9.1-15.fc19

--- Additional comment from Fedora Update System on 2013-07-11 23:19:24 EDT ---

Package cinnamon-1.9.1-15.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-1.9.1-15.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12859/cinnamon-1.9.1-15.fc19
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-07-12 09:01:36 EDT ---

cinnamon-1.9.1-16.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-1.9.1-16.fc19

--- Additional comment from Fedora Update System on 2013-07-13 23:32:12 EDT ---

cinnamon-1.9.1-16.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Ilya on 2013-07-18 02:31:59 EDT ---

update cinnamon to ver 1.9.1-15.fc19 and then 1.9.1-16.fc19. "Still dead". May be i have to do something else?

--- Additional comment from Ilya on 2013-07-18 14:42:37 EDT ---

update 1.9.1-15.fc19 - same result, layout doesn't switching. Please, fix it!

--- Additional comment from Ilya on 2013-07-18 14:44:13 EDT ---

sorry, i mean 1.9.1-17.fc19
Comment 1 Fedora End Of Life 2015-01-09 14:04:35 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 2 Fedora End Of Life 2015-02-17 11:19:58 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.