Bug 987823 - Do not ship the Playground repo
Do not ship the Playground repo
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Maciej Swiderski
Lukáš Petrovický
:
Depends On:
Blocks: 988037
  Show dependency treegraph
 
Reported: 2013-07-24 04:52 EDT by Lukáš Petrovický
Modified: 2014-08-06 16:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 988037 (view as bug list)
Environment:
Last Closed: 2014-08-06 16:15:52 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
standalone.sh (9.75 KB, application/x-shellscript)
2013-08-14 22:37 EDT, Ryan Zhang
no flags Details
server.log (388.25 KB, text/x-log)
2013-08-14 22:41 EDT, Ryan Zhang
no flags Details

  None (edit)
Description Lukáš Petrovický 2013-07-24 04:52:45 EDT
At the moment, kie-ide has a hardcoded playground Git project. There is a wide agreement that we shouldn't ship any such repository, so I kindly ask for this to be removed in the productized version.
Comment 2 Maciej Swiderski 2013-07-31 12:40:17 EDT
Load of playground repos has been disabled by default (only for hosted mode and jbpm installer it is enabled). Here are commits for this change:

kie-wb
https://github.com/droolsjbpm/kie-wb-distributions/commit/514100d036691c87622665ba942300c6457ee0f1

jbpm-console-ng
https://github.com/droolsjbpm/jbpm-console-ng/commit/2e5fd1592f88e549613fdee10caca0523cf6c7f6

jbpm
https://github.com/droolsjbpm/jbpm/commit/b8082002e38a525c173236bbc85d210ed0d2f9e6

When running on application server it can be easily enabled by setting system property as follows:
- for jbpm console use: -Dorg.jbpm.console.demo=true
- for kie-wb use: -Dorg.kie.wb.demo=true
- for kie-drools-wb use: -Dorg.kie.droolswb.demo=true 

Since that disables both Group and Repository load it means there will be nothing available (from authoring point of view) when application starts, to setup initial group/repository kie-config-cli tool can be used to bootstrap system repository.
Comment 3 Maciej Swiderski 2013-08-05 13:32:32 EDT
based on discussion slight change was applied to make the playground enabled by default with possibility to disable it via system property. In addition property names were unified to single one:
org.kie.demo

To disable it set system property to false:
-Dorg.kie.demo=false

that will disable completely playground repository load.

Commits:
https://github.com/droolsjbpm/kie-wb-distributions/commit/1ea861bf7c3ca85bbebead2a8f674124ae201a88

https://github.com/droolsjbpm/jbpm-console-ng/commit/7c5643c3bb822f3097ccf63b52e4417f55a98830
Comment 4 Ryan Zhang 2013-08-14 22:37:54 EDT
Created attachment 786758 [details]
standalone.sh
Comment 5 Ryan Zhang 2013-08-14 22:40:02 EDT
I tried this on "sync.2013.08.07".
I added system property -Dorg.kie.demo=false, but the playground is still installed.
Attached standalone.sh and server.log.
Move to Assigned status for investigation.
Comment 6 Ryan Zhang 2013-08-14 22:41:04 EDT
Created attachment 786759 [details]
server.log
Comment 7 Maciej Swiderski 2013-08-15 05:01:15 EDT
Ryan, did you remove .niogit folder from previous installations? As it might be it is still present there so kie-wb does not need to load it from remote and just uses what has already been there.
Comment 8 Ryan Zhang 2013-08-20 03:41:20 EDT
Yes, I tried with removing .niogit folder and the jbpm-playground still appeared.

And beside this, for requirement of the product, we can't modifiy the standalone.sh of EAP.
May I suggest that we keep this option inside the war.

For example, we have an properties.file inside the kie-wb.war that we can patch easily from "false" to "true".
Comment 10 Lukáš Petrovický 2013-09-02 10:48:24 EDT
Repo is still shipped in ER2, but is disabled by default. Since this is the intended behavior, VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.