Bug 988037 - Trying to create new process blocks with missing path
Trying to create new process blocks with missing path
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On: 987823
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-07-24 10:57 EDT by Eric D. Schabell
Modified: 2014-08-06 16:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 987823
Environment:
Last Closed: 2014-08-06 16:06:44 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric D. Schabell 2013-07-24 10:57:56 EDT
I have started working on DR6 evaluation, wanting to try out my customer evaluation demo (https://github.com/eschabell/brms-customer-evaluation-demo).

I can't create a new process definition as it complains of a missing path that I can't edit. It has to do with no repository first being selected:

This was done on the EAP 6.1, then unzip the BPMS over that.

The real problem is that the user should not be allowed to create something unless they have a valid path selected.

If only the option to create a  "process" is not disabled when no path is selected this is a jBPM Designer related error.

A more obvious warning should be displayed other than the smaller "No path selected" message.

Bug raised after discussion on bpm lists.
Comment 1 manstis 2013-07-25 07:54:47 EDT
Tiho, please check the "New asset" menu and popup has "Process" disabled if a project is not selected in the Project Explorer. I've checked the drools-wb type assets and they're all disabled if not path is selected. Thanks, Mike
Comment 2 Tihomir Surdilovic 2013-08-29 14:08:45 EDT
This should no longer be an issue. Needs to be retested.
Comment 3 Zuzana Krejčová 2013-09-19 05:04:28 EDT
I see no change from DR6 regarding this issue.
Comment 4 Kris Verlaenen 2013-09-19 19:30:39 EDT
This will be fixed is https://bugzilla.redhat.com/show_bug.cgi?id=1003622 is solved (as you won't be able to select New Process if no path is selected).
Comment 5 Tihomir Surdilovic 2013-09-23 12:15:09 EDT
fixed in designer master and 6.0.x branches
Comment 9 Sona Mala 2013-10-16 06:29:31 EDT
Verified for ER4.

I tried this scenarios:
  - an empty repository (no project and no package are selected)
           -> result: Business Process is disabled in drop-down menu
  - operation save of data modeler cause that Path is reset to Repository dir
           -> result: Business Process is disabled in drop-down menu
  - in technical view I go to the repository dir and then switch back to the business view:
           -> result: Business Process is disabled in drop-down menu

Note You need to log in before you can comment on or make changes to this bug.