Bug 987872 - fail to add 10gen-mms-agent-0.1 to app
fail to add 10gen-mms-agent-0.1 to app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
: 987264 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 06:57 EDT by Yan Du
Modified: 2015-05-14 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:56:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2013-07-24 06:57:20 EDT
Description of problem:
create a python app and embed 10gen-mms-agent-0.1 after deploying settings.py to the app, fail to add 10gen-mms-agent-0.1 and show Adding 10gen-mms-agent-0.1 to application 'py1' ... Cartridge '10gen-mms-agent-0.1' can not be added with out cartridge '10gen-mms-agent'.


[root@Daphne test]# rhc cartridge add -a py1 -c 10gen-mms-agent-0.1
Adding 10gen-mms-agent-0.1 to application 'py1' ... Cartridge '10gen-mms-agent-0.1' can not be added with out cartridge '10gen-mms-agent'.


Version-Release number of selected component (if applicable):
devenv_3545


How reproducible:
Always


Steps to Reproduce:
1. rhc app create py1 python-2.6 mongodb-2.2
2. deploy settings.py in repo and git push
3. rhc cartridge add -a py1 -c 10gen-mms-agent-0.1


Actual results:
Adding 10gen-mms-agent-0.1 to application 'py1' ... Cartridge '10gen-mms-agent-0.1' can not be added with out cartridge '10gen-mms-agent'.


Expected results:
10gen-mms-agent-0.1 should be added successfully
Comment 1 Jhon Honce 2013-07-24 10:55:37 EDT
*** Bug 987264 has been marked as a duplicate of this bug. ***
Comment 2 Dan McPherson 2013-07-24 12:35:22 EDT
https://github.com/openshift/origin-server/pull/3153
Comment 4 Yan Du 2013-07-25 22:05:18 EDT
verified on devenv_3562

10gen-mms-agent-0.1 can be added to app after deploying settings.py

[root@Daphne py1]# rhc cartridge add -a py1 -c 10gen-mms-agent-0.1
Adding 10gen-mms-agent-0.1 to application 'py1' ... done

10gen-mms-agent-0.1 (10gen Mongo Monitoring Service Agent)
----------------------------------------------------------
  Gears:          Located with python-2.6, mongodb-2.2
  Monitoring URL: https://mms.10gen.com/

10gen-mms-agent added. 
Please configure your mongodb host at https://mms.10gen.com/ to start monitoring performance
data.
Monitoring URL: https://mms.10gen.com/


show correctly message if without deploying settings.py

[root@Daphne py1]# rhc cartridge add -c 10gen-mms-agent-0.1
Adding 10gen-mms-agent-0.1 to application 'py1' ... 
Missing settings.py file:
/var/lib/openshift/8f26f1b0f59611e29eb922000aa4361c/app-root/runtime/repo/.openshift/mms/settings.py
This file is part of the agent zip file: 10gen-mms-agent-<group-name>.zip
The zip file is available to download from https://mms.10gen.com/ after you register with their
service.
It contains your 10gen MMS credentials and is required for running the agent.
You will need to add this file and then do a git commit and push before you can embed the
10gen-mms-agent cartridge.

move to verified.

Note You need to log in before you can comment on or make changes to this bug.