Bug 98793 - defaultroute fails for smtp sending (port 25)
defaultroute fails for smtp sending (port 25)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-08 15:57 EDT by John Reiser
Modified: 2015-01-07 19:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-17 05:43:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2003-07-08 15:57:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
Dialup USB modem connection, manual wvdial, manual copy of DNS from
/var/log/messages to Network Configuration DNS tab [see bug 98786, bug 98790]. 
I can ping by name, surf (http), ssh, receive mail (POP3) in Evolution, but
sending mail via SMTP from Evolution gets "Could not connect to <smtp_hostname>
port 25: no route to host."

Version-Release number of selected component (if applicable):
ppp-2.4.1-10

How reproducible:
Always

Steps to Reproduce:
1.Configure USB modem connection, requesting auto IP and auto DNS.  Manual
wvdial to workaround bug 98786.  Manually forward DNS server settings from
/var/log/messages to Network Configuration DNS tab to workaround bug 98790.
2.Try to send mail using SMTP from Evolution.
3.
    

Actual Results:  "Could not connect to <smtp_host> port 25: No route to host"

Expected Results:  No complaints sending mail.

Additional info:

-----netstat -r
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
nas12.bellevue1 *               255.255.255.255 UH        0 0          0 ppp0
169.254.0.0     *               255.255.0.0     U         0 0          0 lo
127.0.0.0       *               255.0.0.0       U         0 0          0 lo
default         nas12.bellevue1 0.0.0.0         UG        0 0          0 ppp0
-----

-----ps ax | grep ppp
 2984 ?        S      0:00 /usr/sbin/pppd 115200 modem crtscts defaultroute useh
-----

So wvdial did ask pppd to establish a default route using the modem, and
according to netstat there is a route with mask 0.0.0.0 .
Comment 1 John Reiser 2003-07-08 23:50:13 EDT
The correct citations are
bug 98781  failed to activate ppp0 with eror 28  [workaround: manual wvdial]
bug 98786  auto DNS ignored  [workaround: manual copy from /var/log/messages to
Network Configure > DNS tab]

[Sorry; my list got skewed while I was trying to be precise.]
Comment 2 Thomas Woerner 2004-08-17 05:43:16 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.