Bug 987953 - OVIRT35 - [RFE] [oVirt] [webadmin] Tree doesn't refresh
OVIRT35 - [RFE] [oVirt] [webadmin] Tree doesn't refresh
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.5.0
Assigned To: Alexander Wels
movciari
ux
: Improvement
: 1057081 1071835 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 09:02 EDT by Mike Kolesnik
Modified: 2016-02-10 14:45 EST (History)
7 users (show)

See Also:
Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-17 08:37:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 26161 master MERGED webadmin: System tree refresh Never

  None (edit)
Description Mike Kolesnik 2013-07-24 09:02:24 EDT
Description of problem:
After adding/removing/renaming entities the tree on the left doesn't refresh, even after waiting for some time.

This causes the tree to be stale and point at missing entities, or not show new/renamed ones which is very bad user experience.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Expand the tree using "Expand All" button
2. Add a new data center "test"

  
Actual results:
The new data center doesn't appear on the tree


Expected results:
the new data center should appear in the tree


Additional info:
It happens with any entity that appears on the tree.
The tree doesn't ever refresh unless manually.
Comment 1 Einav Cohen 2013-07-31 10:36:15 EDT
we have a "refresh" button that allows the user to at least refresh the tree-state on demand. 
I agree, of course, that automatic refresh would really improve the UX, however it is a bit tricky to do.
Comment 2 Einav Cohen 2014-04-17 12:59:14 EDT
*** Bug 1057081 has been marked as a duplicate of this bug. ***
Comment 3 Einav Cohen 2014-05-08 08:49:28 EDT
*** Bug 1071835 has been marked as a duplicate of this bug. ***
Comment 4 Sandro Bonazzola 2014-10-17 08:37:38 EDT
oVirt 3.5 has been released and should include the fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.