Bug 987971 - Redirect to 'Welcome page' in case of invalid URL
Redirect to 'Welcome page' in case of invalid URL
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Alon Bar-Lev
integration
:
: 1004406 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 09:39 EDT by Pavel Stehlik
Modified: 2013-09-23 06:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 17:15:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Stehlik 2013-07-24 09:39:59 EDT
Description of problem:
Try 'https://FQDN/blah' => in case this 404 Error is called, we should offer Welcome page.


Version-Release number of selected component (if applicable):
ovirt-engine-3.3.0-0.3.beta1.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. install ovirt-engine
2. try http[s]://{FQDN|IP}/something-weird
3.

Actual results:
404 Error page

Expected results:
Welcome page should be shown

Additional info:
Comment 1 Einav Cohen 2013-08-16 17:04:18 EDT
I am not sure if we can do this, since AFAIK - we can't assume that all web-applications installed on the server actually belong to oVirt.
[BTW - if you will try to access a non-existing page in the oVirt context, e.g. https://FQDN/webadmin/bla, you will get the oVirt 404 page, which is being automatically redirected to the welcome page]

@Alon - thoughts?
Comment 2 Alon Bar-Lev 2013-08-16 17:12:32 EDT
(In reply to Einav Cohen from comment #1)
> I am not sure if we can do this, since AFAIK - we can't assume that all
> web-applications installed on the server actually belong to oVirt.
> [BTW - if you will try to access a non-existing page in the oVirt context,
> e.g. https://FQDN/webadmin/bla, you will get the oVirt 404 page, which is
> being automatically redirected to the welcome page]
> 
> @Alon - thoughts?

I agree, we should not assume we own the entire web server, at the context of ovirt we do redirect to a special page.

In ovirt-engine-3.3 we ask the user if he would like to install default web page to redirect to ovirt.

We can add also as user if he want to override default apache ErrorDocument, and redirect to our own page, but I think it is a bad practice to do so, and far from being well behaved application.

There were requests of users to be able to install their own application on the engine machine, any global change will cause conflicts.

Please keep in mind that server administrator can always configure his server to behave as he likes, especially in this regard, this is standard apache configuration.

So I suggest not to perform request.
Comment 3 Einav Cohen 2013-08-16 17:15:05 EDT
thanks, Alon. agreed. closing.
Comment 4 Pavel Stehlik 2013-09-23 06:00:19 EDT
*** Bug 1004406 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.