Bug 988021 - CD images not displayed / GWT RPC Serizalization issue
CD images not displayed / GWT RPC Serizalization issue
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity high
: ---
: 3.3
Assigned To: vszocs
ux
:
: 988407 988751 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 10:31 EDT by Lior Vernia
Modified: 2015-05-04 21:43 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 03:33:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17330 None None None Never

  None (edit)
Description Lior Vernia 2013-07-24 10:31:56 EDT
Description of problem:

CD images that exist in ISO domain don't appear in the attach CD to VM list box.


Version-Release number of selected component (if applicable):

oVirt 3.3


How reproducible:

Always (for me).


Steps to Reproduce:
1. Create ISO domain.
2. Add CD image there.
3. Create a VM.

Actual results:

The attach CD list box is empty.


Expected results:

There should be an option to pick the CD image that exists in the domain.


Additional info:

The engine log doesn't display any error. On the contrary, a log message is displayed that shows that the CD image is actually retrieved by vdsbroker and irsbroker, and just isn't displayed in the UI.
Comment 1 Michal Skrivanek 2013-07-25 06:33:15 EDT
it seems to work, did you create/open the VM while the iso already existed on iso domain? The attach CD you mean in spice client or in user portal?
Comment 2 Lior Vernia 2013-07-25 07:36:07 EDT
Hey Michal,

I created the VM before the ISO existed on the domain, but obviously tried to attach the ISO to the CD drive of the VM after I put it in the domain (manually, not via image-uploader). By "attaching" I mean in either the Edit VM dialog or the Run Once dialog, both in the webadmin portal. The refresh button didn't help either. I have heard suggestions that this might have been due to the GWT upgrade.

Lior.
Comment 3 Michal Skrivanek 2013-07-25 11:17:47 EDT
per Vojtech this is a general GWT RPC serialization issue, assigning to him
Comment 4 Juan Hernández 2013-07-25 18:07:03 EDT
*** Bug 988407 has been marked as a duplicate of this bug. ***
Comment 5 Michal Skrivanek 2013-07-26 06:31:46 EDT
*** Bug 988751 has been marked as a duplicate of this bug. ***
Comment 6 Itamar Heim 2013-07-28 12:35:59 EDT
vojtech - fixed by now?
Comment 7 Michal Skrivanek 2013-07-30 06:18:50 EDT
workaround solution merged to master:
http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=30a941a4b3ed8e46053880a5fd6de325907a9b52

Einav, do want to track it for another fix or is this good enough?
Comment 8 vszocs 2013-07-30 10:26:09 EDT
(In reply to Lior Vernia from comment #0)
> The engine log doesn't display any error. On the contrary, a log message is
> displayed that shows that the CD image is actually retrieved by vdsbroker
> and irsbroker, and just isn't displayed in the UI.

The error was in server.log - GWT RPC servlet (WebModePayloadSink:636) failed while attempting to serialize RepoImage business entity to be passed back to WebAdmin.

(In reply to Itamar Heim from comment #6)
> vojtech - fixed by now?

Yes, this issue is already fixed.

Juan's initial solution [http://gerrit.ovirt.org/#/c/17330/] was later reverted [http://gerrit.ovirt.org/#/c/17349/] because we found the root cause and fixed RepoImage entity itself [http://gerrit.ovirt.org/#/c/17352/].
Comment 9 Itamar Heim 2013-08-21 12:40:45 EDT
as RC is built, moving to ON_QA (hopefully did not catch incorrect bugs when doing this)
Comment 10 Itamar Heim 2013-09-23 03:33:13 EDT
closing as this should be in 3.3 (doing so in bulk, so may be incorrect)

Note You need to log in before you can comment on or make changes to this bug.