Bug 988172 - Installation Guide should indicate which features of RHEV that spicec and the RHEL 6.4 version of virt-viewer do not support
Installation Guide should indicate which features of RHEV that spicec and the...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Tim Hildred
ecs-bugs
:
Depends On:
Blocks: 998191
  Show dependency treegraph
 
Reported: 2013-07-24 20:59 EDT by Bryan Yount
Modified: 2017-05-11 08:05 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 998191 (view as bug list)
Environment:
Build: CSProcessor Builder Version 1.10 Build Name: 12875, Installation Guide-3.2-6 Build Date: 20-06-2013 11:28:46 Topic ID: 7848-429866 [Latest]
Last Closed: 2014-04-06 23:07:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 425693 None None None Never

  None (edit)
Description Bryan Yount 2013-07-24 20:59:07 EDT
Title: 2.3.2. Red Hat Enterprise Virtualization Manager Client Requirements

Describe the issue:
The RHEL 5 client (spicec) is listed as a supported client but it does not support certain features such as Spice proxy and the WAN optimizations.

Suggestions for improvement:
Add an indicator to the spicec entry that not all features of 3.1/3.2 are supported. Perhaps include a note about what doesn't work.
Comment 2 Tim Hildred 2013-07-29 01:37:48 EDT
Hey Bryan,

Can you provide a list of unsupported features in the RHEL 5 spicec client?

- spice proxy
- wan optimizations
- ??

Do any of the other clients in that list also have limitations, or are they otherwise offering the same feature set?
Comment 3 Bryan Yount 2013-08-06 20:20:01 EDT
Hey Tim, sorry it took me a few days to get back to you as I was out of the office last week. Bugzilla really needs an Out of Office indicator.

(In reply to Tim Hildred from comment #2)
> Can you provide a list of unsupported features in the RHEL 5 spicec client?
> 
> - spice proxy
> - wan optimizations
> - ??

- Dynamic resolution resizing and scaling

Those were the only 3 things I could think of. We may need to ask Andy to verify that for us. Setting needinfo on him.

> Do any of the other clients in that list also have limitations, or are they
> otherwise offering the same feature set?

I believe RHEL 5 is the exception because it's the only OS on that list that is still stuck with "spicec" instead of "virt-viewer".
Comment 4 Andrew Cathrow 2013-08-07 19:54:03 EDT
David - what would be on the list.
I presume

wan, mime type support, proxy
Comment 6 Tim Hildred 2013-08-09 01:01:00 EDT
Hey Bryan,

That changes things a bit. The simplest way for me to understand is:

The RHEL 5 SPICE (spicec) client does not support:
- WAN optimizations
- dynamic console resizing
- proxying
- mime types

The RHEL 6.4 SPICE client (virt-viewer) does not support:
- ???


Those features are supported in the following operating systems using the following clients
- Operating System : Client
- ??? : ???

Thanks Bryan.

I've added a note about RHEL 5 that will probably be in the next z stream for 3.2. I'll add more when I hear more, but it may not be backported to 3.2.z in the immediate future.
Comment 7 Bryan Yount 2013-08-09 19:20:45 EDT
(In reply to Tim Hildred from comment #6)
> The RHEL 6.4 SPICE client (virt-viewer) does not support:
> - ???

- proxying

That's the only big feature I know of worth mentioning in the docs. Maybe David can also weigh in here?

> Those features are supported in the following operating systems using the
> following clients
> - Operating System : Client
> - ??? : ???

Not entirely sure how to help fill this list out. But I think you're looking for what operating systems and clients support all of the RHEV 3.2 features? If so, then...

Windows XP : virt-viewer-0.5.3-25 or higher
Windows 7  : virt-viewer-0.5.3-25 or higher

And eventually we'll add RHEL 6.5 to that list. Hope this helps.
Comment 8 Tim Hildred 2013-08-11 22:28:57 EDT
Hey David,

Can you help me fill in the blanks in comment #6? We're trying to get this bug fix backported into the upcoming 3.2.z release.

It looks like the only SPICE clients that support all of the newer RHEV/SPICE features are Windows clients?

For the record, RHEL 6.4 gets virt-viewer-0.5.2-18.el6_4.2.x86_64.
Comment 13 Tim Hildred 2013-08-13 03:30:12 EDT
I've moved the information about which features are supported. Now, the info is in a "note" directly after the client it applies to. Should be much clearer now.

Note You need to log in before you can comment on or make changes to this bug.