Bug 998191 - Installation Guide should indicate which features of RHEV that spicec and the RHEL 6.4 version of virt-viewer do not support
Installation Guide should indicate which features of RHEV that spicec and the...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.4.0
Unspecified Unspecified
high Severity high
: ---
: 3.4.0
Assigned To: Jodi Biddle
ecs-bugs
: Reopened
Depends On: 988172
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 00:56 EDT by Tim Hildred
Modified: 2014-11-09 17:29 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 988172
Environment:
Build: CSProcessor Builder Version 1.10 Build Name: 12875, Installation Guide-3.2-6 Build Date: 20-06-2013 11:28:46 Topic ID: 7848-429866 [Latest]
Last Closed: 2014-08-26 21:45:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 425693 None None None Never

  None (edit)
Description Tim Hildred 2013-08-18 00:56:33 EDT
+++ This bug was initially created as a clone of Bug #988172 +++

Title: 2.3.2. Red Hat Enterprise Virtualization Manager Client Requirements

Describe the issue:
The RHEL 5 client (spicec) is listed as a supported client but it does not support certain features such as Spice proxy and the WAN optimizations.

Suggestions for improvement:
Add an indicator to the spicec entry that not all features of 3.1/3.2 are supported. Perhaps include a note about what doesn't work.

--- Additional comment from Tim Hildred on 2013-08-11 22:48:26 EDT ---

For the time being, I've added this to the topic:

* The Red Hat Enterprise Linux 5 SPICE client (spicec) does not support all of the features present in the latest SPICE client. WAN optimizations, dynamic console resizing, proxying, and mime types are not supported.

* The versions of SPICE clients (virt-viewer) prior to the one shipped with Red Hat Enterprise Linux 6.5 do not support all of the features present in the latest SPICE client. Proxying is not supported. 

I believe this covers the original bug report, and all the information gathered so far. I'm going to move this to MODIFIED for now, and change it to ON_QA when I've staged it. I'll also be backporting this to the 3.2 docs when resources allow. 

--- Additional comment from Alison Young on 2013-08-13 00:29:43 EDT ---

Checked in: Red_Hat_Enterprise_Virtualization-Installation_Guide-3.3-en-US-3.3-3

Content is exactly what was asked for. 
--- Additional comment from Tim Hildred on 2013-08-13 03:30:12 EDT ---

I've moved the information about which features are supported. Now, the info is in a "note" directly after the client it applies to. Should be much clearer now.

--- Additional comment from Alison Young on 2013-08-15 22:40:06 EDT ---

Checked in: Red_Hat_Enterprise_Virtualization-Installation_Guide-3.3-en-US-3.3-4

Great thanks Tim, VERIFIED
Comment 2 Tim Hildred 2013-10-27 20:03:18 EDT
Reassigning to Jodi Biddle (jbiddle@redhat.com) as I am no longer working on Red Hat Enterprise Virtualization documentation.
Comment 3 Zac Dover 2013-12-09 00:43:52 EST
In accordance with Comment 1, I am closing this NOTABUG.
Comment 4 Jodi Biddle 2014-02-11 21:04:56 EST
Re-opening - related to customer case.
Comment 6 Jodi Biddle 2014-04-11 01:24:44 EDT
The table that Bryan makes frequent use of and would like to see in the documentation is here: 

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.3/html-single/Manager_Release_Notes/index.html#SPICE_Features 

Since there's obvious customer requirement for it, I think it should be included in the docs. It's not for us to make the product look good or bad; our only requirement is to help customers use it.
Comment 8 Zac Dover 2014-04-13 12:23:54 EDT
I have also provided instructions for setting up SPICE Proxy which were referred to in this KCS article https://access.redhat.com/site/solutions/425693

It's the circle of life. Here's the article:

https://bugzilla.redhat.com/show_bug.cgi?id=972453#c7

This comment, or some future version of it that remains in lockstep with RHEV as it develops, should be included in the Installation Guide until there's a good reason to no longer include it.
Comment 10 Julie 2014-08-26 21:45:47 EDT
Closing this bug as content is available in the current release already. Please file a new bug if you have further feedback.

Many thanks,
Julie

Note You need to log in before you can comment on or make changes to this bug.