Bug 988318 - CLI - after undefine operation on wsdl-host attribute of webservices subsystem and reload war with webservice can not be deployed
CLI - after undefine operation on wsdl-host attribute of webservices subsyste...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: EAP 6.2.0
Assigned To: Alessio Soldano
:
Depends On: 991240
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 05:51 EDT by Petr Sakař
Modified: 2014-06-18 03:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A bug that caused application deployments to fail when the wsdl-host attribute was undefined has been corrected in this release of JBoss EAP 6.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:23:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deployed war (3.81 KB, application/zip)
2013-07-25 05:51 EDT, Petr Sakař
no flags Details

  None (edit)
Description Petr Sakař 2013-07-25 05:51:56 EDT
Created attachment 778165 [details]
deployed war

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start AS
   ./jboss-eap-6.1/bin/standalone.sh
2. undefine value
   ./jboss-eap-6.1/bin/jboss-cli.sh -c "/subsystem=webservices/:undefine-attribute(name=wsdl-host)"
3. reload
   ./jboss-eap-6.1/bin/jboss-cli.sh -c "reload"
4. deploy war with web service
   ./jboss-eap-6.1/bin/jboss-cli.sh -c "deploy /tmp/CLIWebservicesWsdlPortTestCase.war"


Expected results:
deployed war

Actual results:
failure
{"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"CLIWebservicesWsdlPortTestCase.war\".INSTALL" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"CLIWebservicesWsdlPortTestCase.war\".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment \"CLIWebservicesWsdlPortTestCase.war\"
    Caused by: java.lang.IllegalStateException"}}}}


Server log
1-7) JBAS015012: Started FileSystemDeploymentService for directory /home/development/jbossqe/JBEAP-6.1.1-ER3/jboss-eap-6.1/standalone/deployments
11:49:43,230 INFO  [org.jboss.as.remoting] (MSC service thread 1-1) JBAS017100: Listening on 127.0.0.1:9999
11:49:43,231 INFO  [org.jboss.as.remoting] (MSC service thread 1-2) JBAS017100: Listening on 127.0.0.1:4447
11:49:43,267 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
11:49:43,268 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
11:49:43,268 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss EAP 6.1.1.GA (AS 7.2.1.Final-redhat-4) started in 206ms - Started 123 of 177 services (53 services are passive or on-demand)
11:49:47,519 INFO  [org.jboss.as.repository] (management-handler-thread - 1) JBAS014900: Content added at location /home/development/jbossqe/JBEAP-6.1.1-ER3/jboss-eap-6.1/standalone/data/content/5a/ad6ac47ebdca413454e5250ab0c2fa4fc9709b/content
11:49:47,523 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015876: Starting deployment of "CLIWebservicesWsdlPortTestCase.war" (runtime-name: "CLIWebservicesWsdlPortTestCase.war")
11:49:47,589 INFO  [org.jboss.ws.cxf.metadata] (MSC service thread 1-6) JBWS024061: Adding service endpoint metadata: id=org.jboss.test.ws.cli.AnnotatedServiceImpl
 address=http://jbossws.undefined.host:8080/CLIWebservicesWsdlPortTestCase/AnnotatedSecurityService
 implementor=org.jboss.test.ws.cli.AnnotatedServiceImpl
 serviceName={http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityService
 portName={http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityServicePort
 annotationWsdlLocation=null
 wsdlLocationOverride=null
 mtomEnabled=false
11:49:47,599 INFO  [org.apache.cxf.service.factory.ReflectionServiceFactoryBean] (MSC service thread 1-6) Creating Service {http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityService from class org.jboss.test.ws.cli.AnnotatedServiceIface
11:49:47,624 INFO  [org.apache.cxf.endpoint.ServerImpl] (MSC service thread 1-6) Setting the server's publish address to be http://jbossws.undefined.host:8080/CLIWebservicesWsdlPortTestCase/AnnotatedSecurityService
11:49:47,626 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC000001: Failed to start service jboss.deployment.unit."CLIWebservicesWsdlPortTestCase.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."CLIWebservicesWsdlPortTestCase.war".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment "CLIWebservicesWsdlPortTestCase.war"
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.1.Final-redhat-4.jar:7.2.1.Final-redhat-4]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_25]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_25]
	at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]
Caused by: java.lang.IllegalStateException
	at org.jboss.msc.value.InjectedValue.getValue(InjectedValue.java:47) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.as.webservices.config.ServerConfigImpl.getServerEnvironment(ServerConfigImpl.java:80)
	at org.jboss.as.webservices.config.ServerConfigImpl.getServerDataDir(ServerConfigImpl.java:58)
	at org.jboss.wsf.stack.cxf.deployment.WSDLFilePublisher.getPublishLocation(WSDLFilePublisher.java:161)
	at org.jboss.wsf.stack.cxf.deployment.WSDLFilePublisher.publishWsdlFiles(WSDLFilePublisher.java:69)
	at org.jboss.wsf.stack.cxf.deployment.EndpointImpl.publishContractToFilesystem(EndpointImpl.java:131)
	at org.jboss.wsf.stack.cxf.deployment.EndpointImpl.doPublish(EndpointImpl.java:71)
	at org.apache.cxf.jaxws.EndpointImpl.publish(EndpointImpl.java:250)
	at org.apache.cxf.jaxws.EndpointImpl.publish(EndpointImpl.java:536)
	at org.jboss.wsf.stack.cxf.configuration.NonSpringBusHolder.configure(NonSpringBusHolder.java:116)
	at org.jboss.wsf.stack.cxf.deployment.aspect.BusDeploymentAspect.startDeploymentBus(BusDeploymentAspect.java:128)
	at org.jboss.wsf.stack.cxf.deployment.aspect.BusDeploymentAspect.start(BusDeploymentAspect.java:67)
	at org.jboss.as.webservices.deployers.AspectDeploymentProcessor.deploy(AspectDeploymentProcessor.java:74)
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.1.Final-redhat-4.jar:7.2.1.Final-redhat-4]
	... 5 more

11:49:47,635 ERROR [org.jboss.as.server] (management-handler-thread - 1) JBAS015870: Deploy of deployment "CLIWebservicesWsdlPortTestCase.war" was rolled back with the following failure message: 
{"JBAS014671: Failed services" => {"jboss.deployment.unit.\"CLIWebservicesWsdlPortTestCase.war\".INSTALL" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"CLIWebservicesWsdlPortTestCase.war\".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment \"CLIWebservicesWsdlPortTestCase.war\"
    Caused by: java.lang.IllegalStateException"}}
11:49:47,641 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015877: Stopped deployment CLIWebservicesWsdlPortTestCase.war (runtime-name: CLIWebservicesWsdlPortTestCase.war) in 6ms


Additional info:
Comment 1 Petr Sakař 2013-09-11 01:40:37 EDT
fixed already in EAP-6.1.1.ER7

07:36:23,355 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss EAP 6.1.1.GA (AS 7.2.1.Final-redhat-10) started in 299ms - Started 123 of 177 services (53 services are passive or on-demand)

...



07:39:39,047 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015876: Starting deployment of "CLIWebservicesWsdlPortTestCase.war" (runtime-name: "CLIWebservicesWsdlPortTestCase.war")
07:39:39,347 INFO  [org.jboss.ws.cxf.metadata] (MSC service thread 1-4) JBWS024061: Adding service endpoint metadata: id=org.jboss.qa.management.ws.cli.AnnotatedServiceImpl
 address=http://jbossws.undefined.host:8080/CLIWebservicesWsdlPortTestCase/AnnotatedSecurityService
 implementor=org.jboss.qa.management.ws.cli.AnnotatedServiceImpl
 serviceName={http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityService
 portName={http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityServicePort
 annotationWsdlLocation=null
 wsdlLocationOverride=null
 mtomEnabled=false
07:39:39,598 INFO  [org.apache.cxf.service.factory.ReflectionServiceFactoryBean] (MSC service thread 1-4) Creating Service {http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityService from class org.jboss.qa.management.ws.cli.AnnotatedServiceIface
07:39:40,082 INFO  [org.apache.cxf.endpoint.ServerImpl] (MSC service thread 1-4) Setting the server's publish address to be http://jbossws.undefined.host:8080/CLIWebservicesWsdlPortTestCase/AnnotatedSecurityService
07:39:40,185 INFO  [org.jboss.ws.cxf.deployment] (MSC service thread 1-4) JBWS024074: WSDL published to: file:/home/development/jbossqe/JBEAP-6.1.1.ER7/jboss-eap-6.1/standalone/data/wsdl/CLIWebservicesWsdlPortTestCase.war/AnnotatedSecurityService.wsdl
07:39:40,188 INFO  [org.jboss.as.webservices] (MSC service thread 1-7) JBAS015539: Starting service jboss.ws.port-component-link
07:39:40,205 INFO  [org.jboss.as.webservices] (MSC service thread 1-5) JBAS015539: Starting service jboss.ws.endpoint."CLIWebservicesWsdlPortTestCase.war"."org.jboss.qa.management.ws.cli.AnnotatedServiceImpl"
07:39:40,218 INFO  [org.jboss.ws.common.management] (MSC service thread 1-5) JBWS022050: Endpoint registered: jboss.ws:context=CLIWebservicesWsdlPortTestCase,endpoint=org.jboss.qa.management.ws.cli.AnnotatedServiceImpl
07:39:40,241 INFO  [org.jboss.web] (ServerService Thread Pool -- 49) JBAS018210: Register web context: /CLIWebservicesWsdlPortTestCase
07:39:40,336 INFO  [org.jboss.as.server] (management-handler-thread - 1) JBAS018559: Deployed "CLIWebservicesWsdlPortTestCase.war" (runtime-name : "CLIWebservicesWsdlPortTestCase.war")
Comment 2 Paul Gier 2013-09-17 18:10:06 EDT
Moving to ON_QA based on psakar's comment.
Comment 3 Rostislav Svoboda 2013-09-20 08:14:46 EDT
Verified on EAP 620 ER2
Comment 7 Scott Mumford 2013-12-01 18:07:55 EST
Added release note text and marked for inclusion in 6.2 Release Notes document.

Note You need to log in before you can comment on or make changes to this bug.