Bug 988390 - Cursor broken until restart after installation of guest tools
Cursor broken until restart after installation of guest tools
Status: CLOSED DUPLICATE of bug 1025122
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Gal Hammer
Virtualization Bugs
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 09:37 EDT by Tomas Jamrisko
Modified: 2013-12-19 09:22 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 09:22:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2013-07-25 09:37:18 EDT
Description of problem:
Cursor behaves strangely after installing vdagent using rhev-guest-tools 

Version-Release number of selected component (if applicable):
at least rhev-guest-tools-iso-3.1-13; probably older
also in 3.2-12

How reproducible:
Always

Steps to Reproduce:
1. Setup a windows 7 guest
2. Install Tools 

Actual results:
Immediately after installation the cursor is broken

Additional info:
I don't remember this happening after installing the agent alone... could it be caused by virtio?
Comment 1 Gal Hammer 2013-07-28 10:15:34 EDT
Which version of qemu-kvm are you using? Could it be that this issue is related to bz#980752?
Comment 2 Gal Hammer 2013-07-28 10:26:08 EDT
Or could it be related to bz#981987? What is the spice service status after the upgrade (is it running?)? Thanks.
Comment 3 Lev Veyde 2013-07-28 10:32:37 EDT
(In reply to Tomas Jamrisko from comment #0)
> Description of problem:
> Cursor behaves strangely after installing vdagent using rhev-guest-tools 
> 
> Version-Release number of selected component (if applicable):
> at least rhev-guest-tools-iso-3.1-13; probably older
> also in 3.2-12
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. Setup a windows 7 guest
> 2. Install Tools 
> 
> Actual results:
> Immediately after installation the cursor is broken
> 
> Additional info:
> I don't remember this happening after installing the agent alone... could it
> be caused by virtio?


Hi Tomas,

3.1.13 should not be used. For 3.1 the current version of tools is 3.1.14.

But in any case even 3.1.13 should not cause such an issue during an ordinary install but only during an update from the previous version.

An install of 3.2.12 also should not cause this.

I was not able to reproduce this, can I get access to the VM(s) in question?

Thanks in advance,
Lev Veyde.
Comment 4 Tomas Jamrisko 2013-07-29 04:44:00 EDT
(In reply to Gal Hammer from comment #1)
> Which version of qemu-kvm are you using? Could it be that this issue is
> related to bz#980752?

qemu-kvm-rhev-0.12.1.2-2.295

Not sure about whether is it related, obviously different version of qemu, will update. And I don't experience any BSOD

(In reply to Gal Hammer from comment #2)
> Or could it be related to bz#981987? What is the spice service status after
> the upgrade (is it running?)? Thanks.

Both vdagent and vdservice are running. 


> 3.1.13 should not be used. For 3.1 the current version of tools is 3.1.14.

Happens with 3.1.14 as well.
Comment 6 Lev Veyde 2013-07-31 09:19:07 EDT
I reproduced the issue in QE env. It seems that the cursor still moves, but very very slowly.

It seems that stopping the services, disabling and then enabling the Virtio-Serial device (and then the Spice Agent) resolves the issue.
Comment 8 Tomas Jamrisko 2013-08-01 04:52:49 EDT
(In reply to Lev Veyde from comment #6)
> It seems that stopping the services, disabling and then enabling the
> Virtio-Serial device (and then the Spice Agent) resolves the issue.

You're right, disabling and then enabling the device again fixes the issue. Restarting the service alone doesn't help. 

Also yesterday you asked me about whether it fails when driver and agent are installed manually. It does. But it only fails if machine wasn't rebooted after installation of virtion (virtio -> reboot -> vdagent works fine)
Comment 9 Lev Veyde 2013-08-04 06:08:36 EDT
(In reply to Tomas Jamrisko from comment #8)
> (In reply to Lev Veyde from comment #6)
> > It seems that stopping the services, disabling and then enabling the
> > Virtio-Serial device (and then the Spice Agent) resolves the issue.
> 
> You're right, disabling and then enabling the device again fixes the issue.
> Restarting the service alone doesn't help. 
> 
> Also yesterday you asked me about whether it fails when driver and agent are
> installed manually. It does. But it only fails if machine wasn't rebooted
> after installation of virtion (virtio -> reboot -> vdagent works fine)

Thanks for the update.

So we certainly have an issue with Virtio-Serial device/driver that under some consequences works slow until reset.
Comment 11 Mike Cao 2013-08-20 08:42:29 EDT
lijin ,pls try to reproduce this issue on RHEM3.2
Comment 12 lijin 2013-08-21 06:12:03 EDT
(In reply to Mike Cao from comment #11)
> lijin ,pls try to reproduce this issue on RHEM3.2

Try to reproduce on RHEM3.2,with
virtio-win-1.6.5
qemu-kvm-rhev-0.12.1.2-2.375.el6.x86_64
kernel-2.6.32-369.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64
rhev-guest-tools-iso-3.1-13/rhev-guest-tools-iso-3.2-11/rhev-guest-tools-iso-3.2-12

QE hit this issue twice,both occurs after rhev-guest-tools installation on a brand new image,but after I choose restart to finish the installation,the cursor works well.And this never happened on the second/third installation.
Comment 13 yxu 2013-08-28 23:04:07 EDT
As far as I know, in virtio-0.1-59 , serial driver got some problem in system hibernation and resume situation , it will got a BSOD.

Yan has fixed this bug in virtio-0.1-65.

In 59 version , when firstly install the guest agent , service can't read serial normally .Thus the service can't run normally .

But in 65 version , when firstly install the guest agent , if the installation program run the service at once, the agent can't get any data from serial actually , but the agent start . And it got no problem.Without any data input into serial , the agent can't dispatch any mouse message. Thus your mouse broken .

My solution :
1, DONOT run the service when installation complete. 
2, suggest reboot after installation .


Of course , my solution is not so perfect. Can anyone solve the virtio-serial  BUG?

Here is some agent log :
version  59:
1760::INFO::2013-08-29 09:49:45,707::run::***Agent started in session 1***
1760::INFO::2013-08-29 09:49:45,707::log_version::0.5.1.0
1760::INFO::2013-08-29 09:49:45,707::consistent_displays::#qxls 0 #others 1
1760::INFO::2013-08-29 09:49:45,707::init_vio_serial::Failed opening \\.\Global\com.redhat.spice.0, error 2
2208::INFO::2013-08-29 09:49:48,718::run::***Agent started in session 1***
2208::INFO::2013-08-29 09:49:48,718::log_version::0.5.1.0
2208::INFO::2013-08-29 09:49:48,718::consistent_displays::#qxls 0 #others 1
2208::INFO::2013-08-29 09:49:48,718::init_vio_serial::Failed opening \\.\Global\com.redhat.spice.0, error 2
2920::INFO::2013-08-29 09:49:51,729::run::***Agent started in session 1***
2920::INFO::2013-08-29 09:49:51,729::log_version::0.5.1.0

version 65:
2860::INFO::2013-08-28 17:02:29,851::run::***Agent started in session 1***
2860::INFO::2013-08-28 17:02:29,851::log_version::0.5.1.0
2860::INFO::2013-08-28 17:02:29,851::consistent_displays::#qxls 0 #others 1
2860::INFO::2013-08-28 17:02:29,851::send_announce_capabilities::Sending capabilities:
2860::INFO::2013-08-28 17:02:29,851::send_announce_capabilities::B7
2860::INFO::2013-08-28 17:02:29,851::run::Connected to server
2860::INFO::2013-08-28 17:02:29,851::input_desktop_message_loop::Desktop: Default
2860::INFO::2013-08-28 17:02:29,851::input_desktop_message_loop::First display setting
2860::INFO::2013-08-28 17:02:29,851::load::loading display setting
2860::INFO::2013-08-28 17:02:29,851::load::open registry key: fail 2
Comment 14 Chao Yang 2013-09-12 23:04:18 EDT
Reproduced with:
qemu-kvm-rhev-0.12.1.2-2.398.el6.x86_64 
2.6.32-414.el6.x86_64
Comment 15 lijin 2013-09-13 04:49:33 EDT
QE can still reproduce this issue with:

rhev-guest-tools-iso-3.3-5.noarch
qemu-kvm-rhev-0.12.1.2-2.402.el6.x86_64
kernel-2.6.32-415.0.1.el6.x86_64
libvirt-0.10.2-18.el6_4.8.x86_64
vdsm-4.10.2-22.0.el6ev.x86_64
Comment 17 Gal Hammer 2013-11-03 09:19:48 EST
It looks like a duplicate of bz#1025122.
Comment 18 Gal Hammer 2013-12-19 09:22:23 EST
Closing as duplicate. Reopen if bug is still reproducible.

*** This bug has been marked as a duplicate of bug 1025122 ***

Note You need to log in before you can comment on or make changes to this bug.