Bug 988482 - gtk warnings on stderr on subscription-manager-gui startup
gtk warnings on stderr on subscription-manager-gui startup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-25 12:43 EDT by Adrian Likins
Modified: 2013-09-30 19:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:15:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2013-07-25 12:43:06 EDT
Description of problem:


[adrian@dhcp129-86 subscription-manager]$ sudo bin/subscription-manager-gui 

(subscription-manager-gui:18026): libglade-WARNING **: unknown property `has_tooltip' for class `GtkButton'

(subscription-manager-gui:18026): libglade-WARNING **: unknown property `has_tooltip' for class `GtkEventBox'

(subscription-manager-gui:18026): libglade-WARNING **: unknown property `primary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:18026): libglade-WARNING **: unknown property `secondary_icon_activatable' for class `GtkEntry'

(subscription-manager-gui:18026): libglade-WARNING **: unknown property `primary_icon_sensitive' for class `GtkEntry'

(subscription-manager-gui:18026): libglade-WARNING **: unknown property `secondary_icon_sensitive' for class `GtkEntry'


These are all gtk widget properties that don't exist on rhel5's gtk-2.10. 
None of them seem important, just stuff glade adds.
Comment 6 Sharath Dwaral 2013-08-05 14:31:47 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.8.16-1.el5
subscription-manager-debuginfo-1.8.16-1.el5
subscription-manager-migration-data-1.11.3.2-1.git.0.14f9d59.el5
subscription-manager-firstboot-1.8.16-1.el5
python-rhsm-1.8.16-1.el5
subscription-manager-migration-1.8.16-1.el5
python-rhsm-debuginfo-1.8.16-1.el5
subscription-manager-gui-1.8.16-1.el5


Verification:

Running subscription-mamager-gui from command line throws no warning anymore

VERIFIED
Comment 8 errata-xmlrpc 2013-09-30 19:15:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.