Bug 988623 - SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file INSTALL.
SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file INSTALL.
Status: CLOSED DUPLICATE of bug 988622
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1a058a44422ba1e372dd9f24d83...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 22:12 EDT by Devon Janitz
Modified: 2013-07-26 02:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 02:47:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devon Janitz 2013-07-25 22:12:57 EDT
Description of problem:
Joined Webex meeting and was wonder if this should be normal behavior due to bugs or something related to Webex itself.
SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file INSTALL.

*****  Plugin mozplugger (99.1 confidence) suggests  *************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests  ***************************

If you believe that rm should be allowed unlink access on the INSTALL file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep rm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                INSTALL [ file ]
Source                        rm
Source Path                   /usr/bin/rm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-65.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-302.fc19.x86_64 #1 SMP Sat
                              Jul 6 13:41:07 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-25 22:01:56 EDT
Last Seen                     2013-07-25 22:01:56 EDT
Local ID                      98fa484b-1d64-4751-9c1c-312e37963f10

Raw Audit Messages
type=AVC msg=audit(1374804116.875:631): avc:  denied  { unlink } for  pid=8289 comm="rm" name="INSTALL" dev="dm-2" ino=20447816 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file


type=SYSCALL msg=audit(1374804116.875:631): arch=x86_64 syscall=unlinkat success=yes exit=0 a0=ffffffffffffff9c a1=d950c0 a2=0 a3=100 items=0 ppid=8118 pid=8289 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=rm exe=/usr/bin/rm subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: rm,mozilla_plugin_t,user_home_t,file,unlink

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-302.fc19.x86_64
type:           libreport

Potential duplicate: bug 824095
Comment 1 Miroslav Grepl 2013-07-26 02:47:47 EDT

*** This bug has been marked as a duplicate of bug 988622 ***

Note You need to log in before you can comment on or make changes to this bug.