This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 988643 - [KDE] Libreoffice crashes while doing a "Save as" with a "QWidget::repaint: Recursive repaint detected" error
[KDE] Libreoffice crashes while doing a "Save as" with a "QWidget::repaint: R...
Status: CLOSED DUPLICATE of bug 977068
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 00:11 EDT by Vinu Moses
Modified: 2015-07-13 13:37 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 19:33:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Short video showing the crash (567.42 KB, image/gif)
2013-07-26 00:11 EDT, Vinu Moses
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 69002 None None None Never

  None (edit)
Description Vinu Moses 2013-07-26 00:11:52 EDT
Created attachment 778651 [details]
Short video showing the crash

Description of problem:
Libreoffice crashes every time I try to save a document with "Save as" with the following error "QWidget::repaint: Recursive repaint detected".

Version-Release number of selected component (if applicable):
libreoffice-writer-4.1.0.1-8.fc19.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1.Open a new libreoffice document and type a word or two into it.
2.Click on "Save as" to save the document. 
3. Move the mouse outside the "Save as" dialog


Actual results:
Libreoffice crashes with a "QWidget::repaint: Recursive repaint detected" error.

Expected results:
Libreoffice should save the file.

Additional info:
I'm able to reproduce this crash on multiple user accounts on two F19 boxes.
A short video showing the crash is enclosed.
Comment 1 Lukáš Tinkl 2013-08-05 07:54:28 EDT
Does it still happen with the latest version (here libreoffice-writer-4.1.0.4-5.fc19)?
Comment 2 Vinu Moses 2013-08-05 21:28:19 EDT
(In reply to Lukáš Tinkl from comment #1)
> Does it still happen with the latest version (here
> libreoffice-writer-4.1.0.4-5.fc19)?

Yes, it still does crash with the latest update, 
libreoffice-writer-4.1.0.4-5.fc19.x86_64.
Comment 3 Murz 2013-08-28 01:14:16 EDT
Confirm this issue on Ubuntu 12.04 with 4.1.0-0ubuntu1~precise1~ppa1 package too.
Comment 4 Kevin Kofler 2013-10-24 19:33:00 EDT

*** This bug has been marked as a duplicate of bug 977068 ***

Note You need to log in before you can comment on or make changes to this bug.