Bug 988857 - [RFE] Dist-geo-rep : geo rep status should show detail info. for recent sync performance in files/sec, bytes/sec.
[RFE] Dist-geo-rep : geo rep status should show detail info. for recent sync ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Aravinda VK
storage-qa-internal@redhat.com
status
: FutureFeature
: 1025949 (view as bug list)
Depends On:
Blocks: 994876
  Show dependency treegraph
 
Reported: 2013-07-26 11:00 EDT by Rachana Patel
Modified: 2016-01-13 03:14 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 994876 (view as bug list)
Environment:
Last Closed: 2016-01-13 03:14:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-26 11:00:53 EDT
Description of problem:
Dist-geo-rep : geo rep status should show detail info. for recent sync performance in files/sec, bytes/sec.

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta6-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Amar Tumballi 2013-08-01 05:49:04 EDT
reasons for taking down the 'blocker' flag:

We are currently (with the patches committed yesterday) showing 'pending size', 'pending files', 'pending deletes' etc... but the perf numbers asked in this bug will be shown with more of hooks to measure performance. Right now, the data whatever we show regarding performance, would be misleading, hence it would need little more time for testing/correcting the behaviors.
Comment 5 Sachidananda Urs 2013-08-12 07:58:52 EDT
Removing blocker flag, as per bug triage from Rich and Sayan.
Comment 6 Scott Haines 2013-09-27 13:08:02 EDT
Targeting for 3.0.0 (Denali) release.
Comment 15 Aravinda VK 2015-08-06 10:34:24 EDT
*** Bug 1025949 has been marked as a duplicate of this bug. ***
Comment 16 Aravinda VK 2016-01-13 03:14:18 EST
With this patch, Performance can be recorded for sync_engine=rsync(or use_tarssh=False)

http://review.gluster.org/#/c/10070/

This feature is already available in RHGS 3.1.0, Closing this bug. Please reopen if required again.

Note You need to log in before you can comment on or make changes to this bug.