Bug 988861 - subscription-manager-1.8 list --consumed throws traceback when installed on RHEL57
subscription-manager-1.8 list --consumed throws traceback when installed on R...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-26 11:12 EDT by John Sefler
Modified: 2014-09-14 20:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:15:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-07-26 11:12:10 EDT
Description of problem:
After cherry-picking subscription-manager-1.8 onto an older RHEL57 system, the following traceback is often thrown at the end of the output from subscription-manager calls.  Note that there is no obvious information in the rhsm.log to help identify the traceback.  Moreover the traceback is not always reproducible, However I have been able to consistently see it.  If it doesn't fail the first time, try again.

Traceback (most recent call last):
  File "/usr/lib64/python2.4/logging/handlers.py", line 71, in emit
    if self.shouldRollover(record):
  File "/usr/lib64/python2.4/logging/handlers.py", line 150, in shouldRollover
    self.stream.seek(0, 2)  #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file



Version-Release number of selected component (if applicable):
[root@rhsm-compat-rhel57 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription-manager: 1.8.14-1.el5
python-rhsm: 1.8.15-1.el5
[root@rhsm-compat-rhel57 ~]# rpm -q --whatprovides /usr/lib64/python2.4/logging/handlers.py
python-libs-2.4.3-44.el5



Steps to Reproduce:
[root@rhsm-compat-rhel57 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com:443/subscription --autosubscribe --username gss-test-11a
Password: 
The system has been registered with ID: c86c3b45-9e5d-4926-8ccd-e5aa5ceb2c34 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

Traceback (most recent call last):
  File "/usr/lib64/python2.4/logging/handlers.py", line 71, in emit
    if self.shouldRollover(record):
  File "/usr/lib64/python2.4/logging/handlers.py", line 150, in shouldRollover
    self.stream.seek(0, 2)  #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file
[root@rhsm-compat-rhel57 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Server, Premium
Provides:          Red Hat Enterprise Linux High Performance Networking (for
                   RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Server - Extended Update Support
                   Red Hat Enterprise Linux Server
                   Red Hat EUCJP Support (for RHEL Server) - Extended Update
                   Support
                   Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
                   - Extended Update Support
                   Red Hat Beta
                   Red Hat Software Collections (for RHEL Server)
                   Red Hat Enterprise Linux High Availability (for RHEL Server)
                   - Extended Update Support
                   Red Hat Enterprise Linux Scalable File System (for RHEL
                   Server) - Extended Update Support
                   Red Hat Software Collections Beta (for RHEL Server)
                   Red Hat Enterprise Linux Load Balancer (for RHEL Server) -
                   Extended Update Support
                   Red Hat S-JIS Support (for RHEL Server) - Extended Update
                   Support
SKU:               RH00003
Contract:          10024231
Account:           5226522
Serial:            4129306350133156123
Pool ID:           8a99f9843fcdf045013fe9067fa931b6
Active:            True
Quantity Used:     1
Service Level:     Premium
Service Type:      L1-L3
Status Details:    
Starts:            07/16/2013
Ends:              07/15/2014

Traceback (most recent call last):
  File "/usr/lib64/python2.4/logging/handlers.py", line 71, in emit
    if self.shouldRollover(record):
  File "/usr/lib64/python2.4/logging/handlers.py", line 150, in shouldRollover
    self.stream.seek(0, 2)  #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file
[root@rhsm-compat-rhel57 ~]# 
[root@rhsm-compat-rhel57 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        5.7
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         07/16/2013
Ends:           07/15/2014

Segmentation fault                     <=========  STRANGE (only observed once)
[root@rhsm-compat-rhel57 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        5.7
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         07/16/2013
Ends:           07/15/2014

[root@rhsm-compat-rhel57 ~]# 
[root@rhsm-compat-rhel57 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Server, Premium
Provides:          Red Hat Enterprise Linux High Performance Networking (for
                   RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Server - Extended Update Support
                   Red Hat Enterprise Linux Server
                   Red Hat EUCJP Support (for RHEL Server) - Extended Update
                   Support
                   Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
                   - Extended Update Support
                   Red Hat Beta
                   Red Hat Software Collections (for RHEL Server)
                   Red Hat Enterprise Linux High Availability (for RHEL Server)
                   - Extended Update Support
                   Red Hat Enterprise Linux Scalable File System (for RHEL
                   Server) - Extended Update Support
                   Red Hat Software Collections Beta (for RHEL Server)
                   Red Hat Enterprise Linux Load Balancer (for RHEL Server) -
                   Extended Update Support
                   Red Hat S-JIS Support (for RHEL Server) - Extended Update
                   Support
SKU:               RH00003
Contract:          10024231
Account:           5226522
Serial:            4129306350133156123
Pool ID:           8a99f9843fcdf045013fe9067fa931b6
Active:            True
Quantity Used:     1
Service Level:     Premium
Service Type:      L1-L3
Status Details:    
Starts:            07/16/2013
Ends:              07/15/2014

[root@rhsm-compat-rhel57 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Server, Premium
Provides:          Red Hat Enterprise Linux High Performance Networking (for
                   RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Server - Extended Update Support
                   Red Hat Enterprise Linux Server
                   Red Hat EUCJP Support (for RHEL Server) - Extended Update
                   Support
                   Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
                   - Extended Update Support
                   Red Hat Beta
                   Red Hat Software Collections (for RHEL Server)
                   Red Hat Enterprise Linux High Availability (for RHEL Server)
                   - Extended Update Support
                   Red Hat Enterprise Linux Scalable File System (for RHEL
                   Server) - Extended Update Support
                   Red Hat Software Collections Beta (for RHEL Server)
                   Red Hat Enterprise Linux Load Balancer (for RHEL Server) -
                   Extended Update Support
                   Red Hat S-JIS Support (for RHEL Server) - Extended Update
                   Support
SKU:               RH00003
Contract:          10024231
Account:           5226522
Serial:            4129306350133156123
Pool ID:           8a99f9843fcdf045013fe9067fa931b6
Active:            True
Quantity Used:     1
Service Level:     Premium
Service Type:      L1-L3
Status Details:    
Starts:            07/16/2013
Ends:              07/15/2014

Traceback (most recent call last):
  File "/usr/lib64/python2.4/logging/handlers.py", line 71, in emit
    if self.shouldRollover(record):
  File "/usr/lib64/python2.4/logging/handlers.py", line 150, in shouldRollover
    self.stream.seek(0, 2)  #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file




Actual results:
Results above show Traceback often but not every time.
Comment 1 John Sefler 2013-07-26 11:33:35 EDT
I was NOT able to reproduce this traceback on a RHEL58 system...
[root@rhsm-compat-rhel58 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: Unknown
subscription-manager: 1.8.14-1.el5
python-rhsm: 1.8.15-1.el5
[root@rhsm-compat-rhel58 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.8 (Tikanga)
[root@rhsm-compat-rhel58 ~]# rpm -q --whatprovides /usr/lib64/python2.4/logging/handlers.py
python-libs-2.4.3-46.el5
Comment 2 Adrian Likins 2013-07-26 13:29:57 EDT
How big is the log file on these systems? (ideally, near the time it fails)
Comment 3 Carter Kozak 2013-07-29 10:25:38 EDT
commit 59a50b96258a45ef6c82131cb40708adcd80916b
Author: ckozak <ckozak@redhat.com>
Date:   Fri Jul 26 16:45:54 2013 -0400

    988430, 988861: remove logging from write_cache to avoid segfault
Comment 10 John Sefler 2013-08-12 14:45:56 EDT
Verifying Version....

[root@rhsm-compat-rhel57 ~]# rpm -q redhat-release
redhat-release-5Server-5.7.0.3

[root@rhsm-compat-rhel57 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.8.19-1
subscription-manager: 1.8.19-1.el5_9
python-rhsm: 1.8.16-1.el5_9

[root@rhsm-compat-rhel57 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        5.7
Arch:           x86_64
Status:         Unknown
Status Details: 
Starts:         
Ends:   

[root@rhsm-compat-rhel57 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com:443/subscription --autosubscribe --username gss-test-11a
Password: 
The system has been registered with ID: c383ecb3-9ae1-4eda-aeb7-1ad50b31f740 
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

[root@rhsm-compat-rhel57 ~]# 
[root@rhsm-compat-rhel57 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        5.7
Arch:           x86_64
Status:         Subscribed
Status Details: 
Starts:         07/16/2013
Ends:           07/15/2014

[root@rhsm-compat-rhel57 ~]# 
[root@rhsm-compat-rhel57 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Server, Premium
Provides:          Red Hat Enterprise Linux High Performance Networking (for RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Server - Extended Update Support
                   Red Hat Enterprise Linux Server
                   Red Hat EUCJP Support (for RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Resilient Storage (for RHEL Server) - Extended Update Support
                   Red Hat Beta
                   Red Hat Software Collections (for RHEL Server)
                   Red Hat Enterprise Linux High Availability (for RHEL Server) - Extended Update Support
                   Red Hat Enterprise Linux Scalable File System (for RHEL Server) - Extended Update Support
                   Red Hat Software Collections Beta (for RHEL Server)
                   Red Hat Enterprise Linux Load Balancer (for RHEL Server) - Extended Update Support
                   Red Hat S-JIS Support (for RHEL Server) - Extended Update Support
SKU:               RH00003
Contract:          10024231
Account:           5226522
Serial:            6463577003887165096
Pool ID:           8a99f9843fcdf045013fe9067fa931b6
Active:            True
Quantity Used:     1
Service Level:     Premium
Service Type:      L1-L3
Status Details:    
Starts:            07/16/2013
Ends:              07/15/2014

[root@rhsm-compat-rhel57 ~]# 


Even after repeated transactions, the original traceback is no longer being thrown.
Moving to VERIFIED
Comment 12 errata-xmlrpc 2013-09-30 19:15:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.