Bug 988896 - [abrt] cinnamon-1.9.1-16.fc19: gray_find_cell: Process /usr/bin/cinnamon was killed by signal 11 (SIGSEGV)
[abrt] cinnamon-1.9.1-16.fc19: gray_find_cell: Process /usr/bin/cinnamon was ...
Status: CLOSED DUPLICATE of bug 678397
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
abrt_hash:cad87d01780dc786800ad9ae577...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 11:57 EDT by Mats Wichmann
Modified: 2013-09-02 10:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 10:45:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (193.42 KB, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: core_backtrace (12.66 KB, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: dso_list (18.71 KB, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: environ (1.71 KB, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: maps (81.14 KB, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: open_fds (4.59 KB, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: proc_pid_status (939 bytes, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details
File: var_log_messages (992 bytes, text/plain)
2013-07-26 11:57 EDT, Mats Wichmann
no flags Details

  None (edit)
Description Mats Wichmann 2013-07-26 11:57:00 EDT
Description of problem:
Sorry, no special instructions: logged in, got a crash message, had not had a chance to actually do anything yet myself.

Version-Release number of selected component:
cinnamon-1.9.1-16.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        cinnamon --sm-client-id 105468fee8a49903fc137365492923899800000047360000
crash_function: gray_find_cell
executable:     /usr/bin/cinnamon
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: Window manager warning: Log level 16: cinnamon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 gray_find_cell at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:481
 #1 gray_record_cell at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:511
 #2 gray_set_cell at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:554
 #3 gray_render_line at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:814
 #4 gray_render_conic at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:946
 #5 gray_conic_to at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:1157
 #6 FT_Outline_Decompose at /usr/src/debug/freetype-2.4.11/src/base/ftoutln.c:206
 #7 gray_convert_glyph_inner at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:1736
 #8 gray_convert_glyph at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:1838
 #9 ft_smooth_render_generic at /usr/src/debug/freetype-2.4.11/src/smooth/ftsmooth.c:316

Potential duplicate: bug 879411
Comment 1 Mats Wichmann 2013-07-26 11:57:05 EDT
Created attachment 778813 [details]
File: backtrace
Comment 2 Mats Wichmann 2013-07-26 11:57:08 EDT
Created attachment 778814 [details]
File: cgroup
Comment 3 Mats Wichmann 2013-07-26 11:57:13 EDT
Created attachment 778815 [details]
File: core_backtrace
Comment 4 Mats Wichmann 2013-07-26 11:57:16 EDT
Created attachment 778816 [details]
File: dso_list
Comment 5 Mats Wichmann 2013-07-26 11:57:21 EDT
Created attachment 778817 [details]
File: environ
Comment 6 Mats Wichmann 2013-07-26 11:57:24 EDT
Created attachment 778818 [details]
File: limits
Comment 7 Mats Wichmann 2013-07-26 11:57:27 EDT
Created attachment 778819 [details]
File: maps
Comment 8 Mats Wichmann 2013-07-26 11:57:33 EDT
Created attachment 778820 [details]
File: open_fds
Comment 9 Mats Wichmann 2013-07-26 11:57:37 EDT
Created attachment 778821 [details]
File: proc_pid_status
Comment 10 Mats Wichmann 2013-07-26 11:57:40 EDT
Created attachment 778822 [details]
File: var_log_messages
Comment 11 Steve Tyler 2013-07-28 11:06:17 EDT
cell is a pointer variable, but cell = 0x2, which is not a pointer value:

Core was generated by `cinnamon --sm-client-id 105468fee8a49903fc137365492923899800000047360000'.
Program terminated with signal 11, Segmentation fault.
#0  0x0000003c2d45a5bf in gray_find_cell (worker=0x7f5f50048410) at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:481
481	      if ( cell == NULL || cell->x > x )

Thread 12 (Thread 0x7f5f61c26700 (LWP 3196)):
#0  0x0000003c2d45a5bf in gray_find_cell (worker=0x7f5f50048410) at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:481
        pcell = <optimized out>
        cell = 0x2
        x = 3

This could be a threading problem, because Thread 1 has the same worker pointer and is executing the same code:

Thread 1 (Thread 0x7f5f949c0a40 (LWP 3017)):
#0  0x0000003c2d45a5bf in gray_find_cell (worker=0x7f5f50048410) at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:481
        pcell = <optimized out>
        cell = 0x2
        x = 3
Comment 12 Steve Tyler 2013-07-28 11:46:35 EDT
If we work our way up the stack in Thread 12, we find gtkicontheme.c:
(See also Bug 969669, Comment 22)

Thread 12 (Thread 0x7f5f61c26700 (LWP 3196)):
#0  0x0000003c2d45a5bf in gray_find_cell (worker=0x7f5f50048410) at /usr/src/debug/freetype-2.4.11/src/smooth/ftgrays.c:481
...
#54 0x0000003d95f5e52e in load_icon_thread (task=0x66ae1b0, source_object=<optimized out>, task_data=<optimized out>, cancellable=<optimized out>) at gtkicontheme.c:3594
...
Comment 13 Steve Tyler 2013-07-28 12:40:14 EDT
(In reply to Steve Tyler from comment #12)
> If we work our way up the stack in Thread 12, we find gtkicontheme.c:
...

Oops, that is referring to a different backtrace for an exception in gray_find_cell in gnome-shell:

Bug 956269 - [abrt] gnome-shell-3.8.1-1.fc19: gray_find_cell: Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)

There are several bug reports for exceptions in gray_find_cell in gnome-shell:

https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&classification=Fedora&list_id=1568685&o1=substring&product=Fedora&query_format=advanced&short_desc=gray_find_cell&short_desc_type=allwordssubstr

Sorry about the confusion, I was trying to show that this is not a cinnamon problem ...
Comment 14 Michael Schwendt 2013-09-02 10:45:13 EDT

*** This bug has been marked as a duplicate of bug 678397 ***

Note You need to log in before you can comment on or make changes to this bug.