Bug 988912 - mate-bluetooth should not depend on mate-notification-daemon
mate-bluetooth should not depend on mate-notification-daemon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-bluetooth (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks: depchain
  Show dependency treegraph
 
Reported: 2013-07-26 13:07 EDT by Christoph Wickert
Modified: 2013-08-10 16:02 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-bluetooth-1.6.0-5.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-10 16:01:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2013-07-26 13:07:12 EDT
Description of problem:
mate-notification-daemon should not depend on mate-notification-daemon but use the virtual provides desktop-notification-daemon (provided by gnome-shell, kde-runtime, mate-notification-daemon, notification-daemon and xfce4-notifyd)

Version-Release number of selected component (if applicable):
1.6.0-3.fc20
Comment 1 Christoph Wickert 2013-07-26 13:14:09 EDT
BTW: Is mate-file-manager-sendto really required?
Comment 2 Wolfgang Ulbrich 2013-07-26 19:02:51 EDT
(In reply to Christoph Wickert from comment #0)
> Description of problem:
> mate-notification-daemon should not depend on mate-notification-daemon but
> use the virtual provides desktop-notification-daemon (provided by
> gnome-shell, kde-runtime, mate-notification-daemon, notification-daemon and
> xfce4-notifyd)
> 
> Version-Release number of selected component (if applicable):
> 1.6.0-3.fc20

Agree, i will follow your hint.

(In reply to Christoph Wickert from comment #1)
> BTW: Is mate-file-manager-sendto really required?

mate-file-manager-sendto-devel is a needed build require.
Comment 3 Wolfgang Ulbrich 2013-07-26 20:28:28 EDT
Ok, forget my last comment.
mate-file-manager-sendto is also a runtime require.
But i don't want to force MATE user to install this package by hand, because this package is needed to have send file function from caja.
And in the end this package is designed to use with MATE and not for xfce/lxde.
If a xfce/lxde user want to use it than he have to live with the consquences.
Personaly i don't understand why a xfce/lxde users don't use blueman which works brilliant.
Comment 4 Fedora Update System 2013-07-27 08:13:55 EDT
mate-bluetooth-1.6.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-4.fc18
Comment 5 Fedora Update System 2013-07-27 08:14:05 EDT
mate-bluetooth-1.6.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-4.fc19
Comment 6 Fedora Update System 2013-07-27 08:14:15 EDT
mate-bluetooth-1.6.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-4.fc17
Comment 7 Fedora Update System 2013-07-27 21:04:39 EDT
Package mate-bluetooth-1.6.0-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-bluetooth-1.6.0-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13744/mate-bluetooth-1.6.0-4.fc19
then log in and leave karma (feedback).
Comment 8 Christoph Wickert 2013-07-28 05:38:40 EDT
Not sure if you need to push an update for all releases, I think F17 could be omitted.

(In reply to Wolfgang Ulbrich from comment #3)
> mate-file-manager-sendto is also a runtime require.

Not it's not really a requirement of mate-bluetooth but of mate-file-manager. It enhances the file manager, not mate-bluetooth.

> But i don't want to force MATE user to install this package by hand, because
> this package is needed to have send file function from caja.

You won't force MATE users. You continue to ship %{_libdir}/caja-sendto/plugins/libnstbluetooth.so but omit the dependency on mate-file-manager. MATE users will automatically benefit from the additional functionality because they have mate-file-manager-sendto installed. Other users will not benefit and therefor they should not be forced to install mate-file-manager and all it's dependencies. Where is the problem?

The only thing you need to change is the %files section: Instead of
%{_libdir}/caja-sendto/plugins/libnstbluetooth.so
you would use
%{_libdir}/caja-sendto/
to make sure there are no unowned directories.

> And in the end this package is designed to use with MATE and not for
> xfce/lxde.

It can work perfectly with thunar and pcmanfm, both have their own "Sent to" implementations. I really see no reason to make live harder for Xfce and LXDE users.

> If a xfce/lxde user want to use it than he have to live with the consquences.
> Personaly i don't understand why a xfce/lxde users don't use blueman which
> works brilliant.

No it doesn't. NetworkManager integration doesn't, it's full of bugs and effectively unmaintened upstream.
Comment 9 Wolfgang Ulbrich 2013-07-28 06:59:18 EDT
Christoph,
%{_libdir}/caja-sendto/ should owned by mate-file-manager-sendto, libnstbluetooth.so is only one plugin from 7 or 8.
Without mate-file-manager-sendto installed,  mate-bluetooth installs %{_libdir}/caja-sendto/plugins/libnstbluetooth.so in a unowned directory.

Adding mate-file-manager-sendto as runtime require to mate-file-manager is only a solution for Mate. In xfce you installed %{_libdir}/caja-sendto/plugins/libnstbluetooth.so in a unowned directory.

Let us talk at irc.
Comment 10 Christoph Wickert 2013-07-28 12:35:27 EDT
If two different packages place files in the same directory but do not strictly require each other, it's perfectly fine to use duplicate ownership of both packages. Have a look at https://fedoraproject.org/wiki/Packaging:Guidelines#File_and_Directory_Ownership
We are dealing with case number 3 here: "The directory is owned by a package which is not required for your package to function". All binaries from mate-bluetooth work fine without caja, so this is an extension to add additional functionality. And it add this functionality to mate-file-manager, not to mate-bluetooth.
Comment 11 Wolfgang Ulbrich 2013-07-28 14:54:04 EDT
(In reply to Christoph Wickert from comment #10)
> If two different packages place files in the same directory but do not
> strictly require each other, it's perfectly fine to use duplicate ownership
> of both packages. Have a look at
> https://fedoraproject.org/wiki/Packaging:
> Guidelines#File_and_Directory_Ownership
> We are dealing with case number 3 here: "The directory is owned by a package
> which is not required for your package to function". All binaries from
> mate-bluetooth work fine without caja, so this is an extension to add
> additional functionality. And it add this functionality to
> mate-file-manager, not to mate-bluetooth.
Hope that "The directory is owned by a package
> which is not required for your package to function" is not only theory and also works in practice in this case. ;)
But this solution minimize the comfort for mate users (extra install of mate-file-manager-sendto is needed for sending files with caja) and fix the real problem 'xfce doesn't have a own bluetooth application'.

But this shouldn't be a prob MATE fedora Team if you're willing to add yourself to watch bugzilla for mate-bluetooth. ;)
Because sending files from smartphone to desktop is broken, see https://bugzilla.redhat.com/show_bug.cgi?id=967458  .
Also i'm expected issues which are related to xfce, my experience with compiz and xfce users implies that.
So i expected more work if a lot of xfce user install mate-bluetooth, and I'm seriously not willing to shoulder this extra work alone. ;)

Deal or not?
Comment 12 Wolfgang Ulbrich 2013-07-28 14:59:06 EDT
(In reply to Christoph Wickert from comment #10)
> If two different packages place files in the same directory but do not
> strictly require each other, it's perfectly fine to use duplicate ownership
> of both packages. Have a look at
> https://fedoraproject.org/wiki/Packaging:
> Guidelines#File_and_Directory_Ownership
> We are dealing with case number 3 here: "The directory is owned by a package
> which is not required for your package to function". All binaries from
> mate-bluetooth work fine without caja, so this is an extension to add
> additional functionality. And it add this functionality to
> mate-file-manager, not to mate-bluetooth.

Hope that "The directory is owned by a package
which is not required for your package to function" is not only theory and also works in practice in this case. ;)
But this solution minimize the comfort for mate users (extra install of mate-file-manager-sendto is needed for sending files with caja) and fix the real problem 'xfce doesn't have a own bluetooth application'.

But this shouldn't be a prob MATE fedora Team if you're willing to add yourself to watch bugzilla for mate-bluetooth. ;)
Because sending files from smartphone to desktop is broken, see https://bugzilla.redhat.com/show_bug.cgi?id=967458  .
Also i'm expected issues which are related to xfce, my experience with compiz and xfce users implies that.
So i expected more work if a lot of xfce user install mate-bluetooth, and I'm seriously not willing to shoulder this extra work alone. ;)

Deal or not?
Comment 13 Christoph Wickert 2013-07-28 15:47:06 EDT
(In reply to Wolfgang Ulbrich from comment #11)

> But this solution minimize the comfort for mate users (extra install of
> mate-file-manager-sendto is needed for sending files with caja)

That's what comps is for. Nobody can expect a MATE desktop with all it's features by installing a few random packages. Either use yum groupinstall or install exactly what you want/need.

> and fix the
> real problem 'xfce doesn't have a own bluetooth application'.

This needs to be solved upstream. Let's focus on what we can fix in Fedora.

> But this shouldn't be a prob MATE fedora Team if you're willing to add
> yourself to watch bugzilla for mate-bluetooth. ;)
> Because sending files from smartphone to desktop is broken, see
> https://bugzilla.redhat.com/show_bug.cgi?id=967458  .

It's not broken, it's just not enabled by default. I just commented in that bug, hope it helps.

This is another example of a case where hard requirements don't help much. In order to configure receiving files, you need mate-file-share-properties. This means one needs to install mate-user-share, which then pulls in httpd and a lot of other packages. So in the end, a user who just wants for example the NetworkManager support ends up with tons of irrelevant packages. These kind of dependencies where one package enhances another should be handled in comps.

(Some day rpm will be able to handle that, but that's still years away.)

> Also i'm expected issues which are related to xfce, my experience with
> compiz and xfce users implies that.
> So i expected more work if a lot of xfce user install mate-bluetooth, and
> I'm seriously not willing to shoulder this extra work alone. ;)
>
> Deal or not?

I'm sorry, I already have a lot of work on my shoulders and I cannot really maintain something I don't use. I help where I can, just like in bug 967458, so fee free to ask me whenever you need help. But please understand that I will not incur any additional debts. Thanks.
Comment 14 Fedora Update System 2013-08-01 07:11:04 EDT
mate-bluetooth-1.6.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-5.fc18
Comment 15 Fedora Update System 2013-08-01 07:11:21 EDT
mate-bluetooth-1.6.0-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-5.fc19
Comment 16 Wolfgang Ulbrich 2013-08-01 07:18:39 EDT
(In reply to Christoph Wickert from comment #13)
> (In reply to Wolfgang Ulbrich from comment #11)
> 
> > But this solution minimize the comfort for mate users (extra install of
> > mate-file-manager-sendto is needed for sending files with caja)
> 
> That's what comps is for. Nobody can expect a MATE desktop with all it's
> features by installing a few random packages. Either use yum groupinstall or
> install exactly what you want/need.
> 
> > and fix the
> > real problem 'xfce doesn't have a own bluetooth application'.
> 
> This needs to be solved upstream. Let's focus on what we can fix in Fedora.
> 
> > But this shouldn't be a prob MATE fedora Team if you're willing to add
> > yourself to watch bugzilla for mate-bluetooth. ;)
> > Because sending files from smartphone to desktop is broken, see
> > https://bugzilla.redhat.com/show_bug.cgi?id=967458  .
> 
> It's not broken, it's just not enabled by default. I just commented in that
> bug, hope it helps.
> 
> This is another example of a case where hard requirements don't help much.
> In order to configure receiving files, you need mate-file-share-properties.
> This means one needs to install mate-user-share, which then pulls in httpd
> and a lot of other packages. So in the end, a user who just wants for
> example the NetworkManager support ends up with tons of irrelevant packages.
> These kind of dependencies where one package enhances another should be
> handled in comps.
> 
> (Some day rpm will be able to handle that, but that's still years away.)
> 
> > Also i'm expected issues which are related to xfce, my experience with
> > compiz and xfce users implies that.
> > So i expected more work if a lot of xfce user install mate-bluetooth, and
> > I'm seriously not willing to shoulder this extra work alone. ;)
> >
> > Deal or not?
> 
> I'm sorry, I already have a lot of work on my shoulders and I cannot really
> maintain something I don't use. I help where I can, just like in bug 967458,
> so fee free to ask me whenever you need help. But please understand that I
> will not incur any additional debts. Thanks.

Wrong answer, but MATE do not care.
Comment 17 Fedora Update System 2013-08-10 16:01:40 EDT
mate-bluetooth-1.6.0-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-08-10 16:02:49 EDT
mate-bluetooth-1.6.0-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.