Bug 988976 - seamonkey tries to use user configured proxy even if system proxy settings is selected
seamonkey tries to use user configured proxy even if system proxy settings is...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: seamonkey (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 16:14 EDT by Hin-Tak Leung
Modified: 2013-08-08 23:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 17:25:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2013-07-26 16:14:55 EDT
Description of problem:
since upgraded to seamonkey 2.19 a few days ago, accessing any urls no longer works.

Version-Release number of selected component (if applicable):
seamonkey-2.19-1.fc19.x86_64
(xulrunner-22.0-4.fc19.x86_64
xulrunner-22.0-4.fc19.i686)


How reproducible:
Always, see additional info for background details/workaround.

Steps to Reproduce:
1. start seamonkey
2.
3.

Actual results:
cannot access any url. no error, just timeout.

Expected results:
should work.

Additional info:
After suffering this problem for a few days while lynx works, I noticed from netstat that seamonkey is trying to access the stale proxy setting from nearly 10 years ago.

So it looks like seamonkey inherited the firefox 22 bug, but haven't got the fix for some reason (maybe due to a built-in xulrunner equivalent, rather than using the system one).

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1194841
https://bugzilla.redhat.com/show_bug.cgi?id=978782
https://bugzilla.mozilla.org/show_bug.cgi?id=817533

Switch the proxy setting from "using system proxy setting" to "direct connection to internet" works around this problem.
Comment 1 Hin-Tak Leung 2013-07-26 16:18:09 EDT
I have the newer xulrunner from the fix to Bug 978782, but in any case, seasmonkey does not seem to depend on xulrunner, so likely it has its own copy, or something; but seamonkey 2.19 certainly has a firefox 22 gecko rendering engine, and from the work-around, the bug seems the same, but the fix is not.
Comment 2 Dmitry Butskoy 2013-08-08 17:25:13 EDT
This bug should be fixed in the latest released Firefox-23.

Since Seamonkey-2.20 shares the code with Firefox-23, we hope that seamonkey-2.20 does fix it as well.

Seamonkey-2.20 should appear soon in updates-testing and in updates after a week.

Reopen this bug if the problem still exist with the version of 2.20
Comment 3 Hin-Tak Leung 2013-08-08 23:15:01 EDT
Actually thunderbird also has a private copy of libxul.so, besides seamonkey - so it looks like firefox is the only one using xulrunner's:

$ locate libxul.so | xargs ls -l
-rwxr-xr-x. 1 root root 46751792 Jul  9 12:39 /usr/lib64/seamonkey/libxul.so
-rwxr-xr-x. 1 root root 40978384 Jun 25 13:21 /usr/lib64/thunderbird/libxul.so
lrwxrwxrwx. 1 root root       30 Jul 13 23:22 /usr/lib64/xulrunner-devel-22.0/sdk/lib/libxul.so -> /usr/lib64/xulrunner/libxul.so
-rwxr-xr-x. 1 root root 40787552 Jul  1 17:32 /usr/lib64/xulrunner/libxul.so
-rwxr-xr-x. 1 root root 36742104 Jul  1 17:53 /usr/lib/xulrunner/libxul.so

Note You need to log in before you can comment on or make changes to this bug.