Bug 989035 - Add a missing requirement on crontabs for the cron job to the spec file
Add a missing requirement on crontabs for the cron job to the spec file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: requires-crontabs
  Show dependency treegraph
 
Reported: 2013-07-26 21:15 EDT by Jóhann B. Guðmundsson
Modified: 2013-07-27 05:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-27 02:47:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file fixes patch (1.34 KB, patch)
2013-07-26 21:16 EDT, Jóhann B. Guðmundsson
no flags Details | Diff

  None (edit)
Description Jóhann B. Guðmundsson 2013-07-26 21:15:49 EDT
Description of problem:

Please update your package according to the packing guidelines
http://fedoraproject.org/wiki/Packaging:CronFiles
Thanks


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2013-07-26 21:16:18 EDT
Created attachment 778950 [details]
Spec file fixes patch
Comment 2 Jiri Popelka 2013-07-27 02:47:59 EDT
I removed [1] it in 3.13.6 because we haven't shipped /etc/cron.daily/hplip_cron since then. Why do you think it's still needed ?

[1] http://pkgs.fedoraproject.org/cgit/hplip.git/commit/?id=098fac3992b7e722c6ab2e4c221aedd17f67b4ca
Comment 3 Jóhann B. Guðmundsson 2013-07-27 05:49:43 EDT
(In reply to Jiri Popelka from comment #2)
> I removed [1] it in 3.13.6 because we haven't shipped
> /etc/cron.daily/hplip_cron since then. Why do you think it's still needed ?

Basically because I generated the list of affected components ( around 100 in total 30 of which will potentially be migrated to timer units )  in February after devconf and I'm only really look at the header ( change version number and add the requirement ) and the footer ( add the changelog entry ).

Deep spec file inspection takes longer time than to simply generate the patch and later have it closed like you did here. So it's more efficient doing it this way.

Note You need to log in before you can comment on or make changes to this bug.