Bug 947037 - (requires-crontabs) TRACKER: Fix missing dependency for packages shipping cron job files on crontab
TRACKER: Fix missing dependency for packages shipping cron job files on crontab
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vokal
Radek Vokal
: FutureFeature, Tracking
Depends On: 947040 947045 947047 947058 947066 947136 988602 988605 988609 989020 989021 989023 989024 989031 989032 989033 989034 989035 989037 989039 989072 989073 989074 989075 989076 989077 989079 989080 989082 989085 989089 989090 989095 989102 989107 989109 989110 989113 989114 989115 989119 989121 989122 989123 989125 989126 989127 989128
Blocks: 1076445
  Show dependency treegraph
 
Reported: 2013-04-01 05:58 EDT by Jóhann B. Guðmundsson
Modified: 2014-04-23 08:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 08:59:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2013-04-01 05:58:03 EDT
Tracker bug for fixing missing dependency on crontabs with the following changes to FPG as approved here [1]

1. https://fedorahosted.org/fpc/ticket/261
Comment 1 Jaroslav Reznik 2013-09-16 04:47:35 EDT
Adding Tracking, FutureFeature keywords to avoid rawhide -> f20 rebase of this bug.
Comment 4 Jóhann B. Guðmundsson 2014-04-23 08:59:14 EDT
I have formally retracted this feature since FPC members are under the assumption that it is fine to introduce a new package or a sub package and have that sub package depend on systemd when neither that nor the original package contained systemd units or otherwise has or had an existing hard dependency on systemd.

In other words they have chosen to introduce an dependency on systemd where there should be none which at that point you could just as well migrate everything from cron to systemd unit which requires a completely different implementation ( thus completely differently constructed section in the guidelines ) and is absolutely not the intention of my proposal since cron is not 1 to 1 replacement for systemd.

Cronie has it's purpose for those components that do not depend on systemd as well as serving administrative and end users cron jobs handler and we should keep it that way since both components ( systemd-timers and cronie ) complement each other. 

But since FPC are such experts on how this should be implemented in the distribution it's best to allow them to do just that as well as observer how and what they themselves will actually migrated and leave Red Hat to clean up that mess they will leave behind in RHEL 8 and it will start affecting RHEL customers. 

Good luck!

Note You need to log in before you can comment on or make changes to this bug.