Bug 989040 - AttributeError: 'F18_Url' object has no attribute 'partition'
AttributeError: 'F18_Url' object has no attribute 'partition'
Status: CLOSED DUPLICATE of bug 986069
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:e9f201dd262d5a98f00c47db887...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 21:36 EDT by Joachim Frieben
Modified: 2013-07-29 10:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 10:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (677.53 KB, text/plain)
2013-07-26 21:36 EDT, Joachim Frieben
no flags Details
File: anaconda.log (8.75 KB, text/plain)
2013-07-26 21:36 EDT, Joachim Frieben
no flags Details
File: environ (461 bytes, text/plain)
2013-07-26 21:36 EDT, Joachim Frieben
no flags Details
File: lsblk_output (2.20 KB, text/plain)
2013-07-26 21:36 EDT, Joachim Frieben
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-07-26 21:36 EDT, Joachim Frieben
no flags Details
File: os_info (297 bytes, text/plain)
2013-07-26 21:37 EDT, Joachim Frieben
no flags Details
File: program.log (119.03 KB, text/plain)
2013-07-26 21:37 EDT, Joachim Frieben
no flags Details
File: storage.log (525.56 KB, text/plain)
2013-07-26 21:37 EDT, Joachim Frieben
no flags Details
File: ifcfg.log (2.98 KB, text/plain)
2013-07-26 21:37 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2013-07-26 21:36:27 EDT
Description of problem:
I launched anaconda and confirmed "I accept my fate.''.

Version-Release number of selected component:
anaconda-20.3-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 51, in __getattr__
    return getattr(self.handler.url, name)
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 76, in __getattr__
    return FC3_Method.__getattr__(self, name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 71, in setup
    osimg = storage.devicetree.getDeviceByPath(self.data.method.partition)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 671, in payloadInitialize
    payload.setup(storage)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'F18_Url' object has no attribute 'partition'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-20-Nightly-x86_64-Live-de rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc2.git3.1.fc20.x86_64
other involved packages: python-libs-2.7.5-3.fc20.x86_64, pykickstart-1.99.34-1.fc20.noarch
product:        Fedora
release:        Fedora release 20 (Rawhide)
type:           anaconda
version:        rawhide
Comment 1 Joachim Frieben 2013-07-26 21:36:41 EDT
Created attachment 778954 [details]
File: anaconda-tb
Comment 2 Joachim Frieben 2013-07-26 21:36:46 EDT
Created attachment 778955 [details]
File: anaconda.log
Comment 3 Joachim Frieben 2013-07-26 21:36:50 EDT
Created attachment 778956 [details]
File: environ
Comment 4 Joachim Frieben 2013-07-26 21:36:55 EDT
Created attachment 778957 [details]
File: lsblk_output
Comment 5 Joachim Frieben 2013-07-26 21:36:59 EDT
Created attachment 778958 [details]
File: nmcli_dev_list
Comment 6 Joachim Frieben 2013-07-26 21:37:03 EDT
Created attachment 778959 [details]
File: os_info
Comment 7 Joachim Frieben 2013-07-26 21:37:09 EDT
Created attachment 778960 [details]
File: program.log
Comment 8 Joachim Frieben 2013-07-26 21:37:20 EDT
Created attachment 778961 [details]
File: storage.log
Comment 9 Joachim Frieben 2013-07-26 21:37:25 EDT
Created attachment 778962 [details]
File: ifcfg.log
Comment 10 David Shea 2013-07-29 10:34:47 EDT

*** This bug has been marked as a duplicate of bug 986069 ***

Note You need to log in before you can comment on or make changes to this bug.