Bug 989052 - [abrt] parole-0.5.1-1.fc19: g_type_create_instance: Process /usr/bin/parole was killed by signal 11 (SIGSEGV)
[abrt] parole-0.5.1-1.fc19: g_type_create_instance: Process /usr/bin/parole w...
Status: CLOSED DUPLICATE of bug 972567
Product: Fedora
Classification: Fedora
Component: parole (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:94e43fa064f53a6d7a5e9794abf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 04:01 EDT by Michael Schwendt
Modified: 2013-07-27 04:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-27 04:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.16 KB, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: core_backtrace (1.55 KB, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: dso_list (11.29 KB, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: environ (1.37 KB, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: maps (52.98 KB, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: open_fds (628 bytes, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: proc_pid_status (925 bytes, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details
File: var_log_messages (458 bytes, text/plain)
2013-07-27 04:01 EDT, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2013-07-27 04:01:09 EDT
Description of problem:
1) I've removed ~/.config/xfce4/ and trying to start parole again causes a segfault. Always. 
2) It seems I need to kill ~/.local/share/xfce4/ too. Parole starts again.
3) Adding a music file, restarting Parole, it segfaults.

Those steps are reproducible here.

There is only ~/.local/share/xfce4/parole/auto-saved-playlist.m3u which looks okay and can be loaded with Audacious.

Version-Release number of selected component:
parole-0.5.1-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        parole
crash_function: g_type_create_instance
executable:     /usr/bin/parole
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (8 frames)
 #0 g_type_create_instance at gtype.c:1906
 #1 g_object_constructor at gobject.c:1855
 #4 gtk_window_new at gtkwindow.c:1380
 #5 parole_player_init at parole-player.c:3142
 #6 g_type_create_instance at gtype.c:1917
 #7 g_object_constructor at gobject.c:1855
 #9 g_object_new_valist at gobject.c:1836
 #11 parole_player_new at parole-player.c:3173
Comment 1 Michael Schwendt 2013-07-27 04:01:14 EDT
Created attachment 778987 [details]
File: backtrace
Comment 2 Michael Schwendt 2013-07-27 04:01:16 EDT
Created attachment 778988 [details]
File: cgroup
Comment 3 Michael Schwendt 2013-07-27 04:01:20 EDT
Created attachment 778989 [details]
File: core_backtrace
Comment 4 Michael Schwendt 2013-07-27 04:01:23 EDT
Created attachment 778990 [details]
File: dso_list
Comment 5 Michael Schwendt 2013-07-27 04:01:26 EDT
Created attachment 778991 [details]
File: environ
Comment 6 Michael Schwendt 2013-07-27 04:01:29 EDT
Created attachment 778992 [details]
File: limits
Comment 7 Michael Schwendt 2013-07-27 04:01:33 EDT
Created attachment 778993 [details]
File: maps
Comment 8 Michael Schwendt 2013-07-27 04:01:36 EDT
Created attachment 778994 [details]
File: open_fds
Comment 9 Michael Schwendt 2013-07-27 04:01:39 EDT
Created attachment 778995 [details]
File: proc_pid_status
Comment 10 Michael Schwendt 2013-07-27 04:01:42 EDT
Created attachment 778996 [details]
File: var_log_messages
Comment 11 Michael Schwendt 2013-07-27 04:04:28 EDT

*** This bug has been marked as a duplicate of bug 972567 ***

Note You need to log in before you can comment on or make changes to this bug.