Bug 972567 - [abrt] parole-0.5.1-1.fc19: type_class_init_Wm: Process /usr/bin/parole was killed by signal 11 (SIGSEGV)
[abrt] parole-0.5.1-1.fc19: type_class_init_Wm: Process /usr/bin/parole was k...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parole (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:55b1f1554c2ce2ab95581c3d8cf...
:
: 972395 989052 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 02:00 EDT by Heiko Adams
Modified: 2013-09-10 21:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: parole-0.5.2-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 19:28:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (40.97 KB, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: core_backtrace (1.71 KB, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: dso_list (10.57 KB, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: environ (1.26 KB, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: maps (49.81 KB, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: open_fds (831 bytes, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: proc_pid_status (940 bytes, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: var_log_messages (644 bytes, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details
File: xsession_errors (32.45 KB, text/plain)
2013-06-10 02:00 EDT, Heiko Adams
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 10166 None None None Never

  None (edit)
Description Heiko Adams 2013-06-10 02:00:08 EDT
Description of problem:
Started parole with activated "remember playlist" setting

Version-Release number of selected component:
parole-0.5.1-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        parole
crash_function: type_class_init_Wm
executable:     /usr/bin/parole
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 type_class_init_Wm at gtype.c:2171
 #1 g_type_class_ref at gtype.c:2959
 #3 g_object_new_valist at gobject.c:1797
 #5 _gtk_tray_icon_new at gtktrayicon-x11.c:816
 #6 gtk_status_icon_init at gtkstatusicon.c:848
 #7 g_type_create_instance at gtype.c:1917
 #8 g_object_constructor at gobject.c:1855
 #9 gtk_status_icon_constructor at gtkstatusicon.c:963
 #12 gtk_status_icon_new at gtkstatusicon.c:1188
 #13 tray_provider_set_player at tray-provider.c:366
Comment 1 Heiko Adams 2013-06-10 02:00:14 EDT
Created attachment 759041 [details]
File: backtrace
Comment 2 Heiko Adams 2013-06-10 02:00:17 EDT
Created attachment 759042 [details]
File: cgroup
Comment 3 Heiko Adams 2013-06-10 02:00:20 EDT
Created attachment 759043 [details]
File: core_backtrace
Comment 4 Heiko Adams 2013-06-10 02:00:24 EDT
Created attachment 759044 [details]
File: dso_list
Comment 5 Heiko Adams 2013-06-10 02:00:27 EDT
Created attachment 759045 [details]
File: environ
Comment 6 Heiko Adams 2013-06-10 02:00:30 EDT
Created attachment 759046 [details]
File: limits
Comment 7 Heiko Adams 2013-06-10 02:00:36 EDT
Created attachment 759047 [details]
File: maps
Comment 8 Heiko Adams 2013-06-10 02:00:40 EDT
Created attachment 759048 [details]
File: open_fds
Comment 9 Heiko Adams 2013-06-10 02:00:43 EDT
Created attachment 759049 [details]
File: proc_pid_status
Comment 10 Heiko Adams 2013-06-10 02:00:46 EDT
Created attachment 759050 [details]
File: var_log_messages
Comment 11 Heiko Adams 2013-06-10 02:00:51 EDT
Created attachment 759051 [details]
File: xsession_errors
Comment 12 Heiko Adams 2013-06-10 02:02:11 EDT
*** Bug 972395 has been marked as a duplicate of this bug. ***
Comment 13 Michael Schwendt 2013-06-13 08:12:19 EDT
Indeed.
Comment 14 Fedora Update System 2013-07-26 16:52:25 EDT
parole-0.5.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/parole-0.5.2-1.fc19
Comment 15 Fedora Update System 2013-07-26 16:53:07 EDT
parole-0.5.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/parole-0.5.2-1.fc18
Comment 16 Heiko Adams 2013-07-27 03:00:50 EDT
Bug is fixed. Thanks
Comment 17 Michael Schwendt 2013-07-27 04:00:54 EDT
Doesn't work for me yet. First I thought, it would not crash anymore, but it segfaults again and doesn't start.

  $ rpm -q parole
  parole-0.5.1-1.fc19.x86_64

Here, it saves the playlist, but removing entries from the playlist or emptying the entire playlist, then quitting Parole, upon restarting it, the old playlist reappears with warnings about failing to find the music files here:

> TagLib: Could not open file /home/ms19f/.local/share/xfce4/parole/…

Trying to clean up the config files:

* I've removed ~/.config/xfce4/ and trying to start parole again causes a segfault. Always. 
* ABRT is working on reporting that.
* It seems I needed to kill ~/.local/share/xfce4/ too. Parole starts again.
* Adding a music file, restarting Parole, it segfaults.
Comment 18 Michael Schwendt 2013-07-27 04:01:37 EDT
New bug id: 989052
Comment 19 Michael Schwendt 2013-07-27 04:02:39 EDT
D'oh! The test update is still pending.
Comment 20 Michael Schwendt 2013-07-27 04:04:28 EDT
*** Bug 989052 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2013-07-27 21:06:54 EDT
Package parole-0.5.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parole-0.5.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13750/parole-0.5.2-1.fc19
then log in and leave karma (feedback).
Comment 22 Fedora Update System 2013-09-02 19:28:19 EDT
parole-0.5.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2013-09-10 21:56:26 EDT
parole-0.5.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.