Bug 989103 - Add proper keymap for Samsung Series 5 and Series 5 Ultra
Add proper keymap for Samsung Series 5 and Series 5 Ultra
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
: 989101 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 10:55 EDT by Mauro Carvalho Chehab
Modified: 2013-10-21 17:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 17:38:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
keymap file for Samsung i5 ultra (508 bytes, text/plain)
2013-07-27 10:57 EDT, Mauro Carvalho Chehab
no flags Details
dmidecode info of the notebook (20.20 KB, text/plain)
2013-07-27 10:59 EDT, Mauro Carvalho Chehab
no flags Details
/lib/udev/keymaps/samsung-series-5 (655 bytes, text/plain)
2013-07-29 00:14 EDT, Mauro Carvalho Chehab
no flags Details
/lib/udev/keymaps/force-release/samsung-series-5 (308 bytes, text/plain)
2013-07-29 00:15 EDT, Mauro Carvalho Chehab
no flags Details
/lib/udev/rules.d/95-keymap.rules (13.12 KB, text/plain)
2013-07-29 00:16 EDT, Mauro Carvalho Chehab
no flags Details
/lib/udev/keymaps/force-release/samsung-series-5 (193 bytes, text/plain)
2013-07-29 05:39 EDT, Mauro Carvalho Chehab
no flags Details
/lib/udev/rules.d/95-keyboard-force-release.rules (3.94 KB, text/plain)
2013-07-29 05:40 EDT, Mauro Carvalho Chehab
no flags Details

  None (edit)
Description Mauro Carvalho Chehab 2013-07-27 10:55:35 EDT
Description of problem:

The keymap table for Samsung i5 Ultra models are wrong.

Version-Release number of selected component (if applicable):

systemd-204-9.fc19.x86_64

How reproducible:

Try to press the function keys, like Fn + F12 (Wlan) and check that several of them don't produce any scancode at all.


Steps to Reproduce:
1. Boot
2. Press Fn keys

Actual results:

Several keys don't produce the expected results (Fn+F1, Fn+F11, Fn+F12, Fn Lock)

Expected results:

All keys should produce a scancode.
Additional info:
Comment 1 Mauro Carvalho Chehab 2013-07-27 10:57:36 EDT
Created attachment 779104 [details]
keymap file for Samsung i5 ultra

In order to trigger this keymap table, the following udev rule is needed:

ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*530U3C*", RUN+="keymap $name samsung-i5-ultra"
Comment 2 Mauro Carvalho Chehab 2013-07-27 10:59:51 EDT
Created attachment 779105 [details]
dmidecode info of the notebook
Comment 3 Mauro Carvalho Chehab 2013-07-27 11:01:43 EDT
*** Bug 989101 has been marked as a duplicate of this bug. ***
Comment 4 Mauro Carvalho Chehab 2013-07-29 00:14:18 EDT
Created attachment 779596 [details]
/lib/udev/keymaps/samsung-series-5
Comment 5 Mauro Carvalho Chehab 2013-07-29 00:15:20 EDT
Created attachment 779598 [details]
/lib/udev/keymaps/force-release/samsung-series-5
Comment 6 Mauro Carvalho Chehab 2013-07-29 00:16:49 EDT
Created attachment 779608 [details]
/lib/udev/rules.d/95-keymap.rules

New 95-keymap.rules with Samsung series 5 DMI data
Comment 8 Mauro Carvalho Chehab 2013-07-29 05:39:21 EDT
Created attachment 779708 [details]
/lib/udev/keymaps/force-release/samsung-series-5

Not all Fn keys need software keyup. Update the force-release
Comment 9 Mauro Carvalho Chehab 2013-07-29 05:40:57 EDT
Created attachment 779709 [details]
/lib/udev/rules.d/95-keyboard-force-release.rules
Comment 10 Lennart Poettering 2013-09-12 15:47:56 EDT
Looks like something where Martin Pitt might be able to help. Adding to CC. Martin?
Comment 11 Martin Pitt 2013-09-16 15:29:23 EDT
Thanks for those!

I translated those to the new-style hwdb format and pushed to http://cgit.freedesktop.org/systemd/systemd/commit/?id=6e1452d6

Note that I left out the key codes of these two, as they already appear to be covered in your kernel patches; I just kept the "force release" bit:

0xA8 0x225		# Fn Lock - Function lock on
0xA9 0x226		# Fn Lock - Function lock off
Comment 12 Fedora Update System 2013-09-17 14:52:27 EDT
systemd-204-14.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/systemd-204-14.fc19
Comment 13 Mauro Carvalho Chehab 2013-09-17 16:10:41 EDT
(In reply to Lennart Poettering from comment #10)
> Looks like something where Martin Pitt might be able to help. Adding to CC.
> Martin?

Lennart, thanks for forwarding it to Martin!

(In reply to Martin Pitt from comment #11)
> Thanks for those!
> 
> I translated those to the new-style hwdb format and pushed to
> http://cgit.freedesktop.org/systemd/systemd/commit/?id=6e1452d6

Thanks, Martin!

> Note that I left out the key codes of these two, as they already appear to
> be covered in your kernel patches; I just kept the "force release" bit:
> 
> 0xA8 0x225		# Fn Lock - Function lock on
> 0xA9 0x226		# Fn Lock - Function lock off

Agreed, better to keep only the force release there, at least for now.
Comment 14 Fedora Update System 2013-09-18 08:58:12 EDT
Package systemd-204-14.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-204-14.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16988/systemd-204-14.fc19
then log in and leave karma (feedback).
Comment 15 Zbigniew Jędrzejewski-Szmek 2013-10-21 17:38:54 EDT
Hm, this has been in stable as part for a while. I guess it hasn't been marked as closed because the update was obsoleted.

Note You need to log in before you can comment on or make changes to this bug.